Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Maestro Audio drop out.

henrylance Member ✭✭
edited May 2020 in Maestro

Hello everyone.  I have been trying to resolve a Audio Drop Out problem, for about the past 2 weeks.

I have a Flex 6500, that I purchased used in Oct. and a Maestro, that I bought used in mid Oct.  Both have worked wonderfully without a hitch, till abt two weeks ago.

What happens is that the Maestro drops all audio after a random period of time, maybe 20 to 30 min plus.  The Flex has been used 95 % of the time for FT8 normally at abt 25 watts.  The drop out happens while using the built in speaker, and/or an outboard speaker.  All the Flex software is up to date, and the settings on the Maestro are correct ( DAX, master vol, AGC-T, etc. )  Thinking it might be a software glitch, I deleted all the programs, and their original downloads, and re-downloaded everything.  Doesn’t matter if I run the Maestro via Wi-Fi, or Ethernet.

Interesting that if I use the SmartSDR GUI on the computer(s), I have not had any dropouts.  I had the Flex 6500 running on FT8 today and stepped out of the house for 3 hours, and when I came back in, it was still running fine, and audio was fine. 

Interesting that when the audio drops, the screen still shows a signals(s), but audio to a program ( WSJT-X or maybe FLDIGI ), lose the audio to the program(s), sometimes, not always.  Usually a shut down of the Maestro, will resolve the matter, but it will do it again, just a matter of time. 

Only thing new is MicroSoft with their updates, which they have been doing for several weeks now, but I do make sure to restart the computer a few times after updates, before running any program. 

MS OS is the latest version of Windoze 10, on two different computers.

The problem happens on both computers. 

One computer is a fairly recent Samsung that was just into the MicroSoft store in Charlotte NC.  It was wiped totally clean, and brought up to current specs.  A clean Slate, that now only has ham radio programs, period.  With all the programs running I need, the CPU usage is abt 35 %, with 4 gb of ram. 

The other computer is an Apple Mac Mini with a Intel 2.6 I5 processor, 16 gb of Ram, and 500 gb SSD drive.

I do not use ( or even like Parallels ).  Windows sits in its own little 100 gb separate partition, and is brought up using Bootcamp, and restarting the computer.   Really have had no issues with Windows on the Mac.  Again the Windows partition is 100 % ham related, not other ****.

The only thing I have not done, because until someone says it’s, OK, is to pull the battery inside the Maestro.  Its sort of grasping at straws, but I have seen many electronic products in which that solves issues.

Any Ideas  ?? Help  ?? I hate to have to send the unit back to Flex.

Be easy with me.  I’m getting old, and I’m a Apple OS guy.  Left Windows in 2009, with no regrets, so MicroSoft is now a foreign thing to me 

Thanks,  Lance  L  k4wh  Clover  SC


  • k3Tim
    k3Tim Member ✭✭✭
    edited May 2020
    This sounds like identical problem as posted :


    A restart of the Maestro network setting returned the audio, according to a follow up post by Martin.

    A guess would be the UDP is dropping / sequence error and is not recovered. 
    Haven't seen this problem but do not have enough Maestro time to rule it out.

  • Butch
    Butch Member ✭✭✭
    edited November 2018
    Lance - Reference: "Doesn’t matter if I run the Maestro via Wi-Fi, or Ethernet."  When you say "Ethernet" are you talking about a direct Ethernet connection between your Maestro and Flex, or a direct (hardwired) Ethernet connection between your Flex and Router?  If your audio drop-out problem is occurring across multiple computers, perhaps the problem is your Router.  My suggestion is to first ensure there's nothing wrong with Maestro or Flex, or if you might have SmartSDR DAX driver issues.  Connect your Maestro directly to your Flex with an Ethernet cable and see if you still experience audio drop-out. 
  • Ric KV1W
    Ric KV1W Member
    edited January 2018

    I have had this problem for some time. Seems to happen with the Maestro on same network and also with the Maestro on a RaspberryPi VPN. Nothing I have tried so far resulted in a repeatable occurrence. Was every half hour or so, but yesterday all day without a single event.
    Dropping the network and reconnecting solves it, but I did notice an ocurance of no CW sidetone after reconnecting.

    At the moment I am 100 miles remote so can't run locally until spring.

    I am suspecting long average latency or small occurance of very high RTT. Am watching it now after only 15 minutes up with RTT below 50 msec but highest of 1638 msec still running fine.

    Will keep trying

    Ric KV1W

  • Ric KV1W
    Ric KV1W Member
    edited January 2018

    had one instance of loosing CW sidetone even thought rx audio remained

    Definitely a loss of state somehow in the Maestro or radio remote "stuff".

  • Ric KV1W
    Ric KV1W Member
    edited February 2018

    I have been trying for over a month to find conditions that cause drop out, but with no success.

    Here's what I have seen:

         RX audio drops out but all else is OK and TX audio is OK on SSB

        Waterfall and spectrum display freeze, but audio is OK, haven't gotten to try TX audio for this case

         In CW, side tone stops working, but all else OK

    In all cases, breaking the network connection, such as just pulling the RJ45 Ethernet and then plugging back in will restore full function.

    Almost like some one of several parallel streams stops and won't come back until the initial connection is re-established.
    I have no way to know if this is the way the architecture works, but the symptoms make it seem so.

    Hope this gets to TIM and is of help. I can't think of anything else to do at this point.

    I am running over a VPN via RaspberryPi control at each end, but not sure that is relevant.
    In May when the Maestro again reside next to the 6500, I can see if this does it also.

    My assumption is that some parallel stream in failing and doesn't recover on its own until the whole is re-established, and this may be more of an issue on VPN than direct on the same network.

    What do you think Tim???? Please let me know yo got this message.

    Ric  KV1W

  • Ric KV1W
    Ric KV1W Member
    edited February 2018
    BTW Tim, I am running the latest

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.