Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Remote operation with I-Pad not working

I have an I-Pad setup for Smart SDR remote. It works at home with the Wifi but will not Discover when Im at the shop away from home. The icon just keeps going in a circle and the its Discovering...
It registers ok but thats as far as it goes.

Completed · Last Updated

Comments

  • Chris DL5NAMChris DL5NAM Member
    edited April 3
    Check an other Wifi access point. Some access points block functions.

    Had today same problem. My iPad was connected via FreiFunk router. After i change to another Wifi it works

    73 Chris
    DL5NAM

  • Marcus-DL8MREMarcus-DL8MRE Company Adviser
    edited December 2019
    Hi Don,

    just a few notes / questions so far:

    - Please note: You are seeing "Discover" because you might still have "LAN mode" to "Discover". This is fine and no problem and just means you can use either mode "SmartLink" and "LAN" at the same time. However, when tracking down SmartLink issues, I would suggest to turn "LAN mode" to "Off" and only "Enable SmartLink" to "On". Later, if the problems get solved, you can turn both back on.

    - There are known issues with T-Mobile. T-Mobile sometimes only provides IPv6 connections but the Radio and SmartLink requires an IPv4 connection. Besides this, there is no known issue of using SmartLink.

    - This said (and given you are not using T-Mobile) I would assume this might be an issue with your SmartLink setup. Do you think you have setup SmartLink correctly and have you had any chance to test SmartLink so far?

    73,
    Marcus, DL8MRE


  • Don StefanikDon Stefanik Member
    edited December 2017
    (I have not tested Smart Link at home. I did try testing it before this router change but could not get hooked up. Thinking it was the router problem I didnt bother testing once we got the new router installed and working.)

    I had Ham who is an IT come over Sunday and installed a new router tp-link 1750 and Wifi Extender tp-link re450 . (Router is upstairs, extender down in the shack. ) we got the Lan hooked up to the 6300.  Laptop, Desktop, and I-Pad then all connected and worked.  If I want the BIG screen I use the desktop LOL. But most times the laptop is used for the 6300.
    My connection sometimes goes very weak on the Laptop. I might get an extender for the Laptop.
    Now here in the shop we have the Asus1200 dual band.
    I did as you suggested and turned off the Lan on the I-Pad and tried it again but no joy.
    Execulink here in town and it is cable. 30mbs.
  • Ken HansenKen Hansen Member ✭✭
    edited December 2019
    I have issues using iOS app remotely, I am able to use Windows client remotely from the same remote location, but I can't get my iPhone/iPad to link. What I'd like to see is specific settings to use on iOS app. As a fall back I may put the Flex on an available public static IP I have, but I haven't done that yet.
  • Marcus-DL8MREMarcus-DL8MRE Company Adviser
    edited December 2019
    Don, it really sounds as if SmartLink isn't setup completely for being used from your Shop but if you get help on Sunday, that's great and he will be able to sort everything out.

    There are several very good documents regarding SmartLink on the FlexRadio website. Maybe you can point him to these Documents and he will know what to do.

    Also, just in case you don't know, there is also a Manual for my App (http://go-to.me/smartsdr-manual) which also covers SmartLink in a few chapters.

    A few hints you may want to pass on as well:

    - If you extend your WiFi, ensure you are using one and the same subnet (IP Address range), otherwise the FlexRadio will not work on your network

    - For SmartLink, ideally you can use UPnP on your router. You may need to enable it in some routers in order to use it. In this case, you can use SmartLink in Automatic mode. 

    - If you can't or don't want to use UPnP, then you need to open and pass through one UDP and one TCP Port from the internet through to your Radio. For setting up SmartLink, you then need to use the "Manual" mode and enter exactly these two ports.

    - Whenever you do any of the above changes/setups, from my experience, it is necessary to restart the Radio once again.

    Hope this helps.


  • Marcus-DL8MREMarcus-DL8MRE Company Adviser
    edited December 2017
    In general, there is technically no difference between the Windows Client and iOS Client. Both connect the same way to the Radio which can be one of the following options:

    1.) Local on your home network (but keep in mind that the iPad uses WiFi to connect to your network and if it doesn't work the most common reason is that WiFi isn't setup right for a Radio connection.)

    2.) Remote by using SmartLink - but SmartLink need to be setup and running.

    3.) Remote by using a VPN - but then, you will have to have your VPN Client configured on your iPad

    So if you say your Windows Client is working, it should work the same way on the iPad, assuming the VPN or SmartLink setup has been completed on your iPad.

    I also like to point you to the various manuals available on the FlexRadio website which are covering this subject as well as my Manual for my App  (http://go-to.me/smartsdr-manual) which also covers SmartLink in a few chapters and a "Common issues" section at the end.

    Hope this helps.

    73,
    Marcus, DL8MRE
  • Don StefanikDon Stefanik Member
    edited December 2017
    It was last Sunday that he was out. Anyways when I get home tonight I will check the Smartlink to see if it's working properly.
    Thanks everyone. Love the remote I-Pad ...not sure about the the XYL feels. :( 
  • WX7YWX7Y Member ✭✭
    edited June 11
    On your IPAD, try logging out of Smartlink then log back in using your SmartLink credentials that you set up on your computer when you registered the radio on SmartLink.

    I just tried my IPAD and it wouldn't find the radio on the Verizon network until I logged out and back into SmartLink on the IPAD.

    hope this helps
    Bret
    WX7Y

  • Don StefanikDon Stefanik Member
    edited December 2017
    Still no workie. :( 
  • WX7YWX7Y Member ✭✭
    edited December 2017
    On your local computer connected to the same network as the radio bring up SmartSDR and on the first screen when it shows "Smartlink setup"   un-register, then when that is done re-register SmartLink, this will require you to Key the PTT on the radio it self.
    Then try to log-out and back in on your IPAD. 
    If this does not work then something on your network the IPAD is on may have issues and is blocking your connection. 

    Bret
    WX7Y
  • Don StefanikDon Stefanik Member
    edited December 2017
    Ok. Will try that when I get home.
    Right now sitting in the shop waiting for the debit machine to download updates..............................dialup. Want to set it up for Ethernet. Having issues with this too. **** no luck with all this stuff today!!!!

  • David Decoons, wo2xDavid Decoons, wo2x Member ✭✭✭
    edited December 2017
    Don

    Try re-registering your radio for SmartLink from SmartSDR for Windows. Where it says Network settings click on the down arrow to the left of the word Network. In the bottom left is a button labeled TEST. CLick on it and make sure you get a green indicator. This will tell you if the router has the proper ports forwarded to the radio.

    Once that is established go on to troubleshoot SSDR for IOS.

    Dave wo2x

  • Don StefanikDon Stefanik Member
    edited December 2017
    ok. Got home and tried the I-Pad here and it wouldn't connect. Went and re-registered the Smartlink and got it to work. So I will see when I go into to work tomorrow if it works.
    Thanks to all those that helped me out.
    Don VA3KBC
  • Don StefanikDon Stefanik Member
    edited December 2017
    AARRGGGGGGGGGGGG. This morning it would not link up. Nothing changed other than turning everything off last night. Re-registered etc. I-Pad wont turn come on when I tap the screen. Flex 6300 comes up but when I tap it nothing.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited December 2017
    Your work network may be blocking the iPad from access the SmartLink server
  • David Decoons, wo2xDavid Decoons, wo2x Member ✭✭✭
    edited December 2017
    What do you mean by nothing? Does SmartSDR for IOS open? If so go to the. Settings tab and click on Check SmartLink status. It should return OK. If it does go to the main screen and try and tap but hold your finger on the screen a little longer when you tap. I find on my iPad if Am too quick it does not see the tap. Try what I suggested first and let us know results. Dave wo2x
  • Don StefanikDon Stefanik Member
    edited December 2017
    SmartLink opens and the icon shows the flexradio6300 there. But when I click on it it goes back to the main screen . I even try clicking on it slowly or hold it and nothing happens but goes back to the  main screen. where it says to tap to open.
  • David Decoons, wo2xDavid Decoons, wo2x Member ✭✭✭
    edited December 2017
    Did you do what I suggested last night when re-registering the radio? When in the registration screen click the down arrow to the left of the word Network. There is a button called TEST. Click it and see if it comes up green. I will be around today I am not sure where you are located. Email me direct at wo2x AT arrl DOT net I would be willing to work with you direct. Including setting up my radio for a guest SmartLink account so we can tell if it an issue at your shack or remote location. I will look for your email. Dave wo2x
  • Don StefanikDon Stefanik Member
    edited December 2017
    Yes did that last night and then had 2 flexradio6300 come up. 1 smartlink and the other plain. Cilcked on the smartlink and it worked. But this morning it wouldnt. I did the reregisre and test all was good but no smartlink showed.
  • Don StefanikDon Stefanik Member
    edited December 2017
    OK. Thanks Dave. When i get home tonight I will send you an email to setup something up. Really appreciate all the support from you guys.
  • Don StefanikDon Stefanik Member
    edited December 2017
    Southern Ontario Canada.

    https://www.qrz.com/db/VA3KBC
  • David Decoons, wo2xDavid Decoons, wo2x Member ✭✭✭
    edited December 2017
    ok, sounds good. I have unlimited calling to Canada on my home phone so it will make this easier.

    from what you describe, it does sound like your work network is blocking communications. we can test from your home network to my radio. 

    Dave wo2x
  • Don StefanikDon Stefanik Member
    edited December 2017
    ok...face in palm. :(   Just got home and the first thing I thought of was the easiest thing to try. I rebooted the router. End of story. Works on I-pad, PC, and what I mainly use. The Laptop. 
    Thanks again to all those that were helping out.
    DON
    VA3KBC
  • David Decoons, wo2xDavid Decoons, wo2x Member ✭✭✭
    edited December 2017
    Excellent! At least you have it working now.

    Dave wo2x

  • Don StefanikDon Stefanik Member
    edited December 2017
    In the shop and listening to 7 Meters on my I-Pad via SmartLink.  :):) 

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.