Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Can I make Expert 1.3k or 1.5k work without DDUTIL?

I am currently operating an Alpha 9500 with my remote Flex 6300 setup.

I have a 6400 on order, so the answer has to work for both a 6300 and the new 6400.  I know, nobody outside of Flex has seen it, but still...

The manual for the Expert amp emphasizes, in a way that the Alpha manual does not, that while it cant detect RF and do an automatic band switch, it really, really doesn't want to do that.  The Alpha doesn't care (probably because it's tubes and tubes don't care as much).  I've run it for years without issue; when I forget to change bands, it does it for me, no fuss that I can detect.

Now, when I check around the forum, the obvious response is to simply deploy DDUTIL.  I have never done so.  I have no inherent objection, but I have a VNC display, so screen real estate is at a premium as is bandwidth.  I am not on version 2 and am unsure, in any event, whether a true remote will offer me any significant relief on the bandwidth issue.  I'm running fine with remoterig and VNC today and expect to do so at least some of the time tomorrow.

Is there a way to do this without DDUTIL?   If I run it, what do I have to monitor there, or should I be monitoring somethign else?  The Alpha's little program is very nice, doesn't take up too much screen real estate, and enables complete remote control and status.  I need the Expert, with or without DDUTIL, to do the same.

It appears, also, that the necessary control cable isn't quite right.  If I have to make my own after all, what, exactly, is the schematic for it?  I am able to barely do soldering, so a vague reference to so-and-so a pin isn't quite enough for me.  I want to know what pin from what interface goes where.

Advise?
«1

Answers

  • RiaRia Member ✭✭
    edited November 2019
    I made a guide for it.

    http://www.n2rj.com/2016/12/flex-radio-1108-beta-and-serial-port.html

    9 pin (Radio via FTDI) -------->  15P (Amp)
    Pin 2 (RXD)     ------------------>  Pin 9 (TXD)
    Pin 3 (TXD)     ------------------>  Pin 1 (RXD)
    Pin 5 (Ground) ------------------>  Pin 4 (Ground)

    I also solder the drain wire to the shield for additional RF immunity and to prevent ground loops.

    Note that CAT control is exclusively through the 15 pin interface on the amp. 

    You need a genuine FTDI USB to serial adapter for the radio. 

    The USB cable from the amp should be connected to a Windows PC which allows you to use the control panel software, and it does NOT provide any CAT control.
  • Lawrence Kellar KB5ZZBLawrence Kellar KB5ZZB Member ✭✭
    edited November 2017
    Yes you can. Just set cat up on amp for “flex”. Then use a usb to serial dongle hooked between the amp and radio to get band data. Starting a few versions back flex started letting us get band data directly from the radio.... no more ddutil needed. I prefer to operate like this. In my opinion it is one less point of failure. I know others here feel differently but you can use your amp sans ddutil. I operate my 2k-fa and 1.3k-fa like this on my flex radios
  • Mark_WS7MMark_WS7M Member ✭✭
    edited November 2019
    Hi Larry,

    I use an SPE 2K-FA with Flex 6500 without DDUTIL.

    Here is how:

    I use a USB to serial cable between the amp and 6500.  In the 6500 I set the cable up for the SPE.  The SPE is setup for Flex CAT control.

    This achieves the band switching automatically.  It also sets your power level based on what you configure the amp to want for drive level.

    Now for remote on/off and control you have two choices:

    1)  Use a USB over network thing like virtual here (see www.virtualhere.com) to make the USB port available over the internet.  If you set that up correctly then you can use the SPE console USB program from anywhere and have 100% control over the amp.  This is what I do.

    2) You can use a remote relay switch like: https://dlidirect.com/products/din-relay-iv   Configure one of the relays to supply +12V to the SPE amp remote on (its in the cat connector).  Then configure your SPE amp to come up in the enabled state.

    In mode #2 you will only have on/off control of the amp using the web relay.  But if you configure things right that might be enough.  When I use an iPad I use this mode.  With the iPad I do the following:

    1) Turn off the amp
    2) On the iPad SSDR I tune - This lets my antenna tuner tune with low power
    3) I turn on the amp.  It comes up enabled and ready to run.

    Since the USB-serial cat connection is handling band switching you are simply good to go but if you change bands and need to tune you should turn the amp back off again so your tuner can tune under lower power.

    If you want to use the tuner in the SPE amp itself then you will most likely need to operate using option 1.

    Option 1 works well with a remote computer but does not work well on an iPad since the SPE console software will not run on an iPad.

    These options work very well.  Very reliable as long as you know how to setup your firewall to allow the signals and devices to work over the internet.  

    In fact as I type this I am at work, I have SSDR on my radio at home running on my work computer.  I have the SPE amp turned on and was trying to work some DX.  

    This is by no means as integrated as the Power Genius will be but it is workable.

    Mark - WS7M
  • Ron MorganRon Morgan Member
    edited November 2017
    Follow Ria’s advice as I did. You can always add more features if you need them. My amp tracts frequency, automatically sets the power level and gives me on screen control. I only use one USB FTDI DB-9 cable and an adapter to the DB15 cable on the Expert. It’s a beautiful thing.
  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited November 2019

    Since I seem to be the outlier in the group, I use DDUTIL because it gives me not only Band Switching and full control of power levels but it also allows me to remotely turn my 2K_FA on and off.  I also use DDUTIL for my SteppIR and to control my Rotor.

    Been running it this way remotely for years.  DDUTIL is mostly set it and forget it as it really does not consume any screen real estate except when you are setting it up.

  • edited November 2017
    This all looks good.

  • edited February 9
    On my 2K-FA I use the USB cable made by SPE to connect to a USB port on the Flex..  Installs and works in minutes. I use Term 2kUSB from SPE to totally control the 2K.... Never had an issue with either in local or remote operation.
  • Rick N4RZRick N4RZ Member ✭✭
    edited November 2017
    I am set up the same way with my 2K-FA using one of Dan's Cables from Expert Linears.   The amp turns on when the radio comes on and controls the power levels automatically so that I get about a 3db boost between the Low/Mid/Max settings on the amp. I also use Term 2K to give me complete control and monitoring of the amp.       
  • edited November 2019
    OK, I finally got around to trying all this at the remote setup.  I actually obtained an Expert 2K.  Nothing is working and I don't know why. 

    I have a good friend helping (a qualified electronics tech) and we carefully put this together.

    The DB9->DB15 is failing.  The USB pathway is failing.  My intent was to have the USB->RS232-DB15 out of the Flex and the USB wired up to the PC.  Nothing worked and as you will see, after things failed, I tried to hook everything up in various ways to just the PC just to see what is going on.  Nothing works.

    1.  We verified that we had a 'real' FTDI chip and used the actual FTDI  USB-to-RS232 that Ria recommended.  It works perfectly with the Green Heron Controller when plugged into the PC, so we know it isn't some sort of brain dead manufacturing failure.  That is to say, the FTDI chip shows up, the PC sees it, and it can carry communications, albeit on someone else's device.

    2.  We "rung out" the wiring carefully.  The male plug of the DB9 is numbered left to right (so pin 1 is the upper left of the row of five).  We indeed have pin 2, which should be RXD, going to pin 9 (TXD on the Expert side).  Pin 3 (TXD) on the DB9 is going to pin 1 (RXD) of the 15 pin.  Pin 5 of the DB9 (bottom left pin on the DB9 male) to pin 4 of the DB 15.  I just "re-rung" that out as I type this and even validated that the little helpful guide numbers on the connectors matched.

    3.  The USB interface to the PC worked, momentarily.  It did not work at all with the USB code (I could not unplug all of the USB interfaces, turning SmartCAT off changed nothing, and it would not let me put in an ID string by hand).  But, when I configured the COM port for the straight-up USB cable, it briefly worked the first time with the RS232 version of the code.   It didn't do much or allow us to change much, but it at least showed us the SPE display.

    4  When hooked up to the Flex (as far as I know, accurately) nothing worked.

    5.  Just to see if we could get it to work, we tried to connect the USB-to-RS232 interface to CAT 1 out the back of the SPE amp directly from the PC.  It would connect, but no data flowed.

    Ria's note does not discuss setting up the CAT functionality in the SPE.  I assume it must be set to Flex Radio?  I think it was set to Elecraft at first.  Changing that had no visible effect.

    Another oddity:  The original cable had RXD->RXD and TXD->TXD.  As I read the Expert manual, that (rather than what is traditionally done, by connecting RXD to TXD and TXD to RXD) is what the manual seems to say.  Yet, everyone here says hook it up "normally".  I did try, briefly, wiring them in reverse but if anything, it was worse.  It looks like if I do what is recommended in Ria's site, and by the community generally, the PC *thinks* it is hooking up, though nothing happens.

    I also read the manual and set the baud rate to 115K, which had no effect either.

    I am leaving the site where this all is and may not get back for a day or two.  Suggestions on how to proceed?
  • edited March 2018
    One other thing.  Is that 5v out of the Flex ACC really reliable for REMOTE ON?  The SPE manual says that it needs to be between 9 and 15 v, but the Flex ACC pin is only 5v.  Does anyone have any sort of "trick" to increase that voltage or do you all fake it with 5?

    BTW, to clarify the preceding note.  I actually spent almost all the time with Ria's wiring.  So it is RXD to TXD and TXD to RXD.  But, as I said, the actual cable someone else made and the manual seem to want TXD to TXD, RXD to RXD.  Except for a brief experiment, which did no better and maybe worse, I did not do that.
  • Mark_WS7MMark_WS7M Member ✭✭
    edited March 2018
    " We verified that we had a 'real' FTDI chip and used the actual FTDI  USB-to-RS232 that Ria recommended"

    Does the Flex see this USB cable?  If the flex is not seeing this cable then nothing will work.

    How do you know you have a "real" FTDI chip?  There are many knock offs and clones.  Did you get one of the ones recommended here?  I got them and they work just fine.  The Flex sees them.

    Yes cat in SPE needs to be set to Flex.   

    Hooking this USB cable up to your PC doesn't really tell us much.  It has to work with the flex for it to do what I think you want to do.

    Also what version of SmartSDR and firmware are you running?
  • Mark_WS7MMark_WS7M Member ✭✭
    edited March 2018
    Wait... I'm not sure I understand. The Rem On port of the Flex is for turning the Flex radio on/off with a grounding of that pin. You would NOT connect that to your amp to turn it on. If you want to turn on/off the amp I suggest a relay. There are many of them listed on this forum and use that to toggle 12V from your supply to the amp on pin of the DB-15
  • edited March 2018
    I believe the Flex does see the device.  It reported the "ID" of the thing.  Ria's page shows strings like AL02AWY1  and mine was AI04WPRU.  So, it was definitely reporting it when it was plugged in.

    And,  I did get the exact one Ria recommended.

    I only hooked it up to the PC to see if I could figure something, anything out.  You're right, the end game is hooking it up via the Flex.  But, as I am running remote, I also need to see the SPE displays via the software (I remote the PC nicely, so running it on USB in addition to the Flex path is paramount).  So, I need to get the USB-to-USB thing working on the PC also.

    HW version:   2.1.30.103

    SmartSDR:   2.1.30
  • edited March 2018
    This is not the Flex REMOTE ON.  This is the SPE Amplilfier's REMOTE ON.  SPE's products define an extra pin, beyond the regular RS232, that needs to be set to a voltage (between 9 and 15 says the manual).  That will automatically turn on the amp.  I need something to do that.  The ACC pin on the Flex that puts out +5v might do it, but the voltage appears low.  It is only 5v.  It is not the same pin that you ground to turn the Flex on and off.
  • Mark_WS7MMark_WS7M Member ✭✭
    edited March 2018
    Ok so when you plug it into your flex and you go to USB cables you need to make sure to set the cable as CAT:

    image

    So if you select it and hit edit you should see a dialog like this:

    image

    The name is whatever you want to call it.  Select CAT as the cable type.  Then select TX Slice under source.   Under the advanced arrow I have

    9600
    8
    None
    1
    None

    Then on the amp you go into setup, select CAT then select Flex-radio:

    image

    Once you select that with "Set".  On the next page you select the matching baud, in this case 9600 since that is what I have set above:

    image

    Then set to confirm and store the settings.  As long as your cable is enabled the amp should start following the band of the flex TX slice.
  • Mark_WS7MMark_WS7M Member ✭✭
    edited March 2018
    Ok sorry... I thought you were referring to the Flex Rem On.  On the SPE remote on pin you should use 12V with a relay as I mentioned above.

    I use a raspberry pi with a relay board on it but many other here use other web enabled relays.  There was a recent thread about this so I think if you search for SPE you will probably find it.
  • edited March 2018
    Thanks, Mark.  That's all the pointer I would need.  I already have the regular semi-documented solution for the Flex Remote Power On Grounding method.  I have a wall wart power supply that kicks a reed relay that, when the relay coil is powered, grounds the pin for the Flex Remote On.  I could probably add a simple circuit for the SPE that did the opposite -- the wall wart would trigger a second relay.  The path through that second relay enabled by this second coil would then deliver the 12v, possibly with a current limiting resistor.  So, turning on the Flex Remote On, in this version of it, would turn on both devices by grounding the Flex remote on and delivering voltage to the SPE remote on.  And turn them off.  The wall wart itself is powered on/off under internet control as has been true since the start of my remoting.

    However, I may skip this part altogether.  Once I get the software utility working, my non-Flex buddies tell me that it is full capable of turning the amp on and off.  That's exactly how I work it with the Alpha now, so if that indeed proves out, I may just skip the auto power on part unless there's a compelling reason to have it.
  • edited March 2018
    As far as I know, what you show is exactly what I have.  Including the 9600 Baud.

    On the custom cable:  Do you have TXD->RXD and RXD->TXD?  I'm still a bit hazy on that.  The Flex commuity says one thing, the manual says RXD->RXD and TXD->TXD.  Which do you have?
  • edited March 2018
    When I try and get the SPE USB utility to "see" only one device, all the Flex ports are there and it balks. 

    Did you have to uninstall Smart SDR to get this **** USB utility to work? 

    Or, do you all figure out how to make the RS232 utility work over the USB wire?  On that path, the only one I made briefly work, at least I could tell it what COM port to use and it sorta seemed to work.  For a little while.  This is all USB cable to USB port, for this discussion anyway.

  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited March 2018

    You could save a great deal of Agony by just using DDUTIL I have been remoting my 2K-FA  for several years with DDUTIL and it works flawlessly PLUS it gives you full control (on/off/antennas, power levels) of the SPE Amps.

  • edited March 2018
    I'm dubious at the moment.  Right now, on all paths I have chosen, I am not successfully communicating to the SPE amp.  Not with the Flex rig, not with SPE's own utility, the latter of which  I consider a pretty basic issue.  I've tried several paths, some normal, some abnormal.  Nothing works yet.

    Until I get regular, successful communications with the amp via _some_ means, I don't think we can assume anything about using DDUTIL or any other approach.  At the moment, I am falling down on a basic pathway to and from the amp.

  • RiaRia Member ✭✭
    edited March 2018
    USB/Ser   -------------------->  Amp CAT A port
    Pin 2 (RXD)     ------------------>  Pin 9 (TXD)
    Pin 3 (TXD)     ------------------>  Pin 1 (RXD)
    Pin 5 (Ground) ------------------>  Pin 4 (Ground)

    That's the exact pinout I used with my 1.3K-FA.
  • edited November 2019
    To recap, I think I have three distinct problems:

    1.  There is no successful communication between _anything_ and the SPE Amp.  It doesn't matter what path I  tried.  To solve this (which precedes even getting Flex in the picture), I need, I think, to get a reliable pathway from the PC to the Amp.  In other words, this problem is so significant, I could not hook up this amp to ANY rig whatever.  I need to hook up the USB from the PC to the USB port on the SPE amp.

      A.    I need to either make the USB version of the utility work or
      B.  the RS232 version work (by describing the COM port??).

      The USB utility seems to think I haven't unplugged everything and refuses to find the device.  I need to unplug, even if this includes uninstalling Flex (do I really have to do that?). 

      The RS232 version worked, briefly, once, but did not have full function even when it did.  It seems to "connect" but I am very suspicious that all this means now is that it "connects" with the FTDI chip but the data flows no farther.

      I do not get the SPE display no matter what path I take.  I get a blank screen.

    2.  The DB9->DB15 cable.  I am glad Ria herself has chipped in and confirmed it should be TXD->RXD and RXD->TXD.  That's what I thought and what I was using most of the day.  It is how the cable is configured right now.  I do not know why it is failing.  I need to get this understood so I can get the path where the Flex talks to the amp working.  Maybe DDUTIL can help, maybe the regular utility can, temporarily.  But, ultimately, I see no reason why I shouldn't expect the Flex to actually control this as of March 2018.  Right now, until #1 resolves, it is not clear what my options are and whether the cable I have is good or bad.  In other words, it is just possible that fixing #1 fixes this or unmasks what is going on or something.  Or not.  But, straight USB is not working, either and I need to find a way to get that going and maybe it is easier to figure this one out.

    3.  The remote power on pin thing.  If I can get the software working to where it turns the rig on and off, I may not care about this problem.  I have worked the Alpha by using its utility to turn the amp on and off (soft on, soft off, just as it should be here) for years.   If there is a reason to do the "auto" power that I don't now get, I can wander off and find an answer.  This one, at least, seems independent of the rest.
  • RiaRia Member ✭✭
    edited March 2018
     A.    I need to either make the USB version of the utility work or 
      B.  the RS232 version work (by describing the COM port??).
    SPE does things kind of strange.  USB from the amp is only for the control software (or ddutil if you choose to use that).  It is entirely separate from CAT used to set the band and frequency (specifically for the ATU). 

    So you must use a CAT cable if you want CAT control of the amp.

    The ugreen cable from amazon works, and of course genuine FTDI from digikey or Flex. 

    The wiring I posted earlier is correct, it's what I used on my amp. Actually if in doubt refer to the manual under the section for elecraft or kenwood cable and you will see that wiring.

    The way you have to set it up in SmartSDR is like this. You only need CAT A. I had two cables for SO2R. If you are not doiong SO2R then you don't need two cables.

    image

    By the way it's recommended to use a hub rather than connect the cable directly. I don't know how much of a difference it makes. 

    Once you set it up that way, make sure the baud rate matches the amp. VERY IMPORTANT.

    On the amp, set the CAT type to Kenwood or Flex. The difference between Kenwood and Flex is that Flex allows the amp to control drive power. Kenwood just lets you do it manually.

    Save your settings and you're off to the races. As you tune the slice on the selected antenna port it will QSY the amp. If there is more than one slice open on that antenna port it will follow the active slice. 

    If your cable is not working, maybe you should see if it works with another radio like an elecraft or kenwood. Then you can see if you have a defective USB to serial adapter. 

    Ria

  • RiaRia Member ✭✭
    edited March 2018
    DDUtil is nice for a simple setup. It can't work with SO2R which is why I didn't use it. 
  • Mark_WS7MMark_WS7M Member ✭✭
    edited March 2018
    Larry,

    So if you plug in a standard (not one you made) USB cable between the USB on the SPE amp and your computer.

    Then run the SPE term utility from the CD, you are saying you cannot communicate with the amp?

    What OS is your computer running?

    This should simply work.  Using their USB term utility and assuming your cable is plugged and everything is recognized by Windows the utility should just work.

    Now you do have to "Connect" in the file menu.

    So when this kind of thing happens I suggest you remove all connections from your computer except:

    Keyboard
    Mouse

    Then reboot your computer.   Now plug in the USB from the SPE amp only.

    Run the SPE USB term software and from the file menu select connect...

    I am not in a position to setup my amp to test this but you should be given either a list of possible connections or it just may connect.   Then from the control panel view in the SPE USB term software press the ON button. 

    The amp should turn on and the software should display exactly what is on the amp screen.

    If we cannot get this to work then I suspect you have either issues in your PC or issues with your SPE amp.

    Mark
  • Lawrence Kellar KB5ZZBLawrence Kellar KB5ZZB Member ✭✭
    edited March 2018
    Isn’t there a driver on SPE CD that had to be installed 1st? I remember you have to “choose” the correct usb string Id in the settings of comm program. If I remember correctly they suggest unplugging all other usb devices during setup so you can choose the “ right “ id.
  • Duane_AC5AADuane_AC5AA Member ✭✭
    edited March 2018
    Just as a reference - I plugged my 1.3K into my Windows 10 desktop computer for the first time 2 days ago.  I just connected the provided USB cable between then.  Windows did its usual gyrations, found a driver, and then I started up the SPE USB term program and was able to access the amp and update its firmware.  All the SSDR software and CAT ports were enabled when I did that.  Later, the FlexControl had to be pulled and replugged to get it going, but that was the only hiccup in the process.   For whatever this is worth.  Maybe you could try the USB connect with a different PC that doesn't have much else loaded on it, like a laptop that is just used for email or something . . .   I'd be questioning whether there is a problem in the amp's USB area at this point.
  • edited March 2018
    Mark said:  "So if you plug in a standard (not one you made) USB cable between the USB on the SPE amp and your computer.

    Then run the SPE term utility from the CD, you are saying you cannot communicate with the amp?"

    Yes, that is what I am saying.  If I try to use the RS232 version, it kind of worked, once.  If I try to use the USB version, it cannot find the device.  I _had_ thought I had removed everything, but maybe I need a second look.  Maybe  I even need (even if you did not) to uninstall SmartCAT just to clear things out.

    Lawrence:  I was offered no choice and it found no string. The Flex, when I hooked it up that way, seems to have found the string, but not Windows 10.

    I will check on the CD thing when I get back out to the site.  That's an important clue.
  • edited March 2018
    Duane, I may do exactly that.  The PC that runs my remote setup has a lot going on.  It must control two Green Herons, the amplifier (currently the Alpha) and then of course deal with SmartCAT.   I have other PCs on site with far less complexity .

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.