Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

No persistence using SmartSDR for iOS

Bob  KN4HHBob KN4HH BobMember ✭✭
edited June 16 in SmartSDR for iOS
I am running the latest SmartSDR for iOS version on both an iPhone and iPad.  Each time I power up either device, it defaults to 14.250 and DAX on no matter what band I last operated on.
Is there a setting that I have missed in order to allow the devices to retain last used parameters?

73, Bob, KN4HH

Completed · Last Updated

Answers

  • Greg N8GDGreg N8GD Member ✭✭
    edited June 2018
    I'm noticing the same thing.  However, if I change the frequency on the 20 Meter band, it will return to that new frequency, but it always returns to 20 Meters, no matter what band I was on when I disconnected and exited SSDR iOS. This along with not being able to create or see TNFs in SSDR iOS makes two problems now (see the post on SSDR for iOS TNF failures).
  • Marcus-DL8MREMarcus-DL8MRE Company Adviser
    edited December 2019
    This has been reported a few times but I am unable to reproduce it.

    I have only one suspect which is the Global Profile setting. Can you (Greg and Bob) tell me the name of your global default Profile is, when using the App.

    Normally, there should be a Profile called "iOS_default_profile" which is being used by the App. Maybe it would also be worth a try to delete that profile. It should then be auto-recreated.

    Sorry if the App now turns out to be unusable due to this and the TNF issue.

    Thanks.

    Marcus

     
  • Greg N8GDGreg N8GD Member ✭✭
    edited June 2018
    I was on the "iOS_default_Profile" but this occurs even when other profiles are selected.  I deleted the "iOS_default_Profile" as you suggested, and after it was recreated, SSDR for iOS still starts on 20 Meters even if I was on another band when exiting the program.  This isn't a big deal for me - I just select the correct band after startup and I'm on my way!  As for the TNF bug, your release of an update to fix that bug is far more important to me.  I am awaiting Apple's release of the new version to resolve that TNF issue.  No need to apologize for any of this, Marcus.  Your app is absolutely great, you provide great service in maintaining, upgrading, and fixing your software.  And in many cases, your iOS app does some things that can't be done in Flex's Windows version!
  • Marcus-DL8MREMarcus-DL8MRE Company Adviser
    edited June 16
    Good News Greg and Bob,

    1.) The reason for the 20M Band was found (but please confirm). I asked Eric from Flex and he mentioned that the Low Bandwidth Setting is causing the Radio to behave like this. Can you check if you enabled the Low Bandwidth setting (App Settings) and if so, if you end up on the expected Band when you turn this setting off.

    2.) Apple just started to review my App. Let's cross our fingers they don't find any reason to reject it and are finishing their review soon.

    UPDATE: Version 2.2.2 has just been released by Apple. It may take a few hours until it's available everywhere.

    73,
    Marcus
  • Greg N8GDGreg N8GD Member ✭✭
    edited June 2018
    Yes.  Turning OFF Low Bandwidth Setting makes SSDR for iOS remember band persistence, just like it should. If I turn Low Bandwidth back on, it always goes to 20 Meters, So, is this a Flex bug in the radio firmware, and if so, I presume it will be fixed by FlexRadio? Doesn't the Maestro have the Low Bandwidth capabilities, also?  I'm not familiar with SSDR/Windows having such a setting. Anyway, Marcus, you're off the hook on this one since it's on Flex's side (the radio) - Hi Hi.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited October 2017
    So, is this a Flex bug in the radio firmware, and if so, I presume it will be fixed by FlexRadio? 

    This is not a bug, it is working as designed.  Persistence is disabled in low bandwidth mode to ensure low bandwidth between the radio and client.
  • Eric-KE5DTOEric-KE5DTO Administrator, FlexRadio Employee admin
    edited October 2017
    This is actually the intended behavior -- when using the Low Bandwidth connection mode, the client starts up in a known configuration (single Panadapter, single Slice on 20m) using minimal bandwidth to ensure functionality on less robust internet connections.
  • Greg N8GDGreg N8GD Member ✭✭
    edited October 2017
    That makes sense.  I presumed that persistence was just the transfer of info of the state of the radio at the beginning and end of sessions, but I guess it's really a lot more complicated than that.  It would thus appear that persistence is a constant exchange of the changing states of the radio between the client and the transceiver so that it can be returned to a given state even upon a failed connection.  Anyway, it's really not a big deal to switch to whatever settings you want after startup in low bandwidth mode.  In fact, I would guess that with SSDR/iOS you could start up in high bandwidth mode momentarily and switch to low bandwidth mode (making sure to switch back to high bandwidth mode prior to disconnecting to capture the last state of the radio).  Is this feasible?  I would usually use low bandwidth mode to improve audio quality (dropouts, etc.), but there are certainly situations where bandwidth could be so poor as to preclude even a momentary startup in high bandwidth mode.

    All of this shows why you guys are the designers/programmers and we're the users.
  • Bob G   W1GLVBob G W1GLV Member ✭✭
    edited October 2017
    I tried switching the Low Bandwidth off and does not make any difference. I also noticed the same problem with SSDR.
  • Bob  KN4HHBob KN4HH Bob Member ✭✭
    edited October 2017
    Since I started this thread, I wanted to thank everyone for their comments.  Marcus, I did switch low bandwidth off and I conform that the app on iPhone and iPad now retains last used configuration.  Many thanks to the Flex folks for the explanation of system behavoir.  All is well (except for T-Mobile, hi hi).

    73, Bob, KN4HH

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.