Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Problem accessing radio after 2.0 upgrade

Ken HansenKen Hansen Member ✭✭
edited June 23 in SmartSDR for Windows

Last night I successfully upgraded my Flex 6300 to SmartSDR 2.0, and was able to access radio locally after upgrade.

I registered the radio for SmartLink, registered to my "[email protected]" email address successfully last night also.

Well, today is a new day, and I can't access the radio either locally or via smartlink.

The progression during login is as follows - I start SmartSDR 2.0:


image

That shows the radio available and registered for SmartLink.

Then, a moment later, the screen changes to this:



image

Where did SmartLink go?

Then I click on the Flex-6300, and I get this:


image

But when I click on "SmartLink Setup" I get this:


image

Oh look, my radio IS registered for SmartLink!

If I click on "connect" on the previous screen, after highlighting the Flex-6300, the software just appears to hang, never connecting.

Any thoughts? I'm hoping to use my radio remotely this weekend, any help you can provide is greatly appreciated.

Ken, N2VIP

Comments

  • Ken HansenKen Hansen Member ✭✭
    edited June 2018

    When it fails to connect to the radio, this is the timeout message I see:

    image

  • Ken - NM9PKen - NM9P Member ✭✭
    edited June 23
    Have you done a cold reboot of the rig?
    Shut if off, remove power for about 30 seconds, return power, and start the rig up again.

    While that is happening, reboot your computer, too.

    Then try again, locally at first, and see if it connects.
    If so, then try via your remote connection.

    BTW>  If you go to the network settings tab in your SmartLink setup, what does it say?
    Are you using the "Automatic" UPnP, or have you manually forwarded ports?
    If you hit the "test" button, do you get the green indicator?

    Ken - NM9P
  • NX6D DaveNX6D Dave Member
    edited December 2019
    Assuming all of this is happening on your LAN, you shouldn't see your radio listed as being available via SmartLink. This suggests something unusual is happening in your LAN.

  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited August 2017
    I have converted this topic to a support HelpDesk ticket (http://helpdesk.flexradio.com) for expedited issue resolution.  Please respond using the HelpDesk ticket for issue resolution.
  • Ken HansenKen Hansen Member ✭✭
    edited August 2017
    Yes, all on home lan
  • Ken HansenKen Hansen Member ✭✭
    edited August 2017
    Working backwards: Yes, greenbuttonfrom'test' Using manual port forwarding 4993 --> 4993, 4994 -->4994 The laptop has been rebooted, the radio has not The laptop found the 2.0 updated radio on local LAN right after update, radiohas not been powered down since update. Thanks, Ken, N2VIP
  • Ken HansenKen Hansen Member ✭✭
    edited June 2018

    Thanks all, got a chance to test it today, after power-cycling the radio, and all is well. I was able to access the radio on my local LAN (where I did not see the SmartLink tag next to the radio entry), but when I went to a bookstore to test remote access from my laptop the radio appeared, with the SmartLink tag next to it, and I was able to control it just fine.

    I will update the helpdesk ticket momentarily, but I wanted to add the resolution here - the power-cycle on the radio appears to be needed, or at least very, very helpful. ;^)

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.