Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

DAX and CAT applications now available for macOS



  • George KF2T
    George KF2T Member ✭✭✭
    edited June 2018
    Thanks, Mario. Glad you’re recovering, my friend!
  • Pete WS4G
    Pete WS4G Member
    Just getting started with RUMlogNG. Here's my experience getting it connected to Flex 6xxx radios on the Remote Ham Radio (RHR) network, remotehamradio.com. Maybe you'll see things I should have done differently.

    - Setup: In RUMlogNG, Preference, TX1, Choose Kenwood, Interface TCP, Host (my MacBook Air's IP address), Port 5002, Close //, localhost might work; 5002 is the default CAT port for xCAT; I didn't try Yaesu or Ten-Tec, but the other options didn't work for me.
    - Start RHR, connect to a station
    - Start/Connect DL3LSM xCAT // I chose CAT protocol, CAT & RigCtID probably works too
    - Reopen RUMlogNG preferences, deselect/reselect the Use CAT checkbox, Close

    This is just a start. RUMlogNG's QSO box tracks the radio's frequency and mode. I didn't try to actually work/log a station from RHR, but seems like it'll work.

    If you disconnect/reconnect RHR stations you'll have to stop/restart xCAT and unclick/click Use CAT (and Close) in the RUMlogNG preferences after the new radio is connected.

    Best regards,
    Pete WS4G
  • Robert0
    Robert0 Member
    I moved over to a Flex-6600 about a month ago. I have successfully configured SmartSDR and xSDR6000 (+xCAT and xDAX) to work with WSJT-X using Rogue Amoeba's Loopback application on my M1 Mac Mini. When using RumLogNG with my KX3, I used to have UDP information forward to RumLogNG with DX Spots and log information transferred. Now that I'm using the Flex-6600 I have lost the UDP data transfer and no longer get the DX spots or log information transferred. I've double checked the ports and configurations, but no luck. What am I doing wrong?
  • Tilio
    Tilio Member ✭✭

    would like to share my experience: I have a MacBook Pro (old 4yrs) with Win10 on BootCamp, and I use SSDR for win and N1MM+, being the most common combination for contest (and normal logging) wid my Flex6400. This combination permits to fine-steering the relation between Logger and FlexCliente SSDR, even from remote using an Arduino Winkeyer and WXFlex for paddle use. My main station at home, anyhow, is Mac Based (Mini), using the much more efficient SSDR for Mac, but it is difficult to "gear" a logger, even if actually SSDR for Mac contains a rather efficient logger - not for contests anyhow. The logger most similar to th fantastic N1MM+ seems to be RumLogNG, easily connectable to SSDR, but with several drawbacks, at least for my maybe incorrect/incomplete installation: editing macros not possible, only in Settings; variables unknown, like <CALL>, no sidetone for the few available f-keys available, Winkeyer not working (I have WK2), neither xCAT and xDAX does not work at all (I asked few times help to Mario, DL3LSM: no answer - thanks Mario). Some of the above drawbacks can be solved using Macros in SSDR for Mac, and SkokumMorse, that has its own Macros available, and permits use of paddle manually, even if not with a sidetone (anyhow Winkeyer provides sidetone). My logging monitor is crowded of windows, but everything works, like in the much more simple case of SSDR-WIN and N1MM+. Unless to use my beloved MacloggedDX and dogparkSDR, of which I'll say in other post, and also have some drawbacks.

    Sorry for the lenght

    73 de IU3BRO Tilio

  • K3SF
    K3SF Member ✭✭✭


    you should be well aware that xdax and xcat are freeware and they are offered by Mario.


    he has other things going on in his life.

    from Mario's website/blog

    Hi there,

    it's been awhile since the last update..

    A lot of things happened during the last 2 years (health, job and family wise) which took not only my time away but also my motivation to do any coding.. In this situation I could not even justify shelling out the money for the v3 upgrade as it would have been only for updating the apps..

    I'm still not back to normal but I have slowly started again..

    I Hope this explain to you why you didnt get any response from Mario. Mario is good gus and has done his best to support the flex radio world.


    xdax/xcat work with SSDR 3.x and 2.x...when Flex made significant changes to its APIs, Mario made changes to these apps...no small effort and all done for free...

    I have no issues running them on different MAC (mac mini m1 , mac mini i5, imac's macbook pro I7 and mabooair m1) Xdax and xcat run in High Sierra, Catalina and Monterey, and Ventura MacOS...

    when using windows ssdr, xdax/xcat will work when you connect them to the ip address of the 6400 and not the windows client.

    note that macssdr offer similar dax and cat apps but not as robust as xdax/xcat and only connect to macssdr client as best i know.

    Example of cross platform operations. I run client on iosSSDR and run xdax/ xcat and FT8 on mac mini

    no problem at all...

    as for contest s/w

    i have built some macros to use with macloggerdx (MLDX) and also fldigi for rtty contesting

    Paul K3SF

  • Tilio
    Tilio Member ✭✭

    Sorry for going back on same argument.

    I have a flexradio 6400, which I also use remotely with a windows laptop with SmartSDR and N1MM for contest logging, and winkeyer for CW paddle, with wxflex software. Some time ago I was able to do the same thing, again remotely with a Mac laptop and SmartSDR for Mac (far superior to the equivalent for Windows) and RumLogNG for Contest logging and SkokumMorse for using the CW paddle. Now I can't do it anymore, can I get help on the correct configuration?

    I put the question in ChatGPT, just to try, I was curious, but no satisfying answer, not enough "intelligent", maybe some "humans" are still better (than me for sure)?:-)

  • K3SF
    K3SF Member ✭✭✭

    In this type of situation the first trouble shooting question is

    What change since last time it all worked ????

    Update to any s/w is a good canditate to start to explore the cause then the fix

    for example

    MaOS update ?

    SkokumMorse update?



    DID MacOS update break SkokumMorse ??

    so gotta know the history to figure it all out...

    no quick easy answer unless some here has been down the same path

    Paul K3SF

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.