Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Time to update the recommended WSJT-X config?

John - AF3KJohn - AF3K Member
edited June 11 in Third-Party Software
Would it make sense to update "Configuring WSJT-X and SmartSDR for Windows" so it recommends using a TCP port type for the rig interface instead of a Virtual Serial port?  

Virtual serial ports worked fine for me until I started using multiple instances of WSJT-X, DDUtil, etc. Switching to using TCP ports cleared everything up. 

It also seems a little strange skipping over "FlexRadio 6xxx" as the Rig type in the WSJT-X Radio setup screen, and using TS-2000 as recommended in the document.

Here is a screenshot of the WSJT-X Radio setup using a TCP.

image

SmartSDR CAT TCP port details:

image







Completed · Last Updated

Answers

  • Greg - KØGDIGreg - KØGDI Member
    edited June 2
    I'm curious on this.  How many others run their setup that way?  I'm still using the recommended Kenwood TS-2000 settings for my FLEX-6700.
  • DONDON Member ✭✭
    edited November 2018
    From what I can determine the 6500 and 6700 work well with the TCP port setup.

    The 6300 is another story....

    I believe there is an error in WSJT/Hamlib that prevents the 6300  from working with the TCP port. The error is actually in Hamlib. The error has been identified but the fix has not been incorporated into WSJT 1.7 yet.
    I found a version of WSJT 1.7 where someone had fixed the 6300 ID problem and it works with my 6300 as advertised. The last version of WSJT 1.7 that I downloaded form the official site causes a timeout when using the TCP port.

  • Greg - KØGDIGreg - KØGDI Member
    edited December 2019
    What about split operation.  Will it allow you to select that and it work?
  • edited July 2017
    Confirmed.  FLEX-6300 doesn't work with WSJT-X 1.7.0 r7405.  This is the error: "Hamlib error: Protocol error while opening connection to rig."  Works just fine with WSJT-X 1.7.1-devel r7782.
  • Michael CosloMichael Coslo Member
    edited July 2017
    My 6300 works FB. What are the symptoms of it not working - I might be missing something.
  • John - AF3KJohn - AF3K Member
    edited July 2017
    Greg - I don't work WSJT split but would be glad to try it.  What is a scenario? (sorry if that seems like a dumb question...I do operate "split" if you mean within the bandpass of one slice - but I presume you mean 2 slices? ) 
  • Chuck - KJ6HTChuck - KJ6HT Member ✭✭
    edited July 2017
    I run my 6500 like this, works like a champ!
  • W0JDW0JD Member
    edited July 2017
    I use TCP ports as well, works well.
  • David--NV0ODavid--NV0O Member
    edited July 2017
    I just tried changing WSJT-X settings for my 6300 to match John's, and it is working fine. I am using the latest release WSJT-X r7782, compiled on this PC with JTSDK.

    This post was a complete surprise to me. I had never heard of doing it this way.


  • Greg - KØGDIGreg - KØGDI Member
    edited July 2017
    Where are you getting the latest release?  I'm stuck on r7405.
  • David--NV0ODavid--NV0O Member
    edited July 2017
    I compiled it myself using JTSDK https://sourceforge.net/projects/jtsdk/files/win32/. I tried the TCP port settings with the official release version r7405 and got the same error as Tony K4QE.

  • David Decoons, wo2xDavid Decoons, wo2x Member ✭✭✭
    edited June 11
    I use the IP method with Flex 6x00 selected. i also select Data/Plt and Fake It Fake It will shift your TX signal to keep it centered around 1000 to 2000 Hz range, in case your tx bandwidth is too narrow.
  • PatrickPatrick WH6HI Member ✭✭
    edited July 2017
    Me too.......works great !
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited July 2017
    We'll look into doing some updates to it in the future.  Thanks for the heads up.
  • Greg - KØGDIGreg - KØGDI Member
    edited July 2017
    Thanks Tim!
  • Greg - KØGDIGreg - KØGDI Member
    edited July 2017
    Thanks for that info!  I just updated to that and it works perfectly with my 6700.
  • Greg - KØGDIGreg - KØGDI Member
    edited July 2017
    I have never done it before.  I've had a foreign entity ask me to do split JT65 and I didn't know how to do it.  I'm guessing this was because the  frequency I was transmitting on was outside their privileges.
  • Jay NationJay Nation Member
    edited July 2017
    Been using TCP port with WSJT-X since it began to work. BTW, it nearly works correctly with Fldigi, but Rigcat using the .xml files still works better because it gets the DIGU mode selections and the Filter width options correct.

    It became an option right after the Current WSJT-X v1.7.0 was released. You will need to be running a WSJT-X v1.7.1 -r???? alpha release. It's all dependent on which version of Hamlib was included when the release was built. There was a an issue with the 6300's in the initial v1.7.1 releases that has since been corrected.

         SDRgadgets

    #FlexRadio IRC chat

       73, Jay - NO5J

  • edited May 2019
    I use WSJT 1.7.1 R7782 and no problems with the 6300-AT. I use Ham Radio Deluxe.image 
  • Greg - KØGDIGreg - KØGDI Member
    edited July 2017
    You have a download link for that r7782?  :)
  • Jay NationJay Nation Member
    edited July 2017
    There aren't any downloads available of any of the Alpha versions, you have to build them yourself using JTSDK, which is available at,

    https://sourceforge.net/projects/jtsdk/?source=directory

    There won't be an official binary download available until there is an offficially released WSJT-X v1.7.1. at which point you will be able to begin building WSJT-X v1.7.2 and later.

    Until there is you'll have to build your own. It takes less than 15 minutes, to build. Really easy, once you have JTSDK installed correctly.

         SDRgadgets

    #FlexRadio IRC chat

       73, Jay - NO5J

  • Greg - KØGDIGreg - KØGDI Member
    edited July 2017
    Thanks Jay.  I'm too busy to mess with that.  I'll just wait until we get an official release.  
  • NX6D DaveNX6D Dave Member
    edited July 2017
    I've been running WSJT-X in this configuration for months.  I also open up the TX cut and disable the "Fake It" mode.  Runs perfectly.
  • NX6D DaveNX6D Dave Member
    edited July 2017
    You run split in JT65 for the same reason you run split on SSB.  When a popular DX shows up, everyone and his dog jumps onto his frequency, making it hard for him to decode anything.  If you want to be heard and get the guy in your log, split your JT65 decoder so that you listen on his TX frequency and send on a different, nearby, (non-overlapping, please) frequency.  Remember that unlike SSB, he will see all decodable signals at once.  If he's a good op, he'll answer them in the order they were received, either on his original frequency or on the frequency you sent on.
  • John - AF3KJohn - AF3K Member
    edited July 2017
    That would be great. Thanks Tim.
  • John - AF3KJohn - AF3K Member
    edited July 2017
    I also open up the TX bandpass (to 5kHz), and don't use "Fake it" mode. My RX bandpass is also set to 5 kHz.  That combo enables trading between JT65 and JT9 QSO's without touching the dial. So far so good.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.