Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

iqRouter does not recognize VPN server

Bob  KN4HH
Bob KN4HH BobMember ✭✭
edited November 2019 in Third-Party Software
I have been running a Raspberry Pi VPN server for some time with no problems.  I recently changed routers from Netgear to an IQrouter.  The IQrouter does not recognize the presence of the Raspberry Pi.  Even though the ip address of the Pi does not appear in the pull down menu of detected devices connected to the IQrouter, I manually forwarded ports  22, 4500, and 5555.  The router still does not recognize the server.  I reconnected the Pi to my old Netgear router, and it is immediately recognized as a connected device.  I must be missing something basic.  Any suggestions would be greatly appreciated. 
73, Bob, KN4HH

Answers

  • Mark_W3II
    Mark_W3II Mark W3II Member ✭✭
    edited February 2018
    IPSec uses port 500 so I had to uncheck the IQRouter, Network menu, Firewall menu item, Traffic Rules tab, "Any udp From any host in wan To any host, port 500 in lan" rule. Then I selected the Port Forwards tab and forwarded 4500 and 500 UDP to my RPI. I hope this helps.
  • Mike va3mw
    Mike va3mw Member ✭✭
    edited February 2018
    Hi Bob

    It does work, as I have several Softether VPN's parked behind IQ Routers.    Can you ping the Softether device from your local subnet?  

    Here is what I would try, as I am guessing at your configurations.
    • Can you ping the router from the pi?
    • Can you ping the pi from the router?
    • I assume that the gateway address has not changed between the old and new router
    • Are you still using the same subent?  192.168.0.x vs. 192.168.1.x or some other subnet
    • Is the RPI using DHCP or fixed ip address?
    Please provide more specifics like the exact IP addresses of the routers and the rpi.

    Do and ifconfig of the pi and make sure the IP matches the subnet and the gateway address is correct.

    Mike va3mw

  • Bob  KN4HH
    Bob KN4HH Bob Member ✭✭
    edited July 2017
    Thanks, Mike and Mark.  Mark, I tried your suggestion and no success.  Mike, My Pi is set up with a static ip and nothing has changed.  However, here is a bit more information.  The iqrouter does detect the Raspberry Pi log in  ip.  However, it does not detect the server ip (192.168.1.19). I can ping the log in ip internal and external.  The port forwarding ip address pulldown menu does list the log in ip but not the server ip.  I just reconnected the old Netgear router and the Pi VPN server is detected and I can reach my Flex 6500 with my ipad and iphone.

    Bob
  • Ria
    Ria Member ✭✭
    edited November 2019
    I had a similar issue with a friend's IQRouter and pi. He just rebooted the pi and it was fine.

    Is your pi accessible locally? That would be the first thing to check. Try to ping it or ssh into it.
  • Mark_W3II
    Mark_W3II Mark W3II Member ✭✭
    edited July 2017
    The default subnet on the IQRouter is not 192.168.1 unless you changed it to 192.168.1. I believe it is 192.168.7. So if you did not change the DHCP subnet in the IQRouter change your static IP on the RPi to 192.168.7.19 to put it in the same Class C subnet. 73.
  • Bob  KN4HH
    Bob KN4HH Bob Member ✭✭
    edited July 2017
    Once again, you caring, knowledgeable, helpful people have come to my rescue.  Ria, Mike, and Mark collectively held the keys to getting my VPN back on the air.  It was necessary for me to change the class of my Pi VPN ip to 192.168.7......  I also had to forward port 500.  once I did those things and rebooted the router and the Pi, everything working great.  Again, my tanks to you all for your contribution. 
    By the way, Ria, it was a pleasure to meet you at Xenia this year.

    73, Bob, KN4HH

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.