Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Maestro - Radio version update screen keeps asking to update

Jerry NY2KW
Jerry NY2KW Member ✭✭
edited December 2017 in Maestro
Just got a lightly used Maestro for my 6700.  The 6700 is hardwired into my primary network (I have both a cable system and Fios) and the Maestro is wireless into same network and SSID as the 6700.  Signal is excellent and no dropped frames.  If I disconnect radio from network in menu and go back to Select Radio, I get a screen "Select a version" which has two choices: v1.9.13.23 and v1.10.16.25.  There is a green up arrow next to one and I select it and it goes through the update process and all appears fine.  However, next time I power up and after selecting radio I get the same screen "Select a Version" and now the other line has a green up arrow saying radio software required.  So I select that and now the cycle starts over again.  Anyone have any advice?  I do not seem to have any option to not upgrade.  

Jerry NY2KW

Answers

  • ctate243
    ctate243 Amateur radio contester Member ✭✭
    edited May 2017
    if one has no green or green/blue arrow..  thats the version the radio is running.  select that one. 
  • Jerry NY2KW
    Jerry NY2KW Member ✭✭
    edited May 2017
    OK, is there a preferred version 1.9.13.23 or 1.10.16.25 ?  Those are the two options I am given.  Currently I last updated the v1.10.16.25.  Doesnt it seem odd that on the next power cycle the Maestro will tell me (Green up arrow next to v1.9.13.23) that a radio update is "required" ?? 
  • EA4GLI
    EA4GLI Salvador Member ✭✭✭
    edited May 2017
    What you are actually doimg is upgrading and downgrading your 6700 and not the Maestro. The idea is that you can keep up to 5 different versions of SmartSDR inside the Maestro so you can use it with different radios. This will make more sense when Smartlink is available and set very 2.0. What you could do is make sure the version 1.10.**** is Not the one with the arrow and select that one every time.
  • Jerry NY2KW
    Jerry NY2KW Member ✭✭
    edited May 2017
    Thank you all.  Now it makes sense.  One last question... the Maestro manual says "The newest software is listed at the top of the screen, the oldest at the bottom"  However on my screen the top line is 1.9.13.23 and the 2nd line is 1.10.16.25.   I assume the 1.10 is newer than the 1.9 and I should disregard the manual?

  • ctate243
    ctate243 Amateur radio contester Member ✭✭
    edited May 2017
    1.10.16 is indeed later, they may have had an oversight in the manual.
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited May 2017
    It isn't an oversight.  It is a bug.  When sorting strings, the "9" comes before the "10".  I believe this is resolved in the next release of SmartSDR (still waiting for my Maestro to return from its vacation in Xenia).

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.