Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Flex5000A - VAC1 gets out of sync with PTT

Bob Ruvolo
Bob Ruvolo Member
For the last several RTTY contests I have been using a Flex5000A with KE9NS PowerSDR  (latest version at the time) and a FlexControl as a second radio. I like the receiver so much that I am considering re-arranging the set-up to make the Flex radio #1 i.e. hooked to my only amplifier..

There is one problem however preventing from doing this and it is as follows.


Contesting software is Writelog V12D with MMTTY as the primary transmit/decode window and 2-tone as a second decoder. This combination is run on two radios, an FT-1000D with a Signalink interface and the Flex through Virtual Audio Cable and vspMgr by K5FR v1.0.3.01 . The VAC audio routing and PTT configuration is the same as my WSJT-X setup and otherwise runs just fine. I am telling Writelog to control the Flex as Kenwood TS-2000 at a rate of 19200. Comm PTT is enabled (the PTT command is sent to the radio). PTT on radio #1 is hardware controlled through the Signalink.

The Problem:

First, no problems with Radio #1 been running fine for years.

However, on the Flex after several hours, my transmitted audio get out of sync with the PTT. I first noticed this when stations would continually ask for repeats, they were obviously not getting the complete exchange. Upon investigations I noticed that PTT asserts first obviously, but audio for transmission does not appear for approximately 1 second. PTT drops before the message buffer is complete. I can confirm this by using the monitor function as the transmitted data shows up in 2-Tone or through the use of the FT-1000 receiver. 

This only happens after several hours. The change may be gradual but it eventually reaches the point where I have to shut down PowerSDR. Upon re-launch of Power SDR the problem is solved until again several hours pass. It also does not require that I be using the Flex. For example I can launch PowerSDR and Writelog and lets it sit for several hours with no activity and the problem exists.

This same problem may exist within my WSJT set-up but since timing there is not as critical it has never caused me problems. No one have ever asked me to check my clock.

I am aware that this maybe a Writelog issue as my previous setups have never used Comm PTT.

Just wanting to see if anyone else has run across this problem and looking for any ideas on methods to possibly troubleshoot.

Methods I am considering:

1. Changing my virutal com port program.
2. Changing my Virtual Audio program.
3. Trying N1MM; I have been a Writelog user for many years and would prefer not to switch.

Thanks for any help.

73 de Bob (KI6DY)


  • Paul - K6HR
    Paul - K6HR Member ✭✭
    edited March 2017
    Same here. I have the same problem when using MMSSTV. After PSDR 2.7.2 has been running for some hours, the exact behavior you describe takes place. Delayed start of TX and early end of TX before the data is complete. As if the digital audio becomes 'offset' somehow. Restarting resets the problem. I don't use WriteLog, so you can rule that one out. If this is not a buffer setting or something, I doubt there will be any fix for it this late in the game.
  • Alan WA4SCA
    Alan WA4SCA Member ✭✭
    edited May 2017
    Have seen the same here, using packet radio. Those programs have a TXTail setting to keep the rig PTT asserted after the program releases it. It has worked fine, normally with a 250-300 ms extension, but I have also noticed that at times I need to extend it.  Didn't make the connection of operating up time.  A delay is expected due to the processing latency, but not a variable one

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.