Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Issues in digi modes during tx

WV9L Member ✭✭
edited December 2019 in SmartSDR for Windows
I notice that when i initiate tx running digi modes, my network connectivity meter goes from all green bars to 2 yellow, then sometimes 1 red. Sometime it even closes the program. The latency goes from 1ms to a much higher higher level when this occurs. To give some background. I have my 6500 in my shack ( a detatched garage behind my house, 100' away). Then my laptop in the house approx 5-10' from my router. I have great signals on wifi and my ping times are excellent as well as speed tests. I am running across my LAN when doing so, obviously. Anyone else experience this? Any ideas or tips? Ive even plugged my laptop in hardwired in the house. I use WSJT-X for JT65 and FLdigi for other modes. Never seem to experience it on FLDigi, but i run JT65 90% of the time.


  • Roy Stiegler
    Roy Stiegler Member ✭✭
    edited March 2017
    I had a similar experience.  The following sent to me by another amateur.


    Many of us have gone back to Win7 after experiencing issues with DAX running under Win10.It's usually the receive side that gets corrupt, however, now and then it's the transmit side.
    Suggest you run DAX as Realtime Priority. Open the Task Manager go to details tab right click on DAX right click on priority and select Realtime.
    You can also run Fldigi at above normal priority. Also check for processes **** up CPU time that's not necessary.

    Hope this helps. 

    Bill W2PKY


    After I changed DAX priority to real time, I have had no further problem with network dropping out.

    Roy  w5TCX

  • KF4HR
    KF4HR Member ✭✭
    edited March 2017
    I had similar problems before I switched Routers.  My network connectivity meter was constantly varying,anywhere from full strength all green, down to one yellow or red bar.  And sometimes the latency got so bad the program would just drop altogether.  I fixed the problem by switching from my low end DLink Router, to a ASUS AC-RT3200 Router.  Now I get full strength (all green) all the time, with no varying at all.

    Butch KF4HR   
  • Mike va3mw
    Mike va3mw Member ✭✭
    edited February 2018
    If I was trying to diagnose this, I need to know which data I can trust.  Is there a problem in the network or is there a problem in the metering tool on the Flex or both?  It is pretty hard to tell without some sort of reference data that we can truly trust.  Too bad we can't plug a voltmeter into it.  LOL

    It is hard to debug the switch of the Wifi as the tools to prove or deny a theory don't exist the the home level.  We just assume they work without failure.  Sadly that is not always true.

    Unfortunately, Ping is a great tool to tell you if you have a network path, but it does not do a very good job for diagnosing network performance.  Increasing the packet size for ping helps as the Switches have to move more data.  Small packets sneak through.

    ping  -l 5000 <IP Address>  

    This will use ping to send a 5000 byte packet.  Give that shot and see if your ping performance gets worse.  Do it while you have the Maestro connected and online.  Try larger sizes.  If that works with excellent performance then we can start to look closer to the radio or the Maestro as a possible part of the problem.

    We have seen some issues with the Maestro plugged into Gig switches and have had people move down to 100mb/s switches and all problems go away.  The Gig switch thing is being look into by Flex though.

    These are just my thoughts if I had to diagnose the problem rather than 'easter egg' it.  Easter Egging being a tech support term were we just guess at the likely things.

    Mike va3mw

  • NX6D Dave
    NX6D Dave Member ✭✭
    edited December 2019
    You could try a direct connection from the laptop to the radio.  I assume your shack is wired to the router in the house, and you aren't using WiFi to/from the shack.  The direct connection sets up a link-local net that needs no switch, just the two devices and the Ethernet cable.

    If that isn't stable, then you've pointed to the wire.  If it is stable, that suggests the switch, since you have factored out the WiFi from the laptop to the router/switch.

  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited February 2019
    Sounds like RFI in the network infrastructure.  Either the switch/router or the PC itself since it only happens during transmit
  • Michael Coslo
    Michael Coslo Member ✭✭
    edited March 2017
    I have had hiccups in network connectivity both wired and wireless. I haven't had the program quit, but have had temporary screen freezes. This might happen when  opening a new slice, changing bands, and a few times, randomly. Only on the W10 machine. I will try Roy's  priority suggestion and report back.
  • Michael Coslo
    Michael Coslo Member ✭✭
    edited March 2017
    Fixed the problem, Turned out ot be the USB Ethernet adapter on the computer. The new Envy's from HP don't have a wired Eternet connector, so "knowing" that wired is faster than wireless, I popped that on. I made a direct connection from the flex to the adapter and that worked okay. But that would have killed usage on my other computer unless I wanted to crawl around changing cables. So I gave my 5G wireless connection a try, and it's been running FB for the last 20 minutes. All is well. 

    Tried changing priority, but since that wasn't the problem that didn't work. Doh!
  • WV9L
    WV9L Member ✭✭
    edited March 2017
    After moving the PC to the shack, and testing several different things (usb ethernet adapters, cables, ends, etc.)  I have found that i was getting rf back into my cable modem and causing problems on 40, 80, and 160. 40 and 160 were the worst. I had to run very low power.  I ended up taking a lead from my station ground, to the coax connector on the cable modem, and so far, problem solved.  

    Thanks for everyones input and comments. Hope this helps someone else.  Glad we have these forums. Great resource and great people.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.