Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Winkey Emulation SSDR v. 1.10.15 stutters with N1MM+

Mike_N1MD Member ✭✭
edited June 2020 in SmartSDR for Windows
Worked CQ 160 contest last night with Flex-6700 and N1MM+ using Winkey emulation. I had lots of problems with function keys not responding to mouse presses and macros that send one letter then pause and then complete the macro.

I thought this had been solved since I did not have problems in contests with the previous beta release or the release before that. Alas, that is not the case.

I am back to my trusty, high reliability hardware Winkeyer -- and I will not even attempt using the SSDR emulation in the future until it is proven that it works. It is not worth the intolerable disruption during contests to try to use the emulation.

Mike N1MD


  • Rick Hadley - W0FG
    edited January 2018
    It's not just N1MM.  It happens with CWX too.  My F1 key is programmed to send my call, and it frequently comes out with an additional space between W and 0, or elsewhere in the sequence.

    Rick, W0FG
  • Keith Flint
    Keith Flint Member ✭✭
    edited February 2020
    I am having the same problem with this release. CWX also stutters at 22 WPM or up, at least. I like to run CW at 28 to 35 WPM.

  • Kevin
    Kevin Member
    edited November 2019
    I reported a problem with N1MM+ sending using winkey. I hadn't realized the winkey emulator actually used CWX. Since then, I tried using CWX directly and notice the problem is there. When I send my call sign (or any word), there's often a space between the first and second letter. Enough of a space that K   4VD or K    EVIN often gets a response from the other side before the 4VD or EVIN is sent.

    I am told this issue is covered by defect 4416.

    I have wondered why Flex included a CW keyer but ignored other digital modes. Even if this issue did not exist you have to admit CWX is a pretty minimalist CW sending program. Adding the winkey emulator on top seems to add the missing capabilities but then I ask again, if you have winkey, why have CWX? But I'm getting off track.

    I'm thinking of purchasing a standalone winkey keyer. I've never bought one before. Can someone make a recommendation of a good make/model? Are there any considerations between models or is one winkey emulator the same as any other?

    Kev K4VD

  • Ria
    Ria Member ✭✭✭
    edited January 2017
    I have heard of that issue but it seems pretty sporadic. Before the fixes were applied, I was having much of the same issue as you. CQWW CW I was tearing my hair out because all of a sudden the rig would **** a lot of high speed CW in the middle of a run or S/P, after stalling a few times before. However, since 1.10.15 beta that hasn't happened (I'm doing the CQ 160 contest right now). 

    There may have been multiple issues but I know for sure I am not having it anymore, and this is after the dev team published a fix (which became part of 1.10.15 beta). 

    Very strange. 

    I hope they get to the bottom of this. 
  • Steve Jones gw0gei
    edited January 2017
    Ditto here - played for four hours in cq 160m cw today at run rates of up to 200q per hour and seemed ok here 73 Steve gw9j / gw0gei
  • David Decoons, wo2x
    David Decoons, wo2x Member, Super Elmer Moderator
    edited June 2020

    I was having the same issue and found it went away when turning off QSK in the CWX window.

    Also I was running 5 ms delay in the CWX window with QSK enabled. I increased it to 15 ms and seemed to help. Haven't heard a misfire since.

    Dave wo2x

  • Kevin
    Kevin Member
    edited January 2017
    Thanks Dave, I'll try that. I'm pretty sure I've always got QSK on here.


  • Kevin
    Kevin Member
    edited January 2017
    Steve... note Dave's post below. How was your QSK and delay set during the contest?


  • Kevin
    Kevin Member
    edited January 2017
    Ha! I think that did it. I set the delay to 15 and QSK off and sent a long string of CQs. They flowed nicely. Then I turned on QSK (leaving 15 for the delay) and I would get intermittent skips. In fact, something I never noticed before, the MOX button flashes off momentarily when there's a skip.

    I am going to keep sending loops until I'm convinced but maybe the QSK and the MOX flash might give FRS some insight into the problem.

    For those not having the problem, any chance you could test with QSK on and report results? I really use QSK a lot, especially during a contest or DX hunting.

    I'm not sure this will help. There's no audio because FRS doesn't send sidetone over to the computer!!!!!!! :( But the video shows how MOX flashes off when sending CWX. Basically I hit F3 a bunch of times (sending CQ). The flashing MOX button coincides with elongated gaps between letters.


  • Rick Hadley - W0FG
    edited January 2017
    Tried it with QSK off, Delay set to 17, CWS at 37 and I'm still getting skips.
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    I have entered this problem report (#4437) into our bug tracker for additional investigation. Thank you for the defect report.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.