Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

How do I connect the 6300 to a network to use Maestro wirelessly?

PB Shell - k7shl
edited February 2020 in Maestro
I have Maestro connected wirelessly to my router.  But it does not show a radio (my 6300) to choose from on screen.  I'm running Windows 10 and have an active Homegroup in the network. My main network is set up to obtain the IP address automatically, as well as the DNS.

With the 6300 wired to the PC, the PC shows the radio as a public network that I can't for the life of me join to any other network or even access.  I can see that it is receiving and sending data when the radio is on, but I can't seem to change any settings.   This may have been answered before, but there are only 8700 conversations to wade through.

How do join the radio to the PC's network (a standalone computer connected to the internet by WiFi)??

Thanks!! 

Answers

  • K1DLM
    K1DLM Member ✭✭
    edited September 2017
    Phil,

    Can you provide a little more detail on your network environment?  What type of router are you using?  Is your 6300 connected via. ethernet directly to your router?  Is your PC hardwired to the router as well, or is the PC running over Wi-Fi? 

    If the Maestro and the 6300 are both connected via. ethernet to the router, does the Maestro work correctly?

    73,

    Dave
    K1DLM
  • Ria
    Ria Member ✭✭
    edited February 2020
    For the maestro to work with the radio on wifi they must be on the same network, same subnet. It relies on a broadcast over the network to find the radio. 

    So you can connect the 6300 to one of the wired ports on your router and then connect the maestro via wifi.
  • Mike va3mw
    Mike va3mw Member ✭✭
    edited November 2019
    On your Wifi Access Point / Router, make sure that you have that ability to see other stations on your access point.  Some routers have a 'switch' the blocks you from seeing other devices.  Sometimes it is called Client Visibility or something like that.

    Mike va3mw
  • PB Shell - k7shl
    edited January 2017
    Will it work to run an ethernet cable from the ethernet port in the computer to the back of the 6300?
  • Mark Erbaugh
    Mark Erbaugh Member
    edited January 2017
    Only the computer to which the radio is connected will see the radio.
  • Steve-N5AC
    Steve-N5AC Community Manager admin
    edited January 2017
    Sometimes it is called Client Visibility or something like that.

    Yes, or "isolate wireless LAN" or something similar.  A key indicator it is doing this would be that your IP address in the wireless devices is not in the same subnet as your wired devices.  For example, wireless might get 192.168.2.x and wired 192.168.1.x.  To be certain they are a different subnet, you'd have to check the mask bits on both network interfaces, of course, but most will be a single /24 class C subnet in consumer routers.
  • Ria
    Ria Member ✭✭
    edited January 2017
    Mark is correct. If you connect it to the computer only the computer will see it. You should connect it to your network, directly to your router or a switch connected to your router as this allows maximum versatility with connections. You can then use maestro, iPhone/iPad, Mac running dog park SDR, or even connect a vpn to use it remotely.
  • Ria
    Ria Member ✭✭
    edited February 2017
    The configuration with different subnets is commonly known as a "guest zone." There is a different configuration where each wifi client is isolated, that is called client Isolation where the WAP will simply filter out any packets destined for other wifi clients associated with the same AP (this generally doesn't prevent wireless from connecting to wired hosts). To determine the latter is enabled you have to check router/AP settings. image
  • K1DLM
    K1DLM Member ✭✭
    edited January 2017
    To be more precise, if the computer is directly attached to the Meastro or 6300 directly, both the radio and the PC would need to have IP addresses assigned manually to communicate with one another.  There would be no DHCP server on the connection to automatically assign IP addresses.  The second issue would be physical connectivity.  Connecting two ethernet clients to one another may require the use of a crossover cable to swap the TX and RX pairs on the cable.  Many never devices overcome this requirement through auto-crossover detection, but that's not universal.
  • Steve-N5AC
    Steve-N5AC Community Manager admin
    edited January 2017
    We support RFC2937 in both products (a.k.a. Link-Local) which means that you can connect the two together without a DHCP server or manually assigning addresses.  Said another way, you do not have to manually assign addresses when direct connecting a Maestro and radio.

    Both devices also have support for Auto MDI-X otherwise know as auto-crossover.  As I recall this was originally developed by HP and here's a short note on the invention: (http://www.hp.com/hpinfo/abouthp/iplicensing/automdix.html).  This allows the two devices to be connected without the need for a crossover cable or an MDI/MDI-X switch on one of the devices. 
  • Ria
    Ria Member ✭✭
    edited January 2017
    Auto crossover detection is standard in 1000BASE-T (gigabit using standard Cat5E/Cat6 cables)

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.