Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

6500 not getting local network ip address

Randy Hollingsworth
Randy Hollingsworth Member ✭✭
edited July 2019 in SmartSDR for Windows
I have a FLEX-6500 running SmartSDR v. on a Windows 10 PC. The PC and the 6500 are both connected to the network via a Linksys WUMC710 wireless bridge. I have had this unit for over a year and it has worked fine, except that it would never obtain a local network ip address when first turned on. I would always have to shut the 6500 down then immediately re-start it, at which point it would always grab the correct ip address.

However, now something has changed. No matter how many times I restart the 6500, I get an ip address of, rather than the expected 192.168.1.****. I can receive and transmit OK, but I cannot get any integration with other programs like DDUTIL, etc. Since the PC is working correctly and is able to access the internet over my local area network, the PC must have a correct ip address via the wireless bridge.

I am at a loss to understand what is going on. I did upgrade the SmartSDR software a few weeks ago, but everything worked fine after the upgrade, so it does not seem that would be the issue. Any assistance in solving this is appreciated. Thanks!

Randy, K0FA


  • Kevin
    Kevin Member
    edited July 2019
    My first question would be where is the 10/8 IP address coming from? I would suspect a second device on your network acting as a DHCP server for a block of 10/8 addresses while your expected device is offering a block from within 192.168/16.

    Are the only devices on the bridge the computer and the radio? How about other devices on the wireless access point? Is the WAP providing the 192.168/16 block? Maybe the bridge or some other device has a built-in DHCP server that you accidentally enabled?

    The only other thing I can think of is at some point you assigned the radio a 10/8 address and it remained static.

    I think I would remove any other devices on the extender or on the wireless router in your house. Then I would look at your bridge configuration and make sure it is not acting as a DHCP server. Can you plug the radio directly into an ethernet port on the computer and restart? The IP should be 169.254/16. Then I might reset my radio after saving my profiles.

    If that all fails then I'd probably just open up a helpdesk ticket and hope for the best.

    Good luck,
    Kev K4VD
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    Sounds like you have a secondary DHCP server on your network if the radio is configured to obtain an IP address via DHCP rather than a static IP address.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.