Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Flexcontrol Won't Install

Rich - N5ZCRich - N5ZC Member ✭✭
I just purchased a Flexcontrol and I'm having a difficult time installing it.

If I plug the Flexcontrol into a USB port it generates a comport that I can see in devices.  I've done it twice and the first time it was assigned COM256 and the 2nd time COM603.

SmartSDR will not recognize the Flexcontrol.

Another symptom is DDUtil will not start if the Flexcontrol is plugged into a USB port.

I've followed the directions to uninstall/install the Flexcontrol driver, but that did not resolve the issue.

I've done some research on this and it looks like I have to uninstall SmartSDR, SmartCat and DDutil.

Any other advice or suggestions before I go through all that trouble?

Thanks in advance.

Rich - N5ZC

Completed · Last Updated


  • Neal_K3NCNeal_K3NC Member ✭✭
    edited January 2017

    When Smartsdr will not see the control, usually it is because windows has assigned a duplicate port number with another virtual comm port. First thing, go to the device manager and see if thats happening. Be sure to click to see hidden devices under the view menu.

    If it is present but not duplicate and still not seen, I would try uninstalling it, clicking the 'remove the drivers' option. Then go to the program files folder for the version of Smartsdr you are running, open the '64bit drivers' folder then open the 'flex control' folder. Remember where this folder is! Right click on the flexcontroluninstall.bat file and select 'run as admin user'. When that has finished. reboot the computer. When it comes back up, go back to the flexcontrol driver folder and right click on the flexcontrolinstall.bat file. Select 'run as admin user'. When it finishes, try  plugging in the flex control in a diffferent usb port.

    Then kick up smartsdr. Remember that with smartsdr the button lights to not automatically come on like they do with Powersdr by the way! Twirl the knob and see if the freq changes!
  • Rich - N5ZCRich - N5ZC Member ✭✭
    edited October 2017
    Hi Neal,

    Thanks for the tips.  Unfortunately, I've tried all of those with no luck.

    Rich - N5ZC
  • Neal_K3NCNeal_K3NC Member ✭✭
    edited January 2017
    Try it on a different computer, you might have a broken device. Otherwise,  uninstall smartsdr, delete all its folders everywhere, reboot, reinstall smartsdr and if that doesn't do it, its time for the professionals!

  • Harold RoseeHarold Rosee Member ✭✭
    edited January 2017
    I have had the same problem on the 6500 as well as the 5000a.  I usually switch it to a different USB port and can get it going. You might just try moving things around.

  • KevinKevin Member
    edited July 2019
    If you move the FlexControl around it will capture different COM ports every time. Once you get it working leave it there. You shouldn't have to uninstall anything. You just need to assign the FC its own port.

    In Device Manager, when I originally installed the FC it boldly took a port that was already in use by VSP. To reassign the port used by FC start Device Manger, double-click on the FlexControl device in Ports (COM & LPT), select the port settings tab then the Advanced button.

    Here you will see a drop down. Pick an unused port (99 in my case). You may have to reboot and restart various things to get it recognized but don't move the usb cable to another usb jack. Leave it where it is.


    Kev K4VD
  • Rich - N5ZCRich - N5ZC Member ✭✭
    edited July 2019
    Nothing has worked.

    I've done a total uninstall of SmartSDR (and ensured that all the virtual comports were deleted), deleted DDUtil.  Then reinstalled SmartSDR 1.10.8 ( but did not reinstall DDUtil ).

    When I plug in the FlexControl it is assigned a duplicate com port.  When I go into properties to change the com port, the drop down menu show's me all the com ports.  Unfortunately they all show in use.  There were one or two ports not in use, however, if I select either of them I'm told they are in use.

    Looks like it may be time to open a support ticket.

    Rich - N5ZC

  • KevinKevin Member
    edited January 2017
    This is actually not an uncommon problem. There are a few here on the community that have solved it already. Jay, NO5J I think knows the process to fix up the in-use stuff on the list and get everything back to normal.


  • DaveCDaveC Member ✭✭
    edited May 2018
    I don't know what OS you are running, but I was running Windows 7 32 bit OS and was NEVER able to get my Flex Controller to work. It seemed like all serial to USB devices on my machine had issues. Problem was not solved until I upgraded to Windows 10.
    Here is a link to my issue:

  • Rich - N5ZCRich - N5ZC Member ✭✭
    edited May 2018
    Hi Dave,

    I'm running Win10 Professional.  I'll take a look at your link.

    Rich  - N5ZC
  • Neal_K3NCNeal_K3NC Member ✭✭
    edited January 2017

    When you try to reassign the comm port, you will often see Windows marking comm ports in use when they are not in use at all. You know what comm ports should be in use (by looking at CAT as well as knowing the other physical ports you have). Assign the dupe to an 'used' comm port you know is free, reboot and then try it!
  • DaveCDaveC Member ✭✭
    edited January 2017

    Has it ever worked? Sounds like it has not. One thing you might try if you can is to install SSDR on another computer, if you got one, and see if it works on that one. I am thinking the controller might be bad and have nothing to do with the software.
  • Ken - NM9PKen - NM9P Member ✭✭
    edited June 23
    Please indulge a **** question....... I assume you are enabling the FlexControl Knob with the button in SSDR's    "Settings>Radio Setup>Radio" ?

    I had to ask, because I have actually seen people pulling their hair out with this kind of thing, thinking that it would automatically enable itself once it was installed.....

    Also....I would suggest closing DDUtil and any other program that uses com ports (other than CAT) and rebooting the computer,  until you get it working.  Then  fire  the other programs back up.  There may be a conflict between the two programs -- both trying to seize control of the Knob...

    And as others have suggested, Once you get it installed, MOVE it to a high port like 99 or 100 so it is permanently out of the way of the virtual serial ports.  In fact, if you still can't get it running, try installing the FC Knob with the DAX, CAT, DDUTIL, and SSDR all closed.  then move the Knob's driver port, reboot, and start up SSDR, et. al.

    Good luck.

    Ken - NM9P
  • Rich - N5ZCRich - N5ZC Member ✭✭
    edited July 2019
    Hi Ken,

    Yes, I had it enabled (but thanks for pointing it out, I've done things like that before).  Turned out to be a Com port problem.  NO5J, just finished helping me resolve the com port issues.  I'm up and running!!

    Rich - N5ZC

  • edited January 2017
    Yes, Jay's solution works well here too.  I now have two Flex Controls up and running, following Al, N4ZZ's recent post describing how to have SDR-Bridge control the second knob.  Very handy!

  • KevinKevin Member
    edited January 2017
  • Al_NN4ZZAl_NN4ZZ Loganville GAMember ✭✭✭
    edited July 2018
    Hi Rick,
    Good to hear you got the second knob setup.  It is really nice to have two of them.  I added the setup notes for using either the SDR-Bridge or DDUTil for the second knob to my web page.


    Regards, Al / NN4ZZ  
    al (at) nn4zz (dot) com
    SSDR / DAX / CAT/ 6700 -  V 1.10.8
  • Steve K9ZWSteve K9ZW Member ✭✭✭
    edited January 2017

    @Rich N5ZC - Would be awesome to have some detail on what the break-through fix was.  Write-ups of successful techniques make the Community Archives that much more useful!  Encouraging you to post some detail.

    Glad it is all sorted!


    Steve K9ZW

  • Rich - N5ZCRich - N5ZC Member ✭✭
    edited January 2017
    Hi Steve,

    Long story short,  my particular pc showed all 256 com ports in use.  Jay, NO5J, walked me through installing a program that looked at all the com ports and switched them from in use to not in use (that's the simplistic explanation).

    The program he had me download is called  "Com_Name_Arbiter_Setter".  I know enough about computers to be dangerous, but I also know when to stop and ask for help.  I don't think I would have run this program without Jay's assistance because it could potentially **** up the registry.  Jay had me make a back up of a particular file in my registry just in case.  We didn't need to use it, but it was there if needed.

    It appears that WIn10 doesn't do a good job of keeping track of USB com ports.  It may also be tied to having SDR 1.10 beta installed ( I doubt it, but it is beta)

    Maybe Jay will chime in here.

    I have found the  problem with PC's is that each one is different and requires different fixes to make things work.

    For example I had **** getting DDUtil to work on the same machine.  I ended up having to wipe the hard drive and reinstalling Win10 so I could start from scratch, which solved that particular problem.  I think the actual cause was a Win10 auto update after my initial install.

    Rich - N5ZC
  • Jay NationJay Nation Member
    edited January 2017
    Ok, I'll chimeimage, The "Fix" isn't intended to be a secret, it really ought to be treated as a "need to know only" kind of technique. I'd compare it to fixing potholes with dynamite. I don't want it to become the latest fad. The recommended Flexradio supported methods can achieve the same thing. My "fix" is just a shortcut method.

    It could be dynamite in the wrong hands.  

    I'm willing to explain it all in the #FlexRadio IRC chat channel, which will keep the explanations out of Google. Some folks like to tinker, and don't pay enough attention to warning labels. or backups.

    The next release of SmartSDR may make the "fix" unnecessary. 

    If it ain't broke, then stop, before breaking out the explosives! image


    #FlexRadio IRC chat

      73, Jay - NO5J

  • Joel N9LQJoel N9LQ Member ✭✭
    edited May 2018
    Ken, Thanks for pointing out the obvious one year ago.  I just got a new Flexcontrol knob and couldn't get it working.  Stumbled upon your tip for ENABLING it, and all is well now.  73

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.