Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

MicroHam and Flex6000

MicroHam offer a new software update of his USB device router - includes now Flex6000

Latest news:22-December-2016
 
Router 8.7.8
   - Support for Flex 6000 Signature Series SDR (MKII, MK2R+, SM, SMD)

Comments

  • Lee - N2LEELee - N2LEE Member
    edited April 3
  • Chris DL5NAMChris DL5NAM Member
    edited December 2016
    Lee, i have used the internal update function of device router ( -> Help -> Update Router)
    [procedure update also then my MK2+R   to  v 7.9]

    73 Chris
  • Jean_Luc F5JRCJean_Luc F5JRC Member ✭✭
    edited May 25
    Sorry for my ignorance but I don't understand the benefit of connecting a Microham device to a Flex 6000 Signature Series SDR.

    73 Jean-Luc
  • k3Timk3Tim Member ✭✭
    edited December 2016
    Hi Jean-Luc,

    I was wondering the same thing. Found this page and it helped, somewhat...

    http://microham.com/contents/en-us/d159.html

    Best Regards,

    Tim / k3Tim
  • Chris DL5NAMChris DL5NAM Member
    edited December 2016
    ... or this page http://microham.com/contents/en-us/d56.html (in my case)
  • Jean_Luc F5JRCJean_Luc F5JRC Member ✭✭
    edited December 2016
    Thanks guys, I will go to bed less idiot tonight! Whatever! :-)

    And I wish you a very Happy New Year!
  • DH1RKDH1RK Member
    edited December 2016
    Hi Chris,
    thanks for the information!
    Updated sucessfully and streight forward the setup for my StationMaster controller, too.

    Happy New Year and good DX for 2017.

    Best regards,
    Ruediger, DH1RK
  • Sherman BanksSherman Banks Member ✭✭
    edited April 3
    I have selected Flex 6000 Series as the radio model in USB Router but it is not seeing the radio information. What more do I have to do to get USB Router to see the Flex frequency and mode information?
  • Chris DL5NAMChris DL5NAM Member
    edited December 2018
    imageimage
  • Sherman BanksSherman Banks Member ✭✭
    edited September 2019
    Well the only thing I had different was the baud rate. I matched yours and it still does not detect the radio.
  • Sherman BanksSherman Banks Member ✭✭
    edited December 2018
    Well the only thing I had different was the baud rate. I matched yours and it still does not detect the radio.
  • Sherman BanksSherman Banks Member ✭✭
    edited June 16
    I have discovered the "secret" to connect the microKEYER 2R+ for those interested. You need to add a FTDI based USB-Serial cable with a null modem and gender changer. A search on Amazon turned up the Sabrent which claimed to have the FTDI chipset. I plugged it into the back of the 6400 and it was detected under SmartSDR Settings/USB Cables. I set the USB to 57600, 8n1, CAT and low and behold the USB Router detected the Flex with the settings shown above. USB Router does not connect natively - you need to connect the RS-232 cable to the Flex.

    For those wondering why I need to do this, I also have an Elecraft K3 that I share the headphones and mic. The microKEYER 2R+ switches mic and headphone audio between the two radios. The 2R+ also has a built in Winkeyer that allows me to have consistent CW speed between N1MM+ and my paddles - a problem noted elsewhere on this board when using the Flex built-in keyer. The 2R+ needs to know the mode the radio is in to determine when to send CW and when to route mic audio. Before I got this connection working I had to manually switch the 2R+ from Voice to CW and back as I changed modes. Now it is automatic.
  • Alfredo A. Rios C.Alfredo A. Rios C. Member
    edited May 7
    Hello Sherman, I have the same situation a bit diffrent, I currently own a bunch of MicroHam equipment that is configure to usee in my local shack with the main one being the antenna Selector a double 6, I need them to comunicate with my Flex and my TS990S and can not get it to work. Can you please specify hoy you got the MicroHam to communicate with the radio, I have a Station Master and a DIGi Keyer II I dont think that I would need the DKII to work with the Flex but the Antenna Stitch is a must. Please let me know if you could help me. Thank you 73's Alfredo HI8K/K4CKK
  • Sherman BanksSherman Banks Member ✭✭
    edited June 16
    Hi Alfredo. Sorry I missed this note. I saw it as I was investigating a WSJT-X to Flex interface problem I have.
    1. If you are using microHAM USB Device Router you need to upgrade it to the latest version. See the link at the top of this thread. The new version supports connection to the Flex radio.
    2. You will need a USB to RS-232 cable and plug it into your Flex. I used the Sabrent USB to RS-232 converter. Set it up in SmartSDR under Settings/USB Cables and configure it as CAT. Connect the RS-232 cable from you Microham device to the USB to RS-232 cable you plugged into the Flex. Make sure the baud rate you set it up for in SmartSDR is the same as in USB Router. To check that in USB Router, run the USB Device Router program and go to the Ports tab and under CAT click in Set. Also make sure you choose Flex 6000 series under the Radio pull down menu.
    3. The USB Device Router should now be reading the frequency and mode of the Flex.
    I only have experience with the microKEYER 2R+ and USB Device Router. Hopefully your microHAM devices use the USB Device Router program and if so these instructions will help you get Device Router communicating with the Flex. Good Luck.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.