Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Continued persistence problem?

dlwarnberg
dlwarnberg Member ✭✭
edited May 2019 in SmartSDR for Windows
Not sure if it's me or there is still a persistence issue?  I am still running version SmartSDR 1.9.13.173 (have not installed beta yet) and I think I have a persistence issue.

Pan  A opened - set to channel A and 100 watts
Pan B opened - set to same channel A and 10 watts, with DAX setup on this channel, COM port for program set to auto Switch TX

If I talk on Pan A, then want to send digital traffic I hit send in program, radio switched to Pan B but power goes back to 100 watts...  Do it manually (switch back and forth via TX) and same thing, Pan B power goes to 100 watts.

What am I missing here?

Thanks

David

Answers

  • dlwarnberg
    dlwarnberg Member ✭✭
    edited May 2019
    Well I found it part of it... DDutil puts it back to 100 watts when switching, however shutting DDutil down I can still not have separate RF power between Pan Adapters.. you set it to 10 watts it stays 10 watts, you set it to 100 watts it stays 100 watts...regardless of which Pan you select.

    Is it possible to set an RF power for Pan A to 100 watts and 10 watts on Pan B and the power will change when you change Pan's ??
  • Al K0VM
    Al K0VM Retired Member ✭✭✭
    edited May 2019
    David,
      Per the documentation, TX power setting are saved in a transmit profile on a PER BAND basis ( not per slice or per panadapter )  ... I would recomment that you configure TX Power for 100% in both voice and digital modes and then reduce the digital power with either the DAX TX gain control or the output level control within the digital program ( if available ).  

    AL, K0VM
  • dlwarnberg
    dlwarnberg Member ✭✭
    edited December 2016
    Not sure that will work.  Going to have to think about this one some more.

    I'll figure something out... I am a MARS operator, so we talk and pass traffic on the same frequency just about every net and I use a KPA500 amp that is used only for Voice an PAN A, then switch to PAN B for digital traffic (via DAX Auto TX switch for that com port).. while software is listening on Pan B (DAX 1) all the time.

    We have a new program setup now that once the message is loaded I can just send it, which works out well IF I can switch to PAN B on the same frequency, which then bypasses the amp and increases power (when in voice I only use about 15 watts to drive amp)..  (not sure if this makes sense)

    Anyway, maybe someone on the MARS side using a Flex will have a solution.
  • Jay Nation
    Jay Nation Member ✭✭
    edited December 2016
    David

    Also, the scale on the power slider is in percent, not watts. It almost never ends up being a 1:1 ratio. Set it with the audio level sliders in DAX, and your Digital apps while measuring with an external wattmeter.

    Right now it seems to be persisting at 10%, and 100% for you, but later on it may start persisting at some other percentage.

    It's not a one and done thing. DDUtil switching it to 100% / barefoot, repeatedly, has likely contributed to persistence memorizing 100% as your intended setting. Correcting it repeatedly will eventually solve this problem.

    Which is why many of us leave it defaulted to 100% and then tweak the audio sliders. We got tired of the battle.

    Starting over with a Factory reset, and not importing your preferences when Importing your saved/exported profiles should reset persistence to the factory defaults (Just like it was when you first unpacked it and plugged it in the first time) But I'm pretty sure that the power Slider defaults to 100% in the factory defaults. So that's not going to fix things for you.

    It pains me too when it persists in persisting things I don't want.

    I'm still trying to perfect a work around.

     SDRgadgets

    73, Jay - NO5J

  • dlwarnberg
    dlwarnberg Member ✭✭
    edited December 2016
    I guess I'm lucky, at the frequency's we are working at it's almost a 1:1 ratio, 1% shows almost always a 1 or 1.1 watt output on my LP-100A Digital Vector RF Wattmeter.. and 100% is right at 100 watts.

    I do like the DDutil for controlling RF out when using the AMP, bypass it sets 100% put amp in operate and DDutil automatically sets the RF out to what I preset, saved me from cooking the AMP more then once.

    Thanks for the reply Jay and Al

    David


  • Jay Nation
    Jay Nation Member ✭✭
    edited December 2016
    David

    Mine would likely be closer to a 1:1 ratio, if I eliminated a coax switch I use to select transceivers and about 12 feet of RG-8X. my 10% is usually 8-9 watts and 100% is usually 85 - 90 watts. So I probably underthought that ratio point I made a little.

    Any chance your Digital app could incorporate some power setting macro's into it's Send/TX button macro's ? 

    You might be able lock in on the correct setting that way.
      
     SDRgadgets

    73, Jay - NO5J

  • Bill W2PKY
    Bill W2PKY Member ✭✭
    edited December 2016
    On my 6700 if I select the TX ICON on a slice and then select a transmit profile with a certain power setting and then go to another slice and select a different transmit profile with a different setting I can go back and forth between slices and the power slider will be at the different and proper setting. After getting that working, save the GLOBAL profile and those settings will be there when you select the GLOBAL profile next time.
  • dlwarnberg
    dlwarnberg Member ✭✭
    edited December 2016
    Thanks Bill... I'll give that a shot

    Jay.. doubtful but will look into it..

    Thanks again all, as usual very helpful

    73's and Merry Christmas
  • Jay Nation
    Jay Nation Member ✭✭
    edited December 2016
    Bill

    Yep that's how it works for me too, but I've managed more than once to mess that up. But now I rely on a saved Export reload when that happens. A saved Export that I no longer re-save. I wonder if windows will let me make a file like that un-writeable. Hmmm!

     SDRgadgets

    73, Jay - NO5J

  • Bill W2PKY
    Bill W2PKY Member ✭✭
    edited December 2016
    Jay- The reload seems to add to what is currently in the RADIO so if you want to go back to a previous file ONLY I think you have to do the OKAY button Power On reset and then import the good profiles. How does that sound?
  • dlwarnberg
    dlwarnberg Member ✭✭
    edited December 2016
    Jay.. if the profile is a file and if you can find it you may be able to change the permissions on the file to be read only.. that should do it
  • Bill W2PKY
    Bill W2PKY Member ✭✭
    edited December 2016
    Profiles are saved by the IMPORT/EXPORT function to a directory you pick. They are dated files and are not disturbed by any other software. Check the manual for more information.
  • Jay Nation
    Jay Nation Member ✭✭
    edited December 2016
    Bill

    Yep You do need to press the OK button for a Factory Defaults reset, in order to wipe the existing saved profiles, and preferences from the radios storage.

    Luckily the last time I did the full reset, when I launched SmartSDR I immediately saved an Export of the radio "first" before clicking anything else. So all the Factory defaults were un-modified. So I'm hoping that means persistence got wiped clean too.

    The difference this time is, I set my saved Factory Defaults Export to be Read-Only.
    and then re-imported my current Export with all my profiles in it.

    It seems to be exactly the way it was before the reset now.

    Do we know for certain that the persistence values are part of the Preferences import?

    Or am I still wasting my time trying to eliminate stored persistence values?
       
     SDRgadgets

    73, Jay - NO5J

  • Bill W2PKY
    Bill W2PKY Member ✭✭
    edited December 2016
    On the import panel there is a choice to include Preferences; However, if you didn't export them then there is nothing to import.
  • Jay Nation
    Jay Nation Member ✭✭
    edited December 2016
    Ok I'll remember to uncheck preferences in the Export and do it again. I usually uncheck preferences on the Imports. I believe in overkill most of the time.

      SDRgadgets

    #FlexRadio IRC chat

      73, Jay - NO5J

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.