Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartSDR v1.9.13 and v1.10.8(beta) do not show radio. Worked with earlier versions of SmartSDR

Hi Everyone,

I'm connecting a 2 year old Flex-6500 to my laptop computer (Windows 10). It is a direct connection with an ethernet cable, through only my laptop's docking station. This arrangement worked fine before with earlier versions of SmartSDR (I think 1.4 and 1.6). But then I had a hard drive failure and decided to take the opportunity to update the software.

I first installed v1.9.13 onto my laptop. When I started v1.9.13, the radio appeared, though I needed to update the firmware and pressed the "update" button to start that process. The radio updated it's firmware, so presumably the ethernet connection was working. Then the radio would no longer appear on SmartSDR. I tried rebooting the laptop, power cycling the Flex, even both. One time when rebooting my laptop it went into a "windows repair" mode which implies the process did something strange to my computer.

I figured there might be a bug in v1.9.13 and decided to install the v1.10.8 which is currently in beta. The radio briefly appeard in SmartSDR and then SmartSDR crashed. I no longer saw the radio. Again I tried rebooting/power cycling everything (even the docking station just in case) with no luck.

Could anyone please suggest something to try?

Many thanks!

Geof

Completed · Last Updated

Comments

  • Larry _ NY8T
    Larry _ NY8T Member ✭✭✭
    edited July 2018
    Your firewall is probably blocking it. I have to create firewall rules during every update. Or you might have better luck connecting the radio through a router.
  • AA3RQ-Geof
    AA3RQ-Geof Member
    edited December 2016
    HI Larry- Thanks for the reply. I checked the Windows Firewall settings. All rules related to Flex are allowed for inbound, and there are no outbound rules for Flex which means nothing is blocked. I haven't tried connecting via a router yet.
  • David
    David Member ✭✭
    edited July 2019
    Have you tried different patch cables? Maybe there is problem with the one you are using causing intermittent failures.

    The other issue might be routing if you have the laptop using wifi to connect to the internet and the flex is connecting to the ethernet port on the laptop then there probably two networks configured and one default route. You could try not connecting or disabling the wifi and see if the keeps the connection to the flex.
  • Bill Ham - K0KO
    edited December 2016
    You might want to take a look at the release notes and update per the procedure specified.
  • Al K0VM
    Al K0VM Retired Member ✭✭✭
    edited November 2017
    I suggest opening a help desk ticket..
    AL, K0VM
  • VE7ATJ_Don
    VE7ATJ_Don Member ✭✭
    edited December 2016

    I'm with David on this one.  I have exactly the same setup (direct cabled 6500 to a Win10 machine) and had to go through 3 different Ethernet cables before I found one that worked correctly.  My suspicion is that some cables don't have 'all' the pins connected (or may be null-modem cables with 2 pins x-connected).

    It could very well be that the Ethernet cable has gone bad.  It would certainly explain the radio suddenly disappearing.  There's nothing specific within the changes from 1.6 to 1.9 which would affect the direct connection.  But, it's also worth a try to see if downgrading back to 1.6 (if the s/w is still available) brings the radio back on a regular basis.  If it comes back, then it's likely not the cable and that would help the Flex team.  If it remains 'flaky' (i.e. inconsistently there), then it's a pretty good guess it's the cable.

  • AA3RQ-Geof
    AA3RQ-Geof Member
    edited January 2017
    Thanks for all of your suggestions. I tried the following:
    * Two different Ethernet cables, connected directly between the host PC (via a docking station) and the Flex.
    * Tried using a completely different host PC. Tried the 1.10 beta and an earlier known version that worked (1.5.1).
    * Bought and tried two more new ethernet cables off Amazon, one CAT-5e and one CAT-7.
    * Verified that the host operating system is up to date.
    I do notice that the Ethernet lights do illuminate- Solid green on host PC and solid yellow on Flex, blinking yellow on host and blinking green on flex. I am guessing this means that there is communication. But in all cases, when I click on SmartSDR the radio does not appear.
    It's probably time for a help desk ticket. :)
  • AA3RQ-Geof
    AA3RQ-Geof Member
    edited January 2017
    I submitted a trouble ticket and got a fast response from Dudley that fixed the problem. Thanks!

    As per Dudley's instructions, I did a firmware reset of the Flex- turn the Flex off, press and hold the OK button, and turn on the radio while continuing to press OK. The front panel did a countdown from 5 and I released OK after the countdown was done. The radio appeared in SmartSDR and after re-updating the firmware it operates perfectly fine.


Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.