Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Network issue with v1.9.7

Hardy
Hardy Member ✭✭
edited June 2020 in SmartSDR for Windows
If you upgrade to 1.9.7 you cannot connect to Flexradio any more.

How to solve:
Connect your Flexradio with direct lan cable to pc with ssdr (NO DHCP !!!!)
Downgrade using SSDR 1.8.4.
Restore your profiles.

«1

Comments

  • Neal_K3NC
    Neal_K3NC Member ✭✭
    edited March 2017
    Hardy

    I have no problem connecting my radio to 1.9.7, I am afraid you will be worrying a lot of people with your note needlessly. Have you contacted Flex to see what is going on?
  • KY6LA_Howard
    KY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited June 2020
    This was an issue reported by some of the Alpha group who had fixed IP reservations in their DHCP Server. The solution seems to be remove the Fixed IP reservation in your DHCP Table Then Upgrade to 1.9.7 Then use SSDR FIxed IP reservation to set ur fixed IP NO Need to downgrade to 1.8.4 1.9.7 works OK
  • John G3WGV
    John G3WGV Member ✭✭
    edited December 2016
    I do have a fixed IP reservation for the 6500 in my DHCP and the 1.9.7 upgrade worked just fine with all my various home brew clients, SSDR and Maestro. Just powered everything up from cold this morning and it's still working perfectly.

    I suppose I ought to set up the SSDR static(?) IP address now it's available but as it ain't broke I've not attempted to fix it.
  • G4NRT
    G4NRT David N Bondy Member ✭✭
    edited January 2018
    I have upgraded to v1.9.7 on my FlexRadio 6500 and my Maestro (not without some trepidation I have to say!) and it all went very well.  
    No issues or problems found and I can attach from both the Maestro and from SSDR.

    David G4NRT
  • Hardy
    Hardy Member ✭✭
    edited December 2016
    Dear Neal,

    yes, I have contacted support.
    I tried several times. As soon as dhcp is used, there is no contact after upgrade.
    I can easy reproduce this issue. Only way ro solve is a direct cable connect
    and then downgrade.
    Others have reported this error in this forum too.

  • Hardy
    Hardy Member ✭✭
    edited December 2016
    Fixed IP reservation is a must here.
    What is "Then use SSDR FIxed IP reservation to set ur fixed IP " ?

    So there is a dhcp issue in Flexradio which should be fixed soon!
  • Ria
    Ria Member ✭✭
    edited November 2019
    I have use static DHCP reservation and upgraded to 1.9.7 just fine.
  • EA4GLI
    EA4GLI Salvador Member ✭✭✭
    edited November 2016
    A network issue is not necessarily a smartsdr software issue. I hope you resolve your problem but I also feel your post title is too alarmist. If it ends up being your network and not 1.9.7, what then?
  • KY6LA_Howard
    KY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited September 2016
    Hardy You mistook my words Flex has added the ability to set a fixed IP directly from SSDR rather than using a DHCP reservation. In some case, routers get confused if they see a fixed IP already set outside of the DHCP table The DHCP Issue is likely in the router as it forces the Flex to pick a different Initial IP. THE SOLUTION IS TO REMOVE THE FIXED RESERVATION FROM THE ROUTER
  • KF4HR
    KF4HR Member ✭✭
    edited February 2017
    Hardy, 1.9.7 works fine here!!!!!!!!!  No problems.
  • Lawrence Gray
    Lawrence Gray Member
    edited September 2016
    1.9.7 works fine here--DHCP with reserved address.   No issues at all with the upgrade or operation after the upgrade.


  • Ken - NM9P
    Ken - NM9P Member ✭✭
    edited December 2016
    To put Howard's post another way...some routers go crazy if you try to use BOTH static IP and Reserved DHCP IP for the same device at the SAME TIME. My ASUS router didn't have a problem, but others have reported problems. It may depend upon whether the static IP you are choosing is inside or outside the range that your router's DHCP is set to assign to DHCP clients on the net. Also, be sure that you are not trying to use a static IP that is on a different subnet from the rest of your Local Area Network.
  • Mike va3mw
    Mike va3mw Member ✭✭
    edited February 2018
    I think we should remove this post or at least rename the title. Can that be done. It could be "problems with 1.9.7 upgrade with DHCP reservation" Mike va3mw
  • Clay N9IO
    Clay N9IO Clay N9IO Member ✭✭
    edited August 2019
    Sorry not a very responsible post at all. I agree, re-name it. 
  • Dan -- KC4GO
    Dan -- KC4GO Member
    edited November 2016
    Mine did :), I have tried both individually and they work just fine, but together even if there set to the same it seems to dislike having both set.

  • Ken - NM9P
    Ken - NM9P Member ✭✭
    edited December 2016
    Dan...Just a question for diagnosis...is the Reserved IP inside or outside the range that you have set for DHCP to assign to DHCP clients? Mine was set to assign outside the DHCP range...I.e. My DHCP assigns port numbers 192.168.13.50 to 192.168.13.199 and the reserved ip was set for 192.168.13.200. I don't know if that makes a difference or not, but it might be another piece of the puzzle?

    Here, I confirmed that static ip worked and then went back to reserved DHCP ip because I don't need static ip.
  • Ross - K9COX
    Ross - K9COX Member ✭✭
    edited June 2017
    Lesson learned, never write something when you are angry and have not had time to think about it.
  • Eric-KE5DTO
    Eric-KE5DTO Administrator, FlexRadio Employee admin
    edited February 2017
    The preferred way to allocate IPs in modern networks is to use DHCP.  I cannot emphasize this strongly enough.  Use a static DHCP entry in the router if you want the radio to stay on the same IP address.

    Please don't confuse the addition of the Static IP feature as a suggestion from Flex that you should be using it.  Only those that absolutely HAVE to should be using the Static IP feature.  It should be considered an Advanced feature.  It is completely possible to put your radio on a network that you cannot access from your computer without also manually setting your computer's IP address.  Failing the ability to do this would result in you not being able to communicate with the radio without doing a factory reset and losing your settings.  Note that using Static IPs on a network the has a DHCP server is one easy way to end up with IP address conflicts.  This is not recommended unless you are comfortable with advanced networking.

    As others have pointed out, if you are trying to use a Static IP on a network where there is a static DHCP entry for the same IP address, this may result in problems depending on the router.

    I hope I haven't been unclear.  ;)

    ====================

    Now, with all of that said...

    Hardy, were you able to resolve your issue?  If not, I would recommend opening a helpdesk ticket so that we can help you figure it out.  They are likely going to want to know your network configuration, so be prepared to describe your topology (e.g. modem <-> router <-> Computer/Laptop/Radio).
  • Mark NS9N
    Mark NS9N Member ✭✭
    edited August 2018
    There is clearly a change in 1.9.7 which needs to be corrected. All previous versions worked fine with both static IP and DHCP ranges set in my router. Now with 1.9.7, I can connect fine with both my computer and Maestro when I have a direct cable connection between them. When I connect the system using my wired network, remember no change in my network, the radio will show up in the connection screen but will not communicate when the "connect" button is pressed. There should be no reason for me to change anything in my router or network to make this update work. BTW, the actual actually worked perfect over the wired network and when I return to 1.8 everything works perfect. We need a fix for 1.9. 
  • Eric-KE5DTO
    Eric-KE5DTO Administrator, FlexRadio Employee admin
    edited December 2016
    Mark,

    I'm happy to help resolve this issue and if a software fix is necessary, we can make that happen.  The best way to resolve this is to gather the necessary information so that we understand the problem and can replicate it here.  Unless you really want to post all of your network details publicly, I would recommend that we take the conversation offline.  A helpdesk ticket is always the right place to start.  Please email me directly ([email protected]) and I can help get that process going while also collecting your network details.

    We will report back to the thread what we find.
  • Mark NS9N
    Mark NS9N Member ✭✭
    edited September 2016
    Thank you Eric. Always appreciate the fast response from Flex. You have an email from me with all the details. Please keep up the excellent customer service.
  • Mike va3mw
    Mike va3mw Member ✭✭
    edited September 2016
    I have seen something similar ... possibly. At time I have to actually tap the radio on the radio list and then hit the connect. Just a thought.
  • KC9NRN
    KC9NRN Member
    edited October 2016
    My IP reservation didn't need to be changed after the upgrade, still works like a charm. I love it when things work. :D
  • Eric-KE5DTO
    Eric-KE5DTO Administrator, FlexRadio Employee admin
    edited August 2018
    OK .. I think we have figured out the root cause here.  Because our API currently has no authentication, we increased security by implementing a restriction to only be able to connect to the radio from Private IP addresses (RFC1918).  This is what was getting in the way here.

    We have a plan to optionally allow the user to turn off this security (and thus accept responsibility for potential issues as a result).  This is captured in our system as #3996.  In the mean time, using a Private IP address is a workaround.
  • Eric-KE5DTO
    Eric-KE5DTO Administrator, FlexRadio Employee admin
    edited December 2016
    As noted below, this may be due to using a non-Private Network address space on your network.  See the comments below for more info.
  • Hardy
    Hardy Member ✭✭
    edited December 2016
    Would have been nice to see such changes in release notes!

    So I, and all others with public ip addresses, have to stay on 1.8.4 until next version.
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    Yes.  But that will not be long.  We are testing a program change internally as I write this to allow the user to configure the radio to work on public IP address space.
  • Mike va3mw
    Mike va3mw Member ✭✭
    edited September 2016
    I would be curious to see how big the user base is for those on a public ip base. Interesting.
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    Hardy.  At this time the issue is only affecting a very, very small percentage of users.  We appreciate your efforts and they will not go unnoticed as we identified the issue and will have a fix out in short order.

    BTW, I hate to hear that you will no longer be supporting the Community. 
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    Right now that number is approximately an order of magnitude less than 1%.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.