Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

COM port in use error

Tim VE6SH Member ✭✭
edited March 2019 in Third-Party Software

I realize there have been other threads on dealing with COM port issues, but none captures the issue I am facing. I am a relative computer neophyte so excuse this question if it is obvious.

My computer is set up with one on board Com port (COM 1 in Device Manager), a add on two port serial card (COM 2 and 3) and a number of virtual ports (COM 4 to another rig, COM 5 to the Alpha, COM 6/16 for the Flex, COM 7 for the FLEX control, COM 8 unused and COM 9 for the Genovation Keypad). I don’t use COM 1 (it has no physical port) and COM 2, a physical port, is used for the rotator. So far so good.

I wanted to use COM 3 with the SteppIR controller (using the S12 null modem cable).  Connected and could not get the controller to talk to any one of DDUTIL, SDA100 control program by W8LP or Commander in DXLab. I have the SDA100 controller set up correctly (19200 baud and Kenwood protocol) and am using the DATA OUT port on the back.

I was away for a few weeks and left this issue until I came back. When I tried to connect again from any of the programs I got the “port already in use error”. In fact, I deleted the SDA100 programs (properly) and reinstalled it, but now I cannot even open that program without getting “invalid port” error (ie: program does not even start).

No problem I thought maybe I have some hidden ports. Followed the instructions on the Flex site (running CMD as an administrator), but I have no hidden ports. DDUTIL and Commander still give me a “port already in use” error when I try to use COM 3 to connect.  I physically removed the cables from the COM port as well, but get the same error. Keep in mind this is a physical COM port on a two port card and the other COM port works fine.

Should I delete COM 3 in device manager? If I do that what happens to COM 2 being on the same card? If I delete COM3 can I reinstall it (ie: will WIN 10 recognize it as a physical port even if deleted?). Any other ideas as to what could be causing this issue?

Many thanks in advance.




  • Al K0VM
    Al K0VM Member ✭✭✭
    edited November 2017
    Instead of removing COM3, I would try disabling COM3 in the device manager see if anything complains.. Reboot thePC and see if anything complains..  The device manager might also indicate if it thinks its a VSP or hardware port.. ( look at the driver info ).. If that all looks clean, re-enable COM3 and try again.

    AL, K0VM
  • Tim VE6SH
    Tim VE6SH Member ✭✭
    edited March 2019
    Thanks Al. I did that and no change The driver info does not suggest it is a VSP, but let me kook again.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.