Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

PowerSDR 2.7.2 Lower Band Edge Marker Error on 6m

Mick
Mick Member ✭✭
Please can anyone advise?  The lower Band Edge Marker on 6m Band is incorrectly displayed.  The red text at the bottom shows 50.000 which is the correct lower edge for the band, but there is no band edge vertical red line here and the top text at 50.000 is the default colour.  However at 50.080.0 the top text is red and the red band edge vertical red line is underneath, but here the bottom text is the default colour?  Wrong data in the database.xml file perhaps, but I don't know what I'm looking for and it's a large file.  I'm happy to to edit the file to correct this but need a starting point please. I've only just started using the 6m band so I haven't noticed it before.  Many thanks. 73  Mick M0GWD  UK.

Answers

  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    Band edge data is not stored in the database.xml file; it is controlled by the TURF file that has been applied to the radio.

    I'd really need to see a picture of this issue as I cannot tell what is wrong from the description alone.
  • Mick
    Mick Member ✭✭
    edited September 2016
    Hello Tim, thanks for the very quick reply.
    I have taken a screen shot saved as a .png file.  Thanks Tim.  Mick M0GWD

    image
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    OK.  There is a bug in the 2.7.2 code that incorrectly generated the band marker text label for the waterfall display.  That is what you are seeing at 50.000.000.  I have added that to our bug tracker for further investigation.
  • Mick
    Mick Member ✭✭
    edited September 2016
    OK Tim.  All understood on the TURF file too and not the database file.  Down to my lack of knowledge.
    Thanks for looking into it.  I'll leave it with you.
    All the best from the UK.
    Mick M0GWD

  • KE9NS
    KE9NS Darrin Kohn Member ✭✭
    edited January 2020

    FYI: I just fixed that bug in my PowerSDR ke9ns RevT9  (090416T9) today.

    download at ke9ns.com/flexpage.html


  • Mick
    Mick Member ✭✭
    edited September 2016
    Hello Darren, good morning

    I've uploaded and install T9.
    6m Band red band edge marker line and text now spot on at 50.000 (thanks) but the error red line is still there at 50.080.0?  Is it possible to remove that red line please at 50.080.0 as part of your fix?
    Thanks for doing this Darren.  Very much appreciated.
    73
    Mick M0GWD.
  • KE9NS
    KE9NS Darrin Kohn Member ✭✭
    edited December 2016

    OK.  I found the 2nd reference to the 50.08 issue in the code. So it should be all fixed.

    I uploaded a new installer. you may need to uninstall the prior T9 before running the new installer.


  • Mick
    Mick Member ✭✭
    edited January 2020
    Hello Darrin, good morning
    I've done as you suggested and uninstalled my version of T9 and installed the later version of T9.
    It installs fine with no apparent issues.
    I now get the following Fatal Error message when opening T9, please see image.
    I also get exactly the same message now when opening the original FlexRadio version of 2.7.2.
    image
    I thought that I'd best let you know as soon as possible.
    Thanks Darrin
    73
    Mick M0GWD

  • KE9NS
    KE9NS Darrin Kohn Member ✭✭
    edited December 2016

    Go download the installer again.

    I have been trying to get a good Installer program to use with PowerSDR.

    I did manage to find a very good Installer, but in my haste, I forgot a few items.

    Should be good now.

  • Mick
    Mick Member ✭✭
    edited September 2016
    Hello Darrin.  Excellent thank you.  Now running Version T9 with the Flex 5K on a Win 10 PC and also with a Flex 1500 on a Win 7 PC.  Both working fine with 6m band edge markers perfect.  Thanks for all of your hard work Darrin.  Much appreciated. I've made a small donation to the cause via PayPal. 73 Mick M0GWD
  • KE9NS
    KE9NS Darrin Kohn Member ✭✭
    edited December 2016

    Thank you very much !

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.