Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

iOS app - Repeater Offset Bug?

George Molnar, KF2TGeorge Molnar, KF2T Member ✭✭✭
edited November 2017 in SmartSDR for iOS
When using SSDR for iOS for 2m FM work (via transverter port) there seems to be a bug in the negative offset setting. Simplex and plus 600 work just fine, but minus 600 does not. Such operating works fine in SSDR for Windows. Anyone able to confirm? 73, George

Completed · Last Updated

Comments

  • Watts - K4QJZWatts - K4QJZ Member ✭✭
    edited November 2017
    I have found the same problem in both the iPad and iPhone versions. I had to resort to setting it up as simplex with a transmit frequency (repeater input) and another for the repeater output.
  • Joe - KC2TNJoe - KC2TN Member ✭✭
    edited March 2017
    I have not experienced that problem. However, I did set up priories for Mic, Global, and Transmit to be consistent with what iPone settings worked. I use TX1-3 on my 6700 for PTT on my Xvtr's and they must be enabled properly according to your setup. Also MIC must be set to iPhone or iPad. Once I got those set properly I can go to any repeater Plus or Minus offset regardless if I have a memory setup for it. Setting a memory will recall the appropriate profiles for each memory saved.
  • Joe - KC2TNJoe - KC2TN Member ✭✭
    edited March 2017
    Pretty cool! It turned my iPhone into an HT! Now if Flex can implement C4FM......Just saying!
  • Joe - KC2TNJoe - KC2TN Member ✭✭
    edited March 2017

    Well, maybe I spoke too soon. After working fine for most of the day it seems the settings aren't holding any longer. As stated by George, everything works fine from the Desktop and SSDR but now the operation from iOS is inconsistent. Sometimes it works and others NOT!

    I notice while sitting at the desktop and watching the events as they occur, when operating from the iPhone and iOS, the PTT on iOS operates the 6700 AND Keys the Xvtr, but there is NO power output at times. Checked ALL the settings for Offset, Tone, FM, CTCSS ON, but no power output. I go back to the desktop and ALL is fine. Go back to the iphone and it works for a few times but then drops out again. I don't understand why or how when the Xvtr is keyed in FM mode I get ZERO output?? This only occurs from the iOS app.

    I also notice if I delete the repeater from memory and just set the options manually, neither the Minus or Plus offsets give me power out on FM even though the Xvtr is keyed.

    BUT if I select simplex I DO get power out.

    So something Goofy is going on with the offset selections. But why it's intermittent is confounding!

    BTW - I know Marcus has ordered a Transverter to do more testing and support. So, this problem may fall into that realm?? Even though the 6700 does support 2M FM natively.

    This problem explanation is for Marcus mostly.

    Joe - KC2TN

  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    I have entered this problem report into our bug tracker (#56) for additional investigation. Thank you for the defect report.

  • Watts - K4QJZWatts - K4QJZ Member ✭✭
    edited November 2017
    I have noticed the memory data base will not hold the repeater offset if entered from the iOS App. I modified a memory input file with Excel and it all worked. But when I updated the memory file via the App the offset went back to 0. Again I was trying for a negative offset. Could this be a data base hiccup? Hope this helps. The application is great and has significantly added to my ability to make use of my 6700, Thanks!! Watts K4QJZ

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.