Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Winkeyer and HRD DM780 character spacing/character loss/workaround

DH2IDDH2ID Member ✭✭
edited December 2016 in SmartSDR for Windows
This is not a SmartSDR problem or bug at all, but the workaround I found might help
clear up a problem that exists between HRD DM780 and the SmartSDR software
winkeyer.

Some hams I know have the same problem: Connecting the DM780 winkeyer to
the SmartSDR software winkeyer leads to irregular spacing and character loss, which is
easily repeatable.

There are some programs, which are able to use a hardware or software winkeyer,
like Log4OM or CWType by UA9OV. All these programs - and DM780 - have no problem
at all connecting to a hardware winkeyer. Only DM780 has the issue with the SmartSDR
software winkeyer described above.

Now I like to log all my QSOs with HRD Log and I do a lot of digital work with WSJT-X
and JTAlert-X and DM780, which are all able to log to HRD Log.

For CW I use CWSkimmer 1.9, SDRBridge and CWType or DM780 for short QSOs and CQing, having my paddles ready to step in for a chat.

Now I found that connecting CWType to SmartSDR via the software winkeyer port first,
closing the program and then starting DM780 clears up the CW problem!
What?!? Maybe someone can find the solution to this riddle...
The only thing which comes to my mind is that CWType somehow clears up a clogged pipeline somewhere in the virtual maze ;-)

I'll also post this in the HRD forum.

73, Alex - DH2ID

Answers

  • Mike PeronMike Peron Member ✭✭

    Hi Alex,

    Four years from your above Post, I curious how this turned out for you.

    I am having a similar problem with DM-780's CW Winkeyer sending Macros to my Flex 6600M. Odd, since it worked perfectly for over a year. I updated HRD software from v6.6 to the latest v6.7 with same result. The DM-780 Winkeyer's control panel shows "connected" and keys the Flex with the canned "test" message using the button on that Control Panel. When pressing any Macro, I get the error message "Winkeyer is not started". Put in a support ticket at HRD and they spent an hour over the phone and on TeamViewer trying to fix the problem. No joy. They are stumped and have reached out to FRS for help. I even upgraded my Flex software from v3.1.8 to current 3.1.12 with same failure. I was asked by one of the HRD Beta-testers to make a Post here on the Flex Community site which is my next task. Before doing so, I search this Community archive and found your two 2016 posts. The only thing I can think that may have caused it is a Windows 10 update. Comments and suggestions would be greatly appreciated. Thanks in advance. 73, Mike WB6UTW

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.