Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartSDR does NOT see 6500 on LAN, but it's defintitely there.

New setup of a Flex-6500, cannot see it with SmartSDR.  does not show up on the left.   I can ping it, I can see it on the network, but SSDR can't.  Irritating.   Win7 firewall is supposedly setup to allow the required ports, this is bizarre.   Both the 6700 and the PC are connected to the same switch.   Have tried going through another one to eliminate that possibility.  

Completed · Last Updated

Answers

  • Mark_WS7MMark_WS7M Member ✭✭✭
    edited May 2018
    So I assume when you pinged it somehow you found it by Mac address? SmartSDR has to see UDP packets from the radio to find it. The only reason it would not show up on your PC is somehow UDP packets are not getting from the radio to your computer. One thing to try: Plug your computer LAN port DIRECTLY to the radio. I know this sounds weird but both should get a private IP and then try running SmartSDR. If it sees it then you know the problem is not in your firewall. If you do not see it in this case then try disabling Windows firewall completely and see if that helps. I have had issues in the past with Windows firewall doing strange things.
  • Lee MaiselLee Maisel Member
    edited March 2016
    Yeah, FING sees it, I can SSH to it, I'm going to disable firewall next.  I'll keep you posted.  What ports exactly are necessary for the 6500?

  • Lee MaiselLee Maisel Member
    edited March 2016
    OK.. Turned firewall off.  No change.  I'm going to try from a different PC.  UGH.. maddening.

  • James MaddenJames Madden Member
    edited November 2016
    Try restarting your radio . I have to power cycle mine twice for it to show up. I believe this is a defect in the dhcp software in my 6700. Same problem with my first 6300, Jim
  • Lee MaiselLee Maisel Member
    edited March 2016
    Thanks Jim, I have power cycled it multiple times.   I can see it on the network from multiple computers, PING it, get an SSH session, etc.  Installed SSDR on another PC and same deal.. Won't see it.  this is aggravating.    is there no diagnostic menu from the front panel? what is the display for?
    Thanks!

  • Lee MaiselLee Maisel Member
    edited March 2016
    OK, So I direct connected from the radio to the PC without any hubs, switches, etc in between.. Still a no-go.   In fact the PC does not get an address from the Flex, as it self assigns in the 169 range.     The Flex is making DHCP requests, and getting an assigned address, which I am able to see on the router.

    I tried disabling the NIC on the PC, completely powering down the 6500, rebooting it, waited for it to come up completely, re-enabled the NIC on the PC, and still did not get a DHCP assignment from the 6500.

    Does anyone know what PORT address the Flex is  listening on so I can see if I can connect to it?

    Im ready to rip my hair out already.
  • Lee MaiselLee Maisel Member
    edited March 2016
    Tried doing a factory reset on this thing, it CLAIMS to do so, then comes up with the callsign, obviously didn't clear anything.
  • N7BCPN7BCP Member ✭✭
    edited November 2016
    Although there could be a lot of causes for not finding the flex on the network, I had this happen when my laptop's wireless connection to my home access point was set to public which blocked some traffic. Wires hark showed the discovery packets but the radio would not show up in the smart sdr radio chooser. Setting my wireless connection to private/home resolved the issue.
  • DH2IDDH2ID Member ✭✭
    edited December 2016
    Lee, where is your DHCP-Server? Mine is my DSL router, which is set
    for static IP numbers for my Flex6k5 (and all my Android devices).

    My setup is:
    Router DHCP/static
    <-> Gigabit switch <->
    |-> Sony VAIO i7 notebook
    |-> Flex 6k5
    <~> Android tablets and Smartphones
    <~> serveral other notebooks and SmartSDR remote.

    This setup works only as long as I start my router first !

    As I understand you have a Flex6k7 AND a Flex6k5 connected at
    the same time? Maybe there is the issue? Have you tried to connect
    only the Flex6k5 ?

    Alex - DH2ID
  • Lee MaiselLee Maisel Member
    edited March 2016
    Hi Alex, no, I ONLY have ONE Flex, and it's a 6500.  :)
    at this point, I'm thinking only a hard reset will fix it, but I can't get it to reset to factory defaults.

    Wireshark shows the radio at port 4662
  • Mark_WS7MMark_WS7M Member ✭✭✭
    edited March 2016
    Lee,

    I found the factory reset to be a little strange.  You hold the middle button then turn the radio on.  You have to keep holding the button as it will state factory reset and count down.  If you let go before it completes the count it aborts the reset.

    This is how mine works.  Are you sure you are holding the middle button completely in until that count down finishes?
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    First off, the callsign fields are not reset with a factory reset, along with some other radio specific data.  Only the profiles, persistence and waveforms are reset.

    Second, based on your description, if the radio is getting the proper IP address from your DHCP server, then I suspect there is a Internet security suite / virus scanning program that is blocking the radio discovery packet (broadcast) from your PC.  This is usually the case in 99% of the time when there are issues like this.
  • Lee MaiselLee Maisel Member
    edited March 2017
    HI Tim, I have disabled Windows FIrewall, Avast's firewall, have tried using other machines without the A/V software and no firewall, direct connections, through the router itself, through a network switch, etc.  Pretty much every variation I can think of.   Should I try a very old version of SSDR?  Is there an application that will force a firmware upgrade?  Is there a way of finding out FW version with the front panel?
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    I can assure you that downgrading to a previous version will probably not make a difference and unless you can connect to the radio, there is no other mechanism for doing a firmware upgrade that has to be in-sync with the version of software you are running.  I see you have an open HelpDesk ticket.  I think it is best we address this issue using the HelpDesk
  • Lee MaiselLee Maisel Member
    edited March 2016
    OK, after going through FIVE computers, and disabling all AV and Firewalls, and still nothing, as a last resort, I got the oldest version of SSDR you had online, (1.2.17)
    And installed it..   LO AND BEHOLD, the radio magically appeared.  I did the update, and now I will try the newer version of software.
  • Lee MaiselLee Maisel Member
    edited March 2016
    SUCCESS!!!!   After using 1.2.17 to do the Upgrade, I was then able to see the radio with 1.6.21 (latest) and let it do it's upgrade, and FINALLY was able to get in and actually use the software!   YAY!
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    Ahh.  You indicated in your post this was a "new" setup, but it is an old radio, not a new one which was confusing and why we went down the path of a problem with a firewall.  There was a change in the format of the discovery protocol (v1 to v2).  If the radio is running very old firmware it is using the v1 protocol. 
  • Lee MaiselLee Maisel Member
    edited March 2016
    LOL  Sorry for the confusion, NEW to ME.  :)  
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    No problem.  We haven't run into the discovery protocol mismatch in a long while because the uptake of a new version of SmartSDR is usually in the high 90% range within 96 hours of the release.  Have fun with the radio.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.