Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

FLDIGI RTTY Flex 6300 TX w/no audio

Mike Sonn KF9AF
Mike Sonn KF9AF Member ✭✭
edited May 2020 in SmartSDR for Windows
I have FLDIGI working with fine my Flex 6300 on most digital modes. However, I cannot get it transmitting properly on RTTY.  Decode is not an issue.

I see audio out in DAX Control Panel and DAX "TX" is active (blue)..
SmartSDR shows active "Level" in the P/CW pane and "DAX" is blue.
I'm only using Slice A until this gets working properly and Slice A is set to DAX channel 1.
The Flex 6300 goes into transmit.
Despite RF Power setting, I have zero output, and no audio in "Mon".

Maybe related and maybe not, CW in FLDIGI does not work either...

Seems there is something obvious I'm missing.  I've Googled setup and everything I find, including videos, seems to be a year or more old, using non-current DAX windows or they are prior to RTTY working on SmartSDR.


  • Randy Diddel
    Randy Diddel Member
    edited January 2017
    I too have both issues (RTTY and CW).  Would love to find the solution.  


  • Bill Turner
    Bill Turner Member
    edited December 2016

    On the "PHNE" box on the right side of the screen, make sure the Low Cut and High Cut tones are set wide enough to be outside of the tones you are transmitting. Otherwise they will filter out your TX tones.

    73, Bill W6WRT

  • Keith Flint
    Keith Flint Member
    edited December 2016

    I just set fldigi up with my flex6300, and at first I had your problem, but then I noticed that I did not have DAX set for CH1. so my RX sstreams in the DAX control Panel was greyed out.

    I used the new RTTY mode in SmartSDR which is great. I had to adjust the frequency of fldigi up about 100 hz or so so that my mark and space tones were aligned with the filters (vertical lines) in my slice A Receiver. Please contact me off this reflector if you want to see my setup. Make sure you are using the4 Latest SmartSDR release and Fldigi 3.23.05 or later with the Rigcat SmartSDR- SliceA.xml set up for a DAX virtual com pair in the device with the toggle RTS for PTT checked and the DTR +12V checked, and use rigcat checked, baud rate 115200 then do an itialize and a save.

    Hope this helps



  • Al K0VM
    Al K0VM Member ✭✭✭
    edited November 2017
      Does you have FLdigi configured for AFSK ( not FSK) ? Is "DAX TX audio" selected in the Fldigi sound card Playback ?
      In the DAX control panel does the TX stream show signal when transmitting ? is TX enabled ? 
      In SmartSDR does the level indicator show signal when transmitting?  Is dax P/CW panel enabled?  Does the PHNE panel Low Cut/High Cut  include the afsk tone frequencies ?

    AL, K0VM

  • Mike Sonn KF9AF
    Mike Sonn KF9AF Member ✭✭
    edited December 2016
    Well, this certainly isn't intuitive at all...and I got pretty good at making software work with PowerSDR.  I think I need a few more years with SmartSDR (SSDR)...

    First, thanks to everyone that offered suggestions.  I checked and rechecked everything multiple times and I was about ready to throw in the towel.  Keep in mind, I've only had my 6300 for 2 weeks today, coming from a Flex 3K for 4 years, then a 5K for the last year.

    What stopped RTTY from working in my setup was, when selecting RTTY mode in SSDR, the default selection (ie - FIRST time I ever used RTTY in SSDR), in the "P/CW" pulldown for the mic setting is, "RTTY Default".  What I found was, ANY MIC selection in the P/CW window pull-down works with FLDIGI, EXCEPT for "RTTY Default"!  What? Yup.

    Once I selected another MIC setting from the pull-down, all is well.  Now, when I change my mode in SSDR to RTTY, my new MIC selection comes up and it works.

    My Settings NOW:
    In FLDIGI - "Configuration/Rig/RigCAT", Select "Use RigCAT". (Make sure you've loaded SmartSDR-Slice A.xml in the appropriate folder.)

    For "Device" ; Choose the Slice appropriate CAT/COM port shown in SmartSDR CAT. Baud 115200, Stopbits 1

    Select CAT command for PTT

    Click Initialize/Save/Close

    I did NOTHING in the Hardware PTT tab in the configuration window.

    SmartSDR -
    Select the proper mode from the Slice Flag and be sure you select a DAX Channel on the Flag. Do not do anything with DAXIQ Channel on the left side of SSDR.

    In the P/CW window on the right, in the MIC pull-down, anything except "Default RTTY" worked for me.  I just went with "Default".  Make sure DAX is blue and I use MON set at a low level just to assure I have sound.  After time, I'll probably turn that off.

    CW STILL doesn't work, but I use the CWX function in SSDR so I don't really need it, but it would be nice, as eventually, I want to run N1MM for contesting.  So I'll need to figure out what I need to get it going.  Maybe I can use my WinKeyer...???

    Of course, its possible there's another setting I need to change to make it work with "Default RTTY" MIC setting, but unless someone has a suggestion, it now works.

    Thanks again. This is a great informational community where people are so willing to help.  One day I'll be able to return the favor I'm sure.

    Mike  KF9AF

  • Mike Sonn KF9AF
    Mike Sonn KF9AF Member ✭✭
    edited December 2016
    I do not see where I can select AFSK vs FSK in  FLDIGI, but alas, its working now...

  • Mike Sonn KF9AF
    Mike Sonn KF9AF Member ✭✭
    edited December 2016
    Thanks Keith.  I did update FLDIGI to a new version tonight. is now available.  I do have the latest SmartSDR as I've only had the 6300 for two weeks.  I used different setting than you stated above in that last sentence.  See my notes below.
  • Mike Sonn KF9AF
    Mike Sonn KF9AF Member ✭✭
    edited December 2016
    Check out my solution below for RTTY.  CW, not so much...YET.
  • k3Tim
    k3Tim Member ✭✭✭
    edited May 2020
    I noticed this also on a 6500. Took Keith's advice and RTTY profile works properly now. I set the RTTY tones to be centered at 1Kc instead of std.

    Also note - The Tune button wouldn't turn on the RF until the tones were set properly. So one can test / troubleshoot SDR + FLDIGI by getting tune to engage as a first step. 

    Thanks for the advice.

  • Mike Sonn KF9AF
    Mike Sonn KF9AF Member ✭✭
    edited December 2016
    Upon further reading and knowing what to search for helps...

    I have found that FLDIGI does not key the SSDR when in CW mode.  FLDIGI is apparently only an AUDIO program.  With FLDIGI in CW, in SSDR, select DIGIU or DIGIL depending on band and CW works.  You'll need to reconfigure the filtering under DIGIU (or L) for more CW friendly filters.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.