Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Windows 10 reporting Flex USB drivers are unsigned

Steve WI2W
Steve WI2W Member
edited February 2020 in FLEX Series (Legacy) Radios
Trying  to get PowerSDR 2.7.2 and Flex-1500 running on ASUS x205ta laptop. Did a Windows 10 RESET to start with a fresh system. After installing PowerSDR, DEVICE MANAGER is showing the Flex USB kernal with a yellow caution icon and reports that the drivers are unsigned. 

Rebooting the laptop with driver signing checking disabled PowerSDR will recognize the Flex-1500 and connect to it. After pressing Start in PowerSDR there is no activity in the panadapter but pressing the band buttons activates the filter relays in the Flex-1500.

Suggestions would be appreciated.

Thanks es 73,
Steve WI2W


  • KD7YDW
    KD7YDW Member ✭✭
    edited February 2016
    Did you install by right clicking and install as Administrator? Also once the app is installed, change the properties to "Run as Administrator"
  • Steve WI2W
    Steve WI2W Member
    edited February 2016
    Yes. Also tried running in Win 7 compatibility mode. Thank you for your suggestions.
  • John
    John Member
    edited June 2018
    I find it very strange that some people can have no problems when they upgrade say from win8 to win10 and then others have big problems. I am one of the fortunate one's to just run the win10 link to their installer ( the one they push to everyone who is able to upgrade ) and away I went. I simply carried on where I left off. No issues no problems.
    Perhaps the trick after a fresh install is to install the flex software first to prevent anything else from grabbing the ports and not letting go.
    Hope you sort it out......
  • Sergey R5AU
    Sergey R5AU Member ✭✭
    edited April 2017
    Hi All, just report:
    i did plenty of upgrades from Win7 and Win8.1 on Win10 and Win10Pro Pre (what actually i use on Paralles Virtual Machine with my MAC) - no issues mentioned here with Flex SW with drivers signature or anything else

    P.S. i never touch Win Registry  for any clean up or manual entries
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    I have converted this topic to a support HelpDesk ticket (http://helpdesk.flexradio.com) for expedited issue resolution.  If anyone else is experiencing an issue similar to this one, please submit a HelpDesk support ticket for issue resolution.
  • Steve WI2W
    Steve WI2W Member
    edited February 2016
    ASUS x205TA problem solved. Two BIOS settings needed to be changed.

    1. Disable Secure Boot
    2. Change the USB Controller setting from XHCI to EHCI.

    Thank you everyone for your help.
    Steve WI2W

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.