Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

SmartSDR TCP/IP API - "xmit" command - unexpected behaviour

IW7DMH, Enzo
IW7DMH, Enzo Member ✭✭
edited February 2017 in FLEX-6000 Signature Series

during a test on my voice keyer I found the following (I suppose) problem: I sent a "xmit on" command while the radio was turned on, but no client was connected (SSDR off).
This caused and immediate transmit (MOX button enabled) as soon as I started SSDR.
Probably commands like "xmit" should be rejected by the radio when no client is connected.

Can you confirm this is the right beaviour? (My rig is a 6300)

73' Enzo



  • Eric-KE5DTO
    Eric-KE5DTO Administrator, FlexRadio Employee admin
    edited February 2017
    This is indeed a bug as I just confirmed the behavior.  I have entered it as  issue #2990 in our tracking system.  Thanks for reporting this.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.