Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Accidentally deleted Flex "network" in Windows 7 Network and Sharing Center

Fred-NA2U Member ✭✭
edited August 2019 in SmartSDR for Windows
After an ugly unrelated computer incident yesterday I deleted the "network" that was my Flex 6300 in Windows - Control Panel -All Control Panel Items - Network and Sharing Center.  It was not named Flex, it had a generic name and since it was a network "incident" I deleted what was an unknown network.  I have tried reconnecting the Flex to the Ethernet port on my PC with the Flex turned and turned off.  Have rebooted both PC and Flex multiple times.  I can't seem to now get the computer to recognize the Flex connection.  I have followed Tim's instructions for "How to Connect your FLEX-6000 to a LAN" from exactly one year ago today:

A “directly connected” network configuration is fully supported by the FLEX-6000. When you connect a PC and a FLEX-6000 together with the supplied Ethernet cable, the FLEX-6000 will sense that it is directly connected to a PC and automatically configure its Ethernet port to properly communicate with it. No special Ethernet cables are needed. In this configuration both the PC and the FLEX-6000 will self allocate a "link local" IP address automatically allowing for them to communicate properly. However the PC must be configured to obtain an IP address via DHCP for link local to work properly.  Refer to the diagram below.

I checked the Ethernet cable.  It's simple.  I unplugged and replugged both ends of the cable.  Network lights on connection at radio are one flashing yellow and one flashing red.  On the computer one green and one flashing yellow.  Running a 25' CAT cable down the hallway works but that solution will expire in approximately 32 hours.

The initial setup of the radio was simple yet I can't seem to recreate it.  Related posts to the Community don't address this type of pilot error.  It worked, all of the hardware worked.  I deleted the 'network'.  What to do?

73 and thanks from the desert,



  • K5CG
    K5CG Member ✭✭
    edited October 2018
    I had this issue and it was the Windows Firewall needed a rule for the 169.254/16 network. Test by turning off the Windows Firewall completely and see if SmartSDR then sees the radio. Perhaps your rules were corrupted when you had your "incident".
  • Larry Loen  WO7R
    Larry Loen WO7R Member ✭✭
    edited January 2016
    Better still, check you Windows firewall and see if there is a rule that lets the Flex machine through.  There should be a rule that allows anything on the local subnet through.  That's probably what you somehow deleted and it's usually a pretty safe rule.

    Also, you may be able to "restore defaults".   Control Panel -> System and Security -> Windows Firewall.

    Depending on your third party software, your firewall may be controlled by a third party instead.  If so, the Windows Firewall screen will tell you.
  • K5CG
    K5CG Member ✭✭
    edited October 2018
    Fred, I re-read your post and I'm not sure, but perhaps I misunderstood and your LAN network connection is still missing.
    From the Control Panel->Network and Sharing Center, click on "Change Adapter Settings". You should see your network interfaces listed there. Are you saying that you have none?
    If that is the case then perhaps you've accidentally deleted the driver for your NIC when you deleted it. If that is the case then you need to get the drivers onto a USB thumb drive or some media that would allow you to install it again. Knowing what drivers you need is the tricky part. If it is an add-in card then that should be easy enough. If it is a built-in NIC on your motherboard then you need to figure that out from the support website for the manufacturer of your PC (from another PC obviously). Then re-install the drivers.
  • Fred-NA2U
    Fred-NA2U Member ✭✭
    edited January 2017
    Solved by using System Restore.  Fortunately I had a recent point.  Sorry for bandwidth.
  • Clay N9IO
    Clay N9IO Member ✭✭✭
    edited August 2019
    Lucky man.
    It took me a couple of years to realize there is a REAL need to create a Restore Point.
    My xyl is particularly **** her last few win 8.1 laptops, has REALLY come in handy there!

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.