Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

usb hubs

Bill-W9OL
Bill-W9OL Member

Even though I 'think' I have solid ground connections to all equipment, I still get rfi problems, even working low power JT modes. I have little clamp ons on all cables. But the antennas go directly over the roof. (note I'm strictly barefood, no amp)

So can anyone suggest a USB hub that is rf resistant? The one I'm using was advertized as being so but with all the cables to keyboard, keyer, mouse, KNOB etc. I'm looking for any suggestions.

pse et tu de w9ol

Completed · Last Updated

Answers

  • Sergey R5AU
    Sergey R5AU Sergey Member ✭✭
    edited April 2017
    Hi  Bill, I am using this one https://usb.brando.com/10-port-usb-3-0-hub_p03052c0039d015.html
    trouble free , without strange behavior and with metal body
  • Mark_WS7M
    Mark_WS7M Member ✭✭✭
    edited January 2017
    Hi Bill,

    Sorry to hear you are having issues.  RFI is a real pain at times.  I've dealt with it and I'm sure I still have it.

    For me, not sure about you, the issue is that my station ground runs a fair distance.  I am guessing about 30 feet and when I first had it as a big copper wire it acted better as an antenna perhaps than my real antenna and did a very good job of vectoring the RF right back into the shack.

    My issue was that things would just glitch.  IE transmitting CW, or what ever and suddenly the radio would just reset.  In searching I notice you posted something on grounds but there was no text in the post. 

    Anyway just a side note, what has really helped me is two things:

    1) Get the antenna further away.  When I put up my End Fed wire the feed point is some 75 feet from the shack and the antenna slopes up and away pretty much to a big tree.  This alone took most of the RF out of the shack.

    2) The RF eliminator ground in this article:

    https://community.flexradio.com/flexradio/topics/how-to-build-a-quiet-station

    Since my ground was so long I followed the procedure in this document for the RF elminator ground and it seems to have really worked.

    So back to your question:  USB hubs... Well I am using about the cheapest ones out there and see no RF problems with them even at 1kw:

    http://www.amazon.com/gp/product/B000KUQ8FG?psc=1&redirect=true&ref_=oh_aui_search_detailpag...

    I have two of these.  One near the computer and one over near the equipment and amp.  No issues.  I will not say they are the best and from what I can see there is no way to ground them as they use a plastic case.  I am just pointing out that by dealing with the RFI using the eliminator and using these HUBS I don't have any issues.

    I know the moment I post this some RFI will decide to show up.  Just Murphy's law.
  • WW1SS - Steve
    WW1SS - Steve Member ✭✭
    edited April 2020
    I am using one called "pluggable" no issues with it whatsoever. Got it on Amazon.

    Steve
  • Bill-W9OL
    Bill-W9OL Member
    edited October 2016

    Thanks for your comments. I live on a Chicago area small lot.

    Shack is in basement, right next to Power Circuit breaker box and I have the heat manifold for the copper pipe heating system in the concrete basement floor.

    Right out side the back wall is my com edison box, with it's ground rod.

    and right next to that is the cable feed box with it's ground attached to the edison ground.

    I'm sure the problem is due to the tower being next to the house and wires directly over the ridgeline of the house to a big tree in front on the parkway.

    Basically I'm living inside the antenna.

    I will say that my previous flex5k radio did not suffer from rfi anywhere as near as I am now. 

    But that's apples and oranges and not a fair comparison.

    I'll keep checking and rerouting cables till I find the offending in shack leakage.

    But with my ground system being so close and so complete, I'm looking for something that's contributing to the problem. And all the USB devices are my first guess.

    pse et tu to all who make a suggestion. much appreciated.

    ps: for living in a congested dense chicago suburb, actually my non atmospheric noise level is pretty low.

    Or maybe the flex 6K is pulling the signals out better. LOL



  • Jay -- N0FB
    Jay -- N0FB Member ✭✭
    edited December 2019
    I use an Anker Aluminum 8 port, powered USB hub.   It goes well with my IMac and as it is fully enclosed in aluminum, it is very RFI resistant. I've been very pleased with mine.  Any RFI issues that I've had on the USB chain was a result of the cord and not the USB hub.  A snap on choke took care of that issue.

  • George KF2T
    George KF2T Member ✭✭✭
    edited February 2019
    Have you considered an internal card, Bill? Inside the PC cabinet gives you an extra margin of shielding, and provides powered ports. Of course, won't work for a laptop. In that case, a nice unit like Jay describes should be good. Throw away the switching wall wart if it comes with one, and use a linear supply with a nice ferrite core where it connects to the hub. Good luck!
  • George KF2T
    George KF2T Member ✭✭✭
    edited February 2019
    PS - the little clip-on ferrites are generally pretty useless at HF. You might want to consider a toroid you can wrap a few turns through.
  • Mark_WS7M
    Mark_WS7M Member ✭✭✭
    edited January 2016
    Hi George, recommendations for type and source of torroid cores?
  • Rob N4GA
    Rob N4GA Member
    edited January 2016
    What kind of antenna are you using, Bill?


  • George KF2T
    George KF2T Member ✭✭✭
    edited December 2016
    You know, I have had surprisingly good luck with the square clip on toroids from Radio Shack. Usually one is okay when wrapping a USB or low-current power line, but since they are stackable, they do quite well on larger cables, too. I have a half dozen stacked on my two monitor cables where they leave the PC. The smaller snap on cores make a dandy tool to keep them from sliding down the cable, too.
  • Bill-W9OL
    Bill-W9OL Member
    edited October 2016

    actually George, I have 2 4port internal cards in a K3NC custom built computer. It's all the other stuff that use the Hub. This was also my work office till I retired. I should have mentioned that.


  • Jim Gilliam
    Jim Gilliam Member ✭✭
    edited January 2016

    Don't forget about a company called Amidon. They sell a variety of torroids. I routinely wind 5 or 6 turns on all cables on a number 77/43 toroid. Also don't forget about using an UNUM isolater at the transmitter. This keeps a lot of RF from straying from the coax. If you are using a balanced antenna, be sure to use a BALUN at the feed point. This is to minimize radiation on the outside of the coaxial cable. And, of course, there is the grounding issue. However, I have found a balanced antenna with a BALUN at the feed point does more good than just about anything.

    http://www.amidoncorp.com/product_images/specifications/2-16.pdf

  • K1UO - Larry
    K1UO - Larry Member ✭✭
    edited December 2017

    What exactly is happening that you think RFI is causing problems in your shack?  If the keyboard or mouse cease to function after you transmit, I would change to wireless.  I usually do that anyhow for convenience and less cable clutter.  If using the snap on chokes, get type 31 cores and sized to fit the individual cables you use them on.  Loose fitting snap on cores are not  nearly as efficient as cores that are snug to the cable or the cable can be fed through the core to form multiple loops.  But first we need to know what the symptoms are you are observing before making further suggestions.  What exactly led you to the USB Hub itself?

  • Bill-W9OL
    Bill-W9OL Member
    edited October 2016

    HF is an old old Sommer for 10,12,  15 17 14 (rotatable)

    or old 40 driven element tuned to 30 (rotatable)

    or 80-40 dipole

    or 160 long wire

    all go through a AT Auto except the 6 element 6 meter yagi but not all require it.


  • Jon_KF2E
    Jon_KF2E Member ✭✭
    edited January 2016
    I've had great service ordering from Fair-rite. Here is a link to their catalog.

    http://www.fair-rite.com/newfair/pdf/Fair-Rite_Catalog_17th_Edition.pdf

    For HF frequencies either mix 31 or mix 75 are probably the best. 

    Jon...kf2e
  • Jim Gilliam
    Jim Gilliam Member ✭✭
    edited December 2017

    Clip on's give you an effective 1 turn. It is better to wind the cables on torrids. The effective resistance (dissipation of RF) is proportional to the square of the number of turns.



  • K1UO - Larry
    K1UO - Larry Member ✭✭
    edited December 2016
    Jim is correct  and , depending on the frequency, a single snap on provides anywhere from 100 to 200 ohms rf resistance and usually multiple snap on's are required depending on the rfi severity.  A large 31 type core that can handle multiple cable or wire turns through the core is very good for the more severe instances of rfi in the shack. 
  • Mark_WS7M
    Mark_WS7M Member ✭✭✭
    edited January 2017
    Interesting enough 40m started to look like a mess recently and the only thing I did was to plug in a duplicate USB hub. Been a bit busy but I finally decided to unplug it to see and suddenly 40m looked nice. This is the same hub as my other one that is plugged in. But when this one is plugged in 40 goes to ****. So ordered a new hub today hopefully it works and is not noisy!
  • Jim Gilliam
    Jim Gilliam Member ✭✭
    edited February 2016
    Did you first unplug the "non-messy" hub before plugging in the "messy" hub?
  • KY6LA_Howard
    KY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited February 2016
    Check the wall wart. They usually are the cause of such issues.
  • ka7gzr
    ka7gzr Member ✭✭
    edited December 2016
    I agree with Jon- Make sure the clip-ons or  wound toroid's are "mix 31" for HF frequencies. I have had good luck with the clip-ons- sometimes I stack 3 inline.
  • Mark_WS7M
    Mark_WS7M Member ✭✭✭
    edited February 2016
    One of the reasons I opted for new hubs is the new ones I ordered can run off my 12V linear supply so I'm ditching those two wall warts!

    @Jim Yes I tried various combinations.  Seems to be related to that hub and perhaps it's power adapter.
  • Jim Gilliam
    Jim Gilliam Member ✭✭
    edited February 2016
    Sounds like you should invest heavily in #31 torroids. I found winding RF vulnerable leads reject the RF much better than the clip-on's. However, I guess all this depends on a million variables which the eye can't see :)
  • EA4GLI
    EA4GLI Salvador Member ✭✭
    edited November 2016
    I was having a couple of issues with an AUKEY USB3.0 7 port hub, a couple of Blue Screens on Windows 7 included. The device gets fed with 12v out of the provided WART. I decided to run a cable from my power supply to the USB hub instead of using the **** power adapter. 

    It is now smooth sailing.

    I was a bit concern about using close to 14v (13.85v) on the 12v rated device, but it doesn't get any hotter that it used to with the original power adapter and it works great now.

    The device is identical to THIS ONE

    I have been using it for almost a year connected to the power supply 24/7.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.