Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

dhcp in peer to peer mode

K5CGK5CG DannyMember ✭✭
edited October 2018 in FLEX-6000 Signature Series
I received the 6300 today (used in excellent condition - made in June) and I have done a factory reset (white blinking LED).

I cannot get my laptop to communicate with it directly wired. I am expecting a DHCP server in the Flex to provide an IP address and this isn't happening from what I can tell.

I've tried at GigE speed full duplex and dropped port speed to 100 Mb/s to no avail.

I need to be able to use it in peer to peer mode since I will be operating this way away from home.

Any help wold be appreciated.

Danny
K2DMS
Plano, TX

Completed · Last Updated

Answers

  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited October 2018
    The FLEX-6000 does not have a DHCP server.  This is a function provided by a router or a server on the network.  If your Windows PC is configured for DHCP and none is available to provide the DHCP service, then Windows will fall back and allocate a link-local IP address in the 169.254.x.x / 16 subnet.  The radio will do the same.

    What type of PC and what version of Windows are you using?
  • John WilsonJohn Wilson Member
    edited October 2018
    I've never heard of the Flex containing/running a DHCP server. When ever I connect my PC to the Flex directly - I get a 169.254.0.0/16 (link local) address -
    as expected since there is no DHCP server. Even with this address - my PC can still see and 'talk' to the radio.
    Can you 'see' your radio if you use two cables plugged into a router's LAN (with DHCP server), your PC and your Flex?





  • K5CGK5CG Danny Member ✭✭
    edited October 2018
    Connecting the 6300 to my LAN router I can now see the radio in the SmartSDR panel with my laptop connected with Wireless N.

    I can see HW version etc., on the Radio tab.
    IP 192.168.1.240
    Mask is empty. Really?

    There is a notice that says "An update is required". OK, let's do that.
    First time failed, says to reboot the radio. Done.
    Update in progress...



  • K5CGK5CG Danny Member ✭✭
    edited December 2016
    OK, that's good to know. I'll try again now the the update has been applied. See below.
  • Jim GilliamJim Gilliam Member
    edited December 2015

    I wonder when the WAN becomes available it will provide a manually allocatable I/P address  and port number(s).


    Jim, K6QE

  • K5CGK5CG Danny Member ✭✭
    edited December 2016
    Hi Tim.

    HP Elitebook 8530p Core2 Duo @2.8GHz, 8 GB RAM.
    SmartSR v1.5.1.152
    GPU: Maximum Acceleration

    I was able to get into SmartSDR while connected to the LAN and browse around the band. I can hear WWV etc.

    I powered the radio off so that it would lose the DHCP lease.
    Set the laptop NIC back to auto-negotiate.
    Disabled WiFi.
    Connected the direct cable between.
    Powered down the laptop, brought it back up.
    I see IP 169.254.79.297 IP with the 16 bit mask.
    LEDs are a blinking on both devices.
    Waited 5 minutes.
    No radio listed.
    I see no other MAC addresses in the arp table.
  • K5CGK5CG Danny Member ✭✭
    edited December 2016
    I just transferred the warranty on the site a minute ago.
  • K5CGK5CG Danny Member ✭✭
    edited December 2016
    Forgot to mention...

    Windows 7 Professional 64 bit.
  • K5CGK5CG Danny Member ✭✭
    edited October 2018
    Just for shiggles, I installed a DHCP service on the HP laptop as a possible workaround. But the Flex could not get an IP from it so that told me there was a problem with the connection or NIC settings on the laptop.

    To further confirm it was he HP laptop I installed SmartSDR on my wife's Dell 17R and sure enough the radio came right up. So that's that. I think there must be an Advanced setting for the NIC that is not right or missing.  Intel 82567LM Gigabit Ethernet controller

    Adaptive Interframe Spacing: Enabled
    Enable PME: Enabled
    Flow Control: RX & TX Enabled
    Gigabit Master **** mode: Auto detect
    Interrupt Moderation: Enabled
    Interrupt Moderation Rate: Adaptive
    IPv4 Send Offload: RX &TX Enabled
    Jumbo Packet: 9014 (also tried disabled)
    Large Send Offload V2 (IPv4): Enabled
    Link Speed & Duplex: Auto, 100MB/s full
    Link speed Battery Saver: Disabled
    Priority & VLAN: Priority & VLAN Enabled (Also tried off)
    Receive Buffers: 256
    Receive Slide Scaling: Enabled
    System Idle Power saving: Disabled
    TCP Checksum Offload (IPv4): RX & TX Enabled
    Transmit Buffers: 512
    UDP Checksum Offload (IPv4): RX & TX Enabled
    Wait For Link: Auto Detect
    Wake on Link setting: Disabled
    Wake On Settings: Disabled

    I skipped the IPv6 settings.

    I'll update again if I get it working, and please make any suggestions if you see anything wonky.

    Thanks
    Danny
     

  • K5CGK5CG Danny Member ✭✭
    edited October 2018
    OK OK I figured it out.  Wait for it....

    Windows firewall!

    D'Oh!


  • Jim GilliamJim Gilliam Member
    edited December 2015
    The thing I could never understand about Windows is that when they have something that really works well, they always make it twice as hard to use in the subsequent versions, or eliminate it.
  • Lawrence GrayLawrence Gray Member
    edited January 2016
    Windows Firewall service should be permanently disabled by disabling the service.  It causes no end of issues.


  • K5CGK5CG Danny Member ✭✭
    edited October 2018
    I turned the Windows Firewall back on, then added a new "Custom" rule linked to the SmartSDR.exe application to allow only 169.254.0.0/16 on both the local and remote IP address ranges and it still works.

    Done. Thanks everybody for the help.

    73
    Danny
    K2DMS


  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    You beat me too it.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.