Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Radio connection lost...increasingly

edited December 2019 in SmartSDR for Windows

Hi Guys,

Although there seem to be many reporting this problem in the past, I think my issue is slightly different...

My 6500 has been running fine up to now, with the exception of the well documented 'hanging' during power up with v1.5.1. That doesn't bother me too much. However in the past few weeks I have had the radio 'freeze up' on me and then just vanish from the screen, leaving a message 'connection to radio lost'.

Today it reached an irritating **** when it decided to do this at the end of an 'over' and remaining in full TX! I was left with no choice but to force a shut down by holding the power button...something I hate doing.

I have a dedicated PC, running windows 8, 8 cores, 16gb ram with nothing serious, other than flex software running.

I run my Ethernet connection via an 8 port Ethernet switch to this PC. One other PC is connected to this for logging with internet flowing in from a router on another port.

I've been trying to recreate the problem and document the conditions in which it happens, but so far, the occurrences seem quite different...in times of both low and high data flow, TX or RX....and as my post title suggests, the frequency of this problem is increasing...this morning it happened twice in one hour, with only one slice running, once in RX with no input from myself, once in TX as mentioned.

I would be very grateful if you guys have any thoughts to share and indeed any possible actions you would recommend to get to the bottom of this issue.

Many Thanks in advance, Richard MW0XDT

Active · Last Updated


  • Kevin Va3KGSKevin Va3KGS Member
    edited June 2017

    Afternoon Richard

    Did you try a re-install of V1.5.1? (Uninstall first)


  • Dick BDick B Member
    edited November 2015
    I would love to see some safety code that would for example automatically drop out of TX if the connection is lost.  That's the major reason I won't try operating remotely.  I've had too many Windows hangs/freezes to trust it.  The radio has to be fault tolerant.  
  • k0eook0eoo Member ✭✭
    edited March 2017
    I had a problem like that a while back with my 6500 and it turned out to be a bad Ethernet cable.  Never happened again after I changed cables.
  • YV5WZYV5WZ Member
    edited December 2019
    After some time thinking....I decided to not upgrade SmartSDR to 1.5.1    .......and I'm still happy..... I guess in some moment after recovering from my spine surgery I'll take the time to upgrade to feel the spice of the irritation.....

    Richard I hope you may find the solution

    Best Regards

  • edited January 2017

    Hi Kevin,

    No I haven't tries a re-install yet...I guess that's got to be worth a shot.

    ...and Yes, ****, I can really appreciate that sentiment now, having seen it happen first hand!

  • Robert -- N5IKDRobert -- N5IKD Member ✭✭
    edited November 2015
    I would suspect all Ethernet cables and the switch.

  • edited January 2017
    Thanks George and I'll try swapping some cables K0EOO, although I think they are some pretty high quality ones in line...but you never know!
  • edited January 2017
    I'll certainly investigate them Robert, although it seems strange, as everything was running so well just a month ago, with the same cables and switch.
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    Richard - with issues like this is is always best to open a HelpDesk support ticket for official FlexRadio support.  You can try a bunch of stuff, but I think it is best to address this issue systematically as there are several possibilities that can be causing this issue.   Therefore I have converted this topic to a support HelpDesk ticket (http://helpdesk.flexradio.com) for expedited issue resolution.  If anyone else is experiencing an issue similar to this one, please submit a HelpDesk support ticket for issue resolution.
  • edited January 2017

    Hi Tim,

    Thanks for that, I'm never quite sure where is best to post, so your assistance is much appreciated!

    Best Regards, Richard

  • Larry _ W8LLLLarry _ W8LLL Member ✭✭
    edited July 2018

    Shielded ethernet cables are inexpensive and worked for me with some RF issues early on running my amp.

  • Mike KD2CJJMike KD2CJJ Mr Member ✭✭
    edited February 2017
    I had the exact issue and it was my gigabit switch.  Once I replaced this all was well.  Surprisingly my PC was more resilient to the issues I was having vs the Flex.

    Your issue could also be common mode interfering with the switches ability to perform properly.  I would suggest putting ferrites on all your cables including all Ethernet cables as it could also be common mode that is interrupting the network path.  I have ferrites on every single cable in my office and have a significant number of chokes on the antenna system to combat common mode.  This not only has eliminated all my general operating issues but as a plus my noise level dropped some.
  • Ross - K9COXRoss - K9COX Member ✭✭
    edited June 2017
    When this has happened to me the network diagnostics indicator in the lower right gave me a fair warning.
  • edited February 2017
    Thanks guys, some interesting points to investigate! :-)
  • Paul BradbeerPaul Bradbeer Member
    edited June 2016
    Richard, I have experienced this 3 times in the same (i.e. one) general operating period but not since. My quad core i5 is dedicated to, and connected direct, to my 6500 so I'm convinced it is not a PC or cable problem. I'll be interested in what comes of this....
  • Mike KD2CJJMike KD2CJJ Mr Member ✭✭
    edited November 2015
    I bet your issue is due to common mode... try using ferrites on your ethernet and power supply for your switch.
  • Paul BradbeerPaul Bradbeer Member
    edited June 2016
    I doubt it....I wasn't transmitting, just listening and bringing up panadapters/global profiles...
  • Mike KD2CJJMike KD2CJJ Mr Member ✭✭
    edited November 2015
    LOL, then its clear.  Your doing something wrong 
  • DrTeethDrTeeth Member ✭✭
    edited August 2016
    George, same here regarding spine. Major complications this end. God luk to u.
  • edited January 2017

    Hi Guys,

    well it appears I may have cured this issue...at least with my particular station configuration:

    Having taken on board various comments from above, I implemented two fixes. Firstly as I have many ferrites spare, I put ferrites on all Ethernet cables from the switch, plus the power cord. Secondly I completely disabled internet access on my Flex dedicated PC.

    The second fix would appear to be the real winner. Although I had no internet browser running, I did notice Windows activity (despite auto updates being set to OFF!), possibly stealthy updates or data exchange of some sort....either way there was additional activity noted, all of which had to use my one and only Ethernet cable linked to the PC...the same cable that my Flex is using for comms. It was only when this additional activity was taking place that SmartSDR and my Flex appeared to stutter, or freeze up.

    I witnessed this 3 times last night. However since disconnecting the internet feed and ferrite additions I have had silky smooth operation with no hint of a stutter.

    I may well install a decent WiFi card and try linking to my ADSL router via that method, leaving the Ethernet cable dedicated to the 6500, as has been suggested.

    Anyhow for now, all appears to be well again. Thanks for the comments and support guys, it's very much appreciated and indeed one of the joys of being a FlexRadio owner.

    Best Regards to all, Rich MW0XDT

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.