Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Flex VSP Error Msg in Device Mgr.

Steve Belcak
Steve Belcak Member ✭✭
If I visit Device Mgr., under ports I can see my two Flex VSP ports......4/14 and 5/15. Open any of them up and click on Properties,
 
Under the General tab u see
image

it says the device is working properly....


now go to Resources and you find.....
"device isn't using any resources because is has a problem"
image




does anyone else see the same thing?

I'm still fighting my problem of only being able to run one program with CAT.....ie: run Log4OM by itself it works great....Run CW Skimmer by itself it works great......try running both together, the last one you load doesn't see CAT.

the software folks tell me it should work and are telling me the problem is in my computer....
I've been looking for 3 days with no success....

could the above issue be causing the problem....I don't know but maybe.....

any ideas why the resources tab problem....I'm really happy to have my 6500 but these 3rd party connect issues have me playing more with 1/0 than RF.

sure do appreciate any help/suggestions....

73

Steve

Comments

  • Steve Belcak
    Steve Belcak Member ✭✭
    edited May 2020
    I installed SSDR into another machine on my network......same issue

    Steve
  • Neal_K3NC
    Neal_K3NC Member ✭✭
    edited May 2020
    Steve
    If you have done an upgrade (as opposed to a "clean" install, you should:
    1. Delete all VSP Mgs virtual comm ports
    2. Uninstall VSPManager
    3. Delete the folder that VSPManager was located in
    4. Reboot your computer
    5. Reinstall VSPMgr
    6  Set its compatibility settings to run as Admin user and  Win XP service pack 3 compatibility
    7. Run VSPMgr and redefine your comm ports

    73
  • Steve Belcak
    Steve Belcak Member ✭✭
    edited August 2015
    Neal.....I use Flex VSP, is this the same as VSP Manager?  I thought Flex VSP is a recent upgrade. I did a clean install.

    What I have installed is FlexVSP.....no VSPMgr in Programs/Features to uninstall...

    Also Win 8.1 doesn't let me set compatibility mode to XP - it only goes back to Vista

    I think u are on the right track...I fix these port issues and my problem with running multiple programs with Omnirig will go away.....

    Thanks...tell me what to do and I'll get it done...

    Steve
  • Chuck - KJ6HT
    Chuck - KJ6HT Member ✭✭
    edited January 2018

    Steve,

    I am running W10 and I see the same results as you in device manager. I have no issue running several programs that have CAT connectivity to the 6500. It almost sounds like both programs are trying to access the same com port. Have you tried opening SmartSDR CAT and going to the port map tab? This will confirm what port the individual software is trying to use. Don't forget to hit refresh when you connect different software.

    Chuck

  • Al K0VM
    Al K0VM Retired Member ✭✭✭
    edited November 2017
    Flex VSP and VSP MGR are not the same thing.. With the 6500 you should be using Flex VSP.  In the SSDR CAT control panel, you will get one dedicated port by default which will allow you to attach only one program at at time... You should create additional dedicated ports for each additional program that you wish to use with SSDR. Use the ssdr CAT serial ports TAB.

    AL, K0VM

  • Neal_K3NC
    Neal_K3NC Member ✭✭
    edited August 2015
    Sri Steve, I wrote the wrong product but the right thing to do. I would delete the vcomm ports in SDRCat, uninstall SDRCat,  reboot, then reinstall SDRCat.

    see if that works
  • Steve Belcak
    Steve Belcak Member ✭✭
    edited May 2020
    To Everyone...thanks for ur advice and support....it looks like I may have it all working.....Chuck, not sure what hitting the Refresh button does but I'll do as u say....also find there seems to be a startup procedure to succeed in making this all work....I think I have that under control.....noticed also that the CAT user guide is clear to say, HAVE THE RADIO POWERED ON before starting CAT. Is this absolutely necessary...what it says to me is.....if ur using ur PC for non radio with the FLEX off, u need to shut off ur PC, then star the radio, then start the PC again......

    anyway...SSDR, CAT, Log4OM, SDR Bridge, CW Skimmer and FLDigi all seem to be working and talking to Flex. Tomorrow I'll try WSJT-X...

    Thanks again for the help
    73

    Steve
  • Chuck - KJ6HT
    Chuck - KJ6HT Member ✭✭
    edited January 2018

    Steve,

    The purpose of refresh on the port map tab is to update the display of what software is connected to which com port. The display is not dynamic so if you fail to refresh you will not see updated information as you connect or disconnect the various CAT based software packages.

    Regarding CAT startup, it should start whenever the PC boots up. You can confirm by running msconfig (Windows 7) or task manager (Windows 8/10) and check the start up tab. You should see DAX and CAT set to start automatically. In my case, Smart CAT is always running regardless of radio state. I do not ever have to start Smart CAT manually. I normally execute Smart SDR, once up and connected I then start all other programs such as FLDIGI, WSJT-X etc.

  • Vincent Martin - N5ATM
    Vincent Martin - N5ATM Member ✭✭
    edited December 2019
    I'm having this same issue in Win 10.  I think it may have some thing to do with why HRD is not working properly.  When I run HRD, the rig control program reads the frequency, but then nothing else.  I have an open case with HRD but so far, they can't figure it out.  It seems very strange that a VSP comm port would report working properly on one screen but as having a problem on the other.  Does anyone have an actual explanation for what is going on with this yet?  Or maybe even a fix?

    Thanks.
  • RoyS
    RoyS Member ✭✭
    edited December 2016
    Vincent,

    I had a similar problem with HRD Rig Control not long ago in Win 7. Seems I did not have enough memory in my computer. After installing a total of 8 gig, that problem (and others) went away. Upgraded to Win 10. Problem did not return.
    I still have a problem with HRD. If operating in DM-780 and change frequency, DM-780 frequency will not update until I make Rig Control the active screen.

    Good Luck,

    Roy  

  • Vincent Martin - N5ATM
    Vincent Martin - N5ATM Member ✭✭
    edited October 2015
    Interesting Roy.  Glad you got it worked out so easily. I already have 8gig, so it's not a memory issue.  I believe it to be some sort of VSP/Wndows problem.  I have a fresh install of Windows 10 and Flex and the problem remains.
  • Cal  N3CAL
    Cal N3CAL Member ✭✭
    edited March 2017
    I have the same indication within device manager also for all my Flex Radio Virtual Serial Ports !  I'm using a clean install of Windows 10 and a clean install of SSDR with my Flex6300.  Everything appears to be working fine on my system.  No complaints. I'm running DDUTIL, WSJT-X, HRD Logbook,

    Cal/N3CAL

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.