Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

FlexControl will not connect -- Windows 10

Roy - W5TKZ
Roy - W5TKZ Member
edited January 2020 in SmartSDR for Windows
Flex 6300, Win 7 & 10, Ver 1.4.16.142
When I cold boot to begin operating, the FlexControl does not work. I have found a work around by going to Device Manager > Ports (Com & LPT) > Right click on FlexControl > Disable and then Enable. FlexControl connects and I'm good to go. I think others have this problem also. 

Active · Last Updated

Comments

  • Steve W6SDM
    Steve W6SDM Member ✭✭
    edited August 2015
    Have you tried a complete un-install and re-install of all virtual ports?  First, physically unplug your Flex control.  Remove the virtual ports with CAT.  Then reboot and make sure they're gone by viewing COM ports with Device Manager. 

    Make sure Flex Control is disconnected until after everything is removed.  Plug in your Flex Control and back in should grab a virtual port.  Then you can use CAT to reinstall your other ports.
  • Roy - W5TKZ
    Roy - W5TKZ Member
    edited December 2019
    Yes I have done that Steve, but not since upgrade to win 10. I uninstalled SDR, ports and all before upgrade. Reinstalled after upgrade and the problem is still with me. Since I know how to quickly fix the problem, I just do that.

    Thanks for the reply 
  • Al K0VM
    Al K0VM Retired Member ✭✭✭
    edited November 2017
    Roy,
      One thing to try...
    1) Enable the FC in SSDR
    2) Shut down SSDR
    3) Shut down the radio
    4) Start SSDR and wait for the chooser before re-starting the radio
         An LED on the should light
    5) When the radio is up,  select it in the chooser and connect

    If its like mine, FC will now be functional UNTIL you disable it.
    You may have to do it this way every time you start..

    AL, K0VM
  • Roy - W5TKZ
    Roy - W5TKZ Member
    edited December 2019
    Hello Al,
    I tried that and it worked. Problem is, it takes too long. I have an icon on my desktop to Device Manager so with just a few mouse clicks I'm off and running. Thanks a bunch for the reply.

     
  • Joseph Duerbusch
    edited December 2019
    Every Day I have the same problem.  Turn on the computer, start the Flex 6300, then after it boots, then I start SDR.  When it comes up and before I hit connect, I notice the lights on the FC are not on.  So I use ALT-F4 to close the SDR, Then when I start SDR again, the FC lights come on and works normal.  The FC always starts on the 2nd try.  
    It worked fine before the last upgrade.

    Joe K0BX

  • Harry Kosterman
    edited August 2015
    Thanks Roy!  That fixed mine.  
    Harry VA3EC
  • Roy - W5TKZ
    Roy - W5TKZ Member
    edited December 2016
    Joseph, I discovered something this morning and it may help you. In the past, I have been turning off the AC supply to my computer when I shut down. Lately I have left the AC to the computer on and once I have gotten the FlexControl connected, I don't have any problems connecting at bootup. I have no idea why this happens, but now I leave the AC connected to my computer all the time.

    Good Luck

    Roy - W5TKZ 
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    As I have posted previously, there is a known issue where the FlexControl will not properly initialize with SmartSDR v1.4.16.  If following the instructions from Al above fixes your issue, then you are experiencing the issue we have characterized.

    This is a defect we are aggressively working on and have made changes to the code that greatly improves the initialization and operation of the FlexControl.  The improvements will be in the next release of SmartSDR.
  • DonS
    DonS Member ✭✭
    edited January 2020
    I am also experiencing the problem with the FC not working.  I am using Win 10 and SSDR 1.4.16.  I tried all the suggestions listed above.  If I unplug the FC and plug it back in to the same USB port the lights on the FC light up and the correct com port is shown in Device Manager, however, when I go to Settings on the SSDR screen it states the FC is not detected.  

  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    See my comment above.
  • DonS
    DonS Member ✭✭
    edited August 2015
    I did read your comments, however, I should have added that the FC worked fine with Win 7 and SSDR 1.4.16.
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    The FlexControl detection defect we fixed for the upcoming SmartSDR v1.5.0 can happen regardless of operating system; it is 1.4.16 specific and had to do with a threading race condition.  Changing operating systems is a major system change.
  • DonS
    DonS Member ✭✭
    edited August 2015
    Thanks Tim and yes changing OS is a major system change as well as a real PITA as I have discovered trying to get all my stuff from one system to the new system.  
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    Yes, PITA does not even begin scratch the surface.  I have been through this with every Windows upgrade since the dawn of time.  Starting with Win95, I had learned my lesson the hard way and I never upgrade Windows anymore.  

    I get a new drive and do a clean install or as I did with my laptop, I reformatted the drive, installed Win7 from DVD in order to get the free Win10 upgrade, did the upgrade to Win10 and then immediately did a Recovery Refresh which essentially is a "clean" install.  Then I copied over my files and documents and reinstalled all of the applications I use.  This takes about a whole day, but it is a day well spent in the long run.
  • DonS
    DonS Member ✭✭
    edited September 2015
    I was not aware of the Recovery Refresh, however, I had a new PC with Win 8.1 and did the upgrade to Win 10.  I then used the Macrium Reflect Disk Imaging and Backup you suggested to image the SSD drive. That worked great and it took all of several minutes to image the SSD.  Unfortunately the new PC did not come with a recovery disk so I had to take everything installed on Win 8.1 over to Win 10 though I don't think it was much since I did not install anything new on Win 8.1.
  • DonS
    DonS Member ✭✭
    edited January 2020
    Updated  SSDR to 1.5.0 and the FC still will not work.  When I power up the computer the three lights on the FC light up but when I check the FC in SSDR it says there is no FC connected. 
  • DonS
    DonS Member ✭✭
    edited January 2020
    I noticed when I plug in the FC it does not tell me that is a FlexControl USB Control Knob rather a USB Serial Device.  How do I tell if the FC driver is being loaded?  Is it by the name in Device Manager?
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    It is a com port device and it will show Flex Control beside it.  I suspect you have a com port conflict.  Set yours to a high number and don't move it to a different port or the com port number will change.  https://helpdesk.flexradio.com/hc/en-us/articles/202479329-How-to-Change-the-Com-Port-Assignment-for...
  • Burch - K4QXX
    Burch - K4QXX Member ✭✭
    edited May 2016
    I had this problem as well.  It said USB serial device.  Worked fine on Flex 5000 but not on 6500.  I went into device manager and right clicked on "USB Serial Device" and then Update Driver Software.  It then downloaded a new driver and put Flex Control next to it.  It then worked fine on the 6500.  I was still on the same COM port so in my case it wasn't a com port conflict.

  • DonS
    DonS Member ✭✭
    edited September 2015
    Tried this but it didn't work.

  • DonS
    DonS Member ✭✭
    edited September 2015
    Time, when I first plugged in the FC, it grabbed a port already in use by Flex so I changed the port to 100, saved, and rebooted.  I still had the problem so I uninstalled the ports that I knew were not used.  I then plugged in the FC and it came up as COM 3 so changed the port to COM99 this time and rebooted.  I am still using the same USB port.  The com port comes up as USB Serial Device.  Where would I find the device driver for the FC?
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    Don - I recommend opening a HelpDesk ticket on the issue.
  • DonS
    DonS Member ✭✭
    edited September 2015
    thanks Tim, I opened a HelpDesk ticket.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.