Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

transmitting off frequency

Ken - VE5KCKen - VE5KC Member
edited April 2017 in FLEX-6000 Signature Series
Flex 6500 transmitting off frequency from receive frequency in SmartSDR.

I've had this happen a couple of times but most recently with SmartSDR v1.4.16.

I got reports of very high pitch screechy audio but it was found later that I was not transmitting on the receive frequency.

I was a bit slow here but ... I'm still new with my 6500. I missed it at first but it was obvious, right before my eyes, I could see that my TX frequency was low compared to the receive frequency on the spectrum display. This was on 40m LSB. We checked and confirmed I had the same problem on USB.

I upgraded to SmartSDR v1.4.16 earlier in the day and worked  a bunch of station on 20m with no complaints/comments on my signal. The problem did not occur until I switched to 40 meters later in the day.

I tried a few thing, not really sure what to do. Shut down SmartSDR and restarted a few times but nothing helped.

The final step .. a factory reset on the radio.

This fixed the problem. 

Any idea what has caused this?  Something corrupted in the radio?






Comments

  • Sergey R5AUSergey R5AU Sergey Member ✭✭
    edited April 2017
    Ken,
    just from the UM (usually helpfull every time with upgrade/downgrade):

    Release notes:
    FLEX-6000 Not Performing Well after an Upgrade to a new Version of Firmware

    If you observe unexpected behavior or your radio is not performing well immediately after an upgrade to a new version of SmartSDR, it is possible that not all of the internal processors rebooted properly during the upgrade process. If this is the case, the first troubleshooting step is to “cold” boot the radio by turning the radio off using the power button. If the radio will not shut down, press and hold the power button until the radio turns off. Then remove all DC power from the radio for 10-15 seconds by unplugging the DC power cable. Replace the DC power cable and turn the radio back on. This will ensure a complete restart of all internal processors.

  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    Make sure you have not inadvertently enabled XIT.
  • Ken - VE5KCKen - VE5KC Member
    edited July 2015
    Thank you Sergey,

    I remember seeing something like that in the past but when I searched for some help last night it never came up.

    At any rate, from the old school of computer & technology the factory reset normally make things right as it did for me.
  • Ken - VE5KCKen - VE5KC Member
    edited July 2015
    Thanks for the input.  Yes that was effeminately one of the thing I checked and it was not the problem. I have lots of experience with radios, it is just that with the Flex one has to wrap their head around doing things differently.

    I'm starting to think that doing a factory reset after each software/firmware update might be a good idea. It is a common procedure with other equipment I work with where a factory reset is part of each upgrade and is done to clear out any old **** fro the previous version.

    I don't think that the reset can do any harm and as long as you have backed up your profile, it only takes slightly longer.. 


  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    I don't think that the reset can do any harm and as long as you have backed up your profile, it only takes slightly longer.

    I agree.  I do this as a matter of practice when I get a new version of code to test, so some days I might do this a half dozen times. I then re-import my TX profiles and away I go...
  • Ken - VE5KCKen - VE5KC Member
    edited July 2015
    UPDATE - same problem again today...

    I found the problem...  not a user problem either..

    Tim...  

    Here is some more info, do we have a problem that could affect others?

    All went fine yesterday after doing the factory update. To day I started up the 6500 then SmartSDR on my computer. I tuned up on forty and was receiving fine. I clicked [MOX] and to my surprise I was back to the same problem with my TX being low in frequency.

    This time I didn't go straight to the factory reset and took a bit more time  checking things out. I played with RIT & XIT..  not the problem.Then I found the problem.. an easy fix.. but why is this happening?

    So here it is...  When I save a global profile, a transmit profile is saved as well with the same name. This profile is shown in the drop down list under [Tune Pwr]. For some reason when SmardSDR starts up it switch to one of those profiles, instead *Default,  for example.

    When one of those TX profiles saved with a global profile backup name is selected, the 6500 transmit is of frequency from receive. Select Default or any of the original TX profiles and the problem is gone.

    Restoring a previously saved global profile backup does not cause this problem. It is only when one of the backup files that show up in the TX profile list are selected. I have done nothing to cause this to happen.

    So what is this file being put in the TX profile list?  Should they be created? If the are suppose to be created, what is making them cause the problem with the TX frequency?

    Well at least now I know what to look for... I don't think this should happen..  It sure adds an element of confusion for this OM.. hi..







Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.