Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

FlexControl Is Not Detected

shawje Member ✭✭
edited May 2020 in SmartSDR for Windows
I searched the Community, but didn't find my problem covered previously.  My FlexControl is not detected and does not show in Device Manager.  It was working until my computer took a lightning ground hit and got the MB replaced.  All equipment is working except the FlexControl.  It lights up when plugged in, but nothing changes in Device Manager.  Just updated to and still the same issue.  Was using 1.4.3.x previously.  I had it assigned to Port 45 before the ground hit and all was well.  Device Manager now shows only Flex Radio on virtual ports 5, 7, 15, and 17.  SmartSDR CAT shows the same four ports.  I have unplugged and re-plugged the FlexControl, and rebooted my computer, to no avail.  Any assistance is much appreciated.


  • Larry _ NY8T
    Larry _ NY8T Member ✭✭✭
    edited July 2018
    Do you see the flex control when you go to devices and printers? If so try changing the port to another higher port number.
  • shawje
    shawje Member ✭✭
    edited December 2016
    No, it does not show up in the Device Manager, same for Devices and Printers.  Thanx for the suggestion.  Before the ground strike, it came up as a low Comm Port and I changed it then to Port 45, but it won't show up now.
  • Walt
    Walt Member ✭✭
    edited July 2017
    Maybe the Flex control was also damaged in the strike - if it blew up the motherboard, it could of damaged the chip set in the flexcontrol.   Any way of trying all this out on another computer first?

    good luck
  • shawje
    shawje Member ✭✭
    edited December 2016
    I just plugged it into my desktop computer, and it didn't recognize it in the Device Manager.  Way too much of an undertaking to move Flex and SmartSDR to desktop.  Maybe it did **** the chip.  The three lights come on, but that is it.  Haven't opened the FlexControl, maybe someone has and troubleshot it previously and has required pin voltages I can check.  Thanx for the reply.
  • George KF2T
    George KF2T Member ✭✭✭
    edited February 2019
    Check for hidden devices in device manager. The knob sometimes hides there. Delete possible multiple entries and start again. You may need to assign the port manually in the advanced settings, then restart. Good luck!
  • Stu Phillips - K6TU
    Stu Phillips - K6TU Member ✭✭
    edited May 2020
    If the three LEDs come on then the processor inside the FlexControl is still working.  It is possible that there is some damage to the chip however.

    The three LEDs go off when the host operating system (Windows) finds the device on the USB bus and connects to it.  For that to happen, the FlexControl must have been installed.

    Follow George's suggestion and see if there are any devices with ??? in the Device Manager.  

    If not, then I'm afraid the most likely cause is the USB port on the FlexControl is kaput.

    Stu K6TU
  • shawje
    shawje Member ✭✭
    edited December 2016
    No question marks, exclamation points, or a FlexControl hidden anywhere in Device Manager.  The three LEDs come on and stay on until I unplug the FlexControl.  Is it possible its driver is corrupt?  Is there any way to reload it?
  • DV
    DV Member ✭✭
    edited June 2015
    I used a port around 45 and the knob still would not work.  Dudley at Flex support recommended trying a port above 100.  I used 110 and it worked.
  • shawje
    shawje Member ✭✭
    edited December 2016
    I had no issues with using Port 45.  I just can't get Win 7 Pro to recognize it.
  • Dan -- KC4GO
    Dan -- KC4GO Member
    edited March 2018
    Hidden but used serial ports. --- This info received from Dave wo2x 

    Here's the steps needed to check.


    The trick was to open the Command Prompt as administrator and start the Device Manager from the same command prompt.

    1. Right-click “Command Prompt” in Accessories and choose “Run as Administrator”

    2. Enter “set devmgr_show_nonpresent_devices=1″ – without the quotes obviously

    3. Enter “start devmgmt.msc”

    4. In the box that opens, select “Show hidden devices” in the ‘view’ menu.

    Now if you expand the section on COM ports, all the COM ports that have ever
    been created will be displayed, the non present ones being in grey. You can
    uninstall away anything that you don’t want (right click, select uninstall).


  • shawje
    shawje Member ✭✭
    edited December 2016
    Thanx, Dan.  Deleted the four or five non-present ones including Port 45 that the FlexControl used.  Restarted Win but it still will not recognized the FC.  I'll give Flex a call in the a.m.  Thanx again for your assistance.
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    I have changed this post to a problem topic and converted this topic to a support HelpDesk ticket (http://helpdesk.flexradio.com) for expedited issue resolution.  If anyone else is experiencing an issue similar to this one, please submit a HelpDesk support ticket for issue resolution.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.