Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Smart SDR 1.4.0 Locks / Freezes Up

GarySOwnsby Member ✭✭
edited December 2018 in SmartSDR for Windows

Since I installed Smart SDR 1.4.0, I'm noticing intermittent freezes / lock ups of the Smart SDR 1.4.0 software.  Windows Vista Home Premium (64 bit) w Service Pack 2 and all current updates.  Clock at bottom right continues to run but audio is dead, waterfall/panadapter stops.  Menus at top of screen continue to operate File | Settings | Profiles | Help but submenus may or may not work depending upon which one is clicked.

Closing SmartSDR then relaunching results in radio's status showing up as "in use". Recovering usually involves turning off the radio

No changes have been made to hardware or software used on the PC.  Have run various versions of SmartSDR on this same PC without any issues.

All of the PC programs as well as the PC itself continue operate normally.

The PC is a HP Pavilion Core 2 Quad 2.33 gHz Processor with 8GB RAM.

Disabling TrendMicro Antivirus does not make any difference.

Any thoughts on what to check?  Thank you.

Gary, AK4ZX
Chattanooga, TN


  • Rhett Aultman
    Rhett Aultman Member ✭✭
    edited April 2015
    This might sound like one of those "did you try turning it off and back on" things, but I had this problem, and it turned out the root cause was that I still had Smart SDR 1.3.8 and its related software still intalled.  I removed it, rebooted, and have never again seen the problem.
  • GarySOwnsby
    GarySOwnsby Member ✭✭
    edited July 2016
    Larry, Rhett:

    Thanks for the quick replies.  I just noticed that Flex has released version SmartSDR V1.4.3.  I've installed it.  I hope it will cure the problem.

    Rhett:  Yes, I tried turning it off and on and everything else I could think of but nothing really helped.  Sometimes the "in use" status continued after a power down and a PC restart.  Pesky problem!

    Thanks again!


  • Duane_AC5AA
    Duane_AC5AA Member ✭✭✭
    edited May 2018
    Gary - see Larry's link above and see the recommendation to DISABLE any unused DAX channels.  This means to open the DAX control panel and disable it there.  I found that this appears to be a workaround for me until they get the problem solved.  (It happens in 1.4 and 1.4.3 as well on my 6500.)
  • Ross - K9COX
    Ross - K9COX Member ✭✭
    edited June 2017
    I'll bet you will be pleased with 1.4.3
  • GarySOwnsby
    GarySOwnsby Member ✭✭
    edited July 2016
    Duane, Ross:

    Thanks for the suggestion and encouraging comment.

    1.4.3 is working flawlessly so far.  I've also installed it on one of my older Toshiba laptops and now can remotely (through my local network) operate the Flex.  I upgraded my home network a year or so ago to 1GB+ speed so the Flex and 1.4.3 are zooming along perfectly.  Latency is practically nonexistent so far even when I'm using my older laptop for email and surfing while listening.

    As soon as the monsoon gets out of here, I'm headed out to the deck to operate "remote".

    Thanks again.


  • DrTeeth
    DrTeeth Member ✭✭
    edited December 2018
    I have had the issue with 1.4.3 and I have disabled all unused DAX channels too. Not too frequent at all, but still happens.
  • Steve Gw0gei
    Steve Gw0gei Member ✭✭
    edited April 2015
    I have had the same issue with 1.4 and 1.43 - always requires a reboot of the radio in the shack so I have given up on remote monitoring from elsewhere in the house for now. Even after my fast work laptop is turned off the shack laptop on cat 5 wired connection stills sees the radio as in use by the PC that has been switched off.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.