Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Can’t get FlexControl to install again after SmartSDR upgrade to v1.4.3.

KD3VK Ken Member ✭✭
edited May 2017 in SmartSDR for Windows

Can’t get FlexControl to install again after SmartSDR upgrade to v1.4.3.  (Didn’t get it to work in v1.4.0 either.) Remember having a problem with com port assignment conflict in an earlier version and was eventually able to change to 99, but now FlexControl doesn’t even show up as a COM device or port in Device Manager at all. 

Have removed all instances of SmartSDR, CAT, DAX and FlexVSP installations and reinstalled SmartSDR v1.4.3 a couple of times, each without getting FlexControl to install.  FlexRadio instructions on “How to change Com Port Assignment for a FlexControl” not of use for me because the “FlexControl USB Control Knob (Comxx)” device described is not even seen in Device Manager for me.  Only Com Ports shown are FlexRadio Virtual Serial Port (COM14) and FlexRadio Virtual Serial Port (COM4), and neither of these will show the “Advanced” Properties option described to change their Port Settings.  Have tried using each of my available USB ports.

Radio=Flex6700 PC=Surface Pro3 OS=Windows 8.1 (All updates installed.)

I don’t recall how this port issues was resolved in the past so need some help in getting the FlexControl to install.  What am I missing?


  • Bob- W5TX
    Bob- W5TX Member ✭✭
    edited May 2017
    This may have already been tried. I would remove the flex control usb cable from computer. Reboot computer and when complete reinsert FC. Computer should now recognize and assign port. If unsuccessful, in Win control panel look to see what if any com ports are assigned and if so, which ports. Sounds like there is a port conflict and you have to find it if so. The com port 4-14 assignment in cat is a virtual port assignment and unless the computer is trying to assign FC to that port there is no relationship. The FC uses a "real" hardware port and if in control panel it appears as com 4 you can either change it there or choose to remove the virtual port in cat.
  • KY6LA_Howard
    KY6LA_Howard Member ✭✭✭
    edited January 2017
    Well Known Issue

    Go into your control panel device manager and Fix the Flex Control USB Port to a high number like COM55 then you will never have a conflict
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    Ken - are you still experiencing an issue?  if so, please submit a support ticket via our HelpDesk (http://helpdesk.flexradio.com) so we can assign you a case number.  For details on how to submit a HelpDesk support ticket, please refer to the following URL: http://helpdesk.flexradio.com/hc/en-us/articles/202118688-How-to-Submit-a-Request-for-Technical-Supp...   Once the support ticket is submitted, a support engineer will be in contact so we can work on the issue.
  • DV
    DV Member ✭✭
    edited May 2015
    I have the exact same problem.  Using port 55 doesn't help. Will submit a helpdesk ticket. Just got the PEN update back and updated to the latest SmartSDR version.  Tried DDUTIL which always worked with the wheel before.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.