Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Fldigi hanging after tx completes

Ben Sinclair
Ben Sinclair Member
edited May 2018 in SmartSDR CAT
I'm suddenly having trouble getting fldigi to work right. I've upgraded to SSDR 1.4, and I'm running the latest fldigi.

It was previously working just fine, but now when I transmit, after it finishes and unkeys the radio the fldigi waterfall hangs and I have to close fldigi and restart. It's strange though, as everything else in fldigi continues to function, except the decoding, but I do have to force fldigi to quit even after selecting quit in fldigi.

The TX does work fine. It just doesn't come back to decoding after it unkeys.

I haven't previously had RF problems, and I don't think that's the case here as it only hangs after the TX has finished, and I don't have any other problems. It still hangs even if I set the TX power to nothing. Other software, like WSJT-X, works fine too.

Has anyone else experienced a similar issue? I'm not sure if it's something related to 1.4, though that's the only change I've made recently.



  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    This is not a behavior I have experienced using Fldigi with SmartSDR and I have done extensive testing with it and the alpha releases of SmartSDR v1.4.  This does not sound like an RFI issue either.  Since SmartSDR, CAT and DAX are working properly with other third-party digital mode applications,  I recommend posting this bug report in the Fldigi Yahoo support group as it may be a PC or operating system related issue.
  • Dan -- KC4GO
    Dan -- KC4GO Member
    edited March 2018
    I setup FLdigi to do psk31 in about 10 min from install to on air...  Used CAT and DAX no problem
    Dan --- KC4GO
  • Duane_AC5AA
    Duane_AC5AA Member ✭✭✭
    edited May 2018
    I had this same problem occur *once* yesterday while trying to use fldigi for an hour or so.  I've found fldigi to be somewhat unstable - sometimes it will run for an hour or more with no trouble, and other times it will take an exception and fail every 5-10 minutes, requiring a restart (and reload macro's, etc.)  I've decided to try to move back to mmtty for RTTY, if I can get it all to work. 
  • mmerm .
    mmerm . Member
    edited July 2015
    I have the same problem...  I tried multiple times today and it froze every time....
  • mmerm .
    mmerm . Member
    edited July 2015
    Any fixes for this yet?
  • Ben Sinclair
    Ben Sinclair Member
    edited March 2017
    Sorry, I should have updated this post a while back!

    What fixed it for me was picking different audio devices inside fldigi. I'm not at the Flex computer right now, so I don't remember exactly what they're called. On mine, the flex audio devices appeared multiple times under different top level menus, something like WDM and some other acronym. I picked them from a different top level, and it works!

    If trying different audio devices doesn't fix it, make sure it doesn't also hang under other digital programs, like HRD or wsjt, just to make sure it's not RF.
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    Use the MME or DirectSound audio driver API.  Do not use WDM-KS.

    I use the DirectSound ones and it works fine.

    If it continues to freeze, you may consider opening a HelpDesk ticket for assistance.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.