Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

double image on powersdr

Kev MallinKev Mallin Member
edited February 2018 in FLEX Series (Legacy) Radios
Hi, on occasions I get double image's on powersdr, also audio breakthrough occurs when the ghost signal appears close. Rebooting powersdr clears it for a while. I'm using a flex1500 ,powersdr 2.7.2 . I've tried three USB cables but still the same. Help regards Kev


  • Andrew VK5CVAndrew VK5CV Member ✭✭
    edited February 2017


    I get Wide Band Image Rejection Failure on occasion on my 1500.

    For me cycling VAC sometimes fixes it or a band change forth and back usually does.


  • Kev MallinKev Mallin Member
    edited February 2018
    Come on guys I still have this problem with this, can any one help as is getting very frustrating having to keep shutting powersdr down what seems like more frequently. It's a shame as when it is running OK I really like it. Regards Kev
  • Bill -VA3WTBBill -VA3WTB Member ✭✭✭
    edited December 2016
    Kev, how long have you been using that radio, I have a 3000 and have never seen that happen in 6 years. It will likely be a software problem. I wonder if uninstalling would help. I don't think it can be the fire wire cable, if it has any drop outs the Flex will freeze. Or sounds like a video problem.

  • Kev MallinKev Mallin Member
    edited December 2015
    Hi Bill, I purchased it last month to proof test the SDR concept before taking the plunge into big style, but I can't even get this little baby running reliably. Its on a new PC i5 16gig ram and even with nothing else running it still has this issue. With this one Bill its on bthe USB cable not fire wire. Talking to a station last night he seemed to think it's in the area of I/Q settings but if that was the case it would be there all of the time. HELP
  • edited February 2015
    Are you using the USB cable that came with the 1500? It has a ferrite bead molded on it and helps with RFI problems. A regular USB cable without the bead, may or may not, keep RFI out. Even at 5Watts, you can have issues with RFI. A bad ground will cause similar problems as well.

  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    Your issue is probably rooted in the USB controller as this is most likely a result of an IQ imbalance.  The USB interface has to stream I and Q data synchronously in two separate channels.  Our USB driver for the 1500 is designed to stream IQ data, but we do not have control over the physical layer interface.  For reasons that are still not entirely clear, some newer USB interfaces exhibit an intermittent failure mode where the IQ data gets out of sync. The USB interface was not initially designed to stream data, so as newer USB interfaces come along that are more software controlled than hardware controlled, we have seen an increase in failures to stream data synchronously.

    If they get out of sync, the result can be images that WBIR (wide band image rejection) cannot null.  
    If you are using a USB3 controller (interface) try switching to a USB2 interface.  If you do not have a USB2 interface or the one on your PC does not show any improvement, some people have had some success by adding a PCIe based USB2 add-on card in the PC.
  • Bill -VA3WTBBill -VA3WTB Member ✭✭✭
    edited February 2018
    Yup I think Tim is right, USB compatibility. 
  • Kev MallinKev Mallin Member
    edited January 2017
    Hi Tim , I think you are on the button here, I first connected it via a vacant USB 2 slot and it worked fine until I rebooted the comp , then it started playing up so after some research I found that the 1500 needed to be on its own root hub so I swapped it to a USB 3 slot and once again it was fine until reboot, I've tried it back on the usb2 but it still play's up. Somewhere in my box of bits I have a PCI USB card but I haven't any details on it, I will see if it will go into the PC this weekend. Thanks for the advice. Yes James I have the original and have tried two other's but still no joy. I'll report back. Regards Kev G0TPZ
  • Kev MallinKev Mallin Member
    edited January 2017
    Well Tim, I've fitted a PCI USB 2 card into the PC, the one I mentioned that was hidden away at the bottom of one of my draw's, radio and powersdr performed flawlessly from 8am till 5pm then it started playing up again but this time even rebooting powersdr didn't sort it so I uninstalled powersdr virtual com &audio port/cable and have started again from scratch , se if a full reinstall makes any difference. It was good while it lasted. Give you an update later. 73 Kev

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.