Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

JT65 + JT9 simultaneous decode prob



  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited December 2018
    Do you have Flatten option in WSJT-X unchecked?  The DAX audio resonse curve is very flat and flattening a flat signal causes decode problems in WSJT-X
  • Greg - K5GJ
    Greg - K5GJ Member ✭✭
    edited February 2019
    Hi folks - We've been doing some significant testing here in the shack with WSJT-X and while I don't have the White Paper ready to go, I'd like to throw out a few hints and see if anyone has better luck decoding JT9 in "BOTH" mode:

    1. DIGU
    2. Set the Slice Passband to 5.1kHz.  This will cause the radio to optimize for digital modes with lower latency.
    3. If you set the filter > 5.1kHz, it's not necessary to uncheck the "FLATTEN" in WSJT-X.  You will need to uncheck if you want to run a narrow filter.  Here is a note from "JT" himself regarding FLATTEN:

    WA3CAS wrote:
    > If you’re a TS-590S owner you may be interested in knowing that when
    > I first used the new Flatten option I observed a severe distortion
    > of the waterfall. I had the bandwidth was set to 100–4000 Hz, which
    > worked perfectly with the old Slope control.

    For those who'd like to know what is going on:

    The *Slope* control allowed the user to apply a straight-line 
    ("straight" in dB) adjustment to the passband shape. The correct slope 
    had to be determined by trial-and-error.

    The *Flatten* algorithm automatically fits and removes a second-order 
    polynomial to the lower envelope of the averaged spectrum. The active 
    region for this fitting presently extends from 200 Hz above the lowest 
    displayed frequency to the highest displayed frequency. If your filter 
    cuts off well above 200 Hz, or well below the highest displayed 
    frequency, *Flatten* (in its present form) will cause the "distortion" 
    you observe.

    You have two possible solutions: use wider filter in your receiver, or 
    reduce the highest displayed frequency in your waterfall. YOu can do 
    this by reducing Bins/Pixel or reducing the width of the Wide Graph.
    > At first I thought Flatten was useless, but changed my mind when
    > I increased the DSP high cut to 5000 Hz. When I did that, the
    > waterfall became perfectly flat (and I do mean flat) with no signs
    > of distortion. Wonderful, wonderful, wonderful.
    > The only problem with using Flatten with the 590S is that I can’t
    > narrow up the bandwidth or use the radio's Data filter without
    > encountering distortion. If I deselect Flatten, the Waterfall
    > baseline drops and disappears. I need to do a considerable amount
    > of tweaking of the Zero and Gain controls to produce a useful but
    > not ideal Waterfall. Also, by deselecting Flatten there’s no way
    > to flatten the response unless I change the 590’s RX audio response.
    > For me, deselecting Flatten is NOT an option.
    > If this were a perfect world, I would have the option of selecting
    > either Slope or Flatten. But until then, its 100–5000 Hz forever.

    What's the disadvantage in using the wide filter? With my TS-2000, I do 
    almost exactly what you are doing. (I use Lo Cut=200, Hi Cut=5000 Hz.) 
    Unless you have an extremely strong signal in the 4000-5000 Hz range 
    -- enough to cause Rx blocking or undesirable AGC pumping -- WSJT-X will 
    just filter that range out, and you'll never know anything was there.

    Finally -- it's surely possible to do a better job with the *Flatten* 
    algorithm. I just made it work well with my system, with a few 
    different test filter widths. If you have a system in which it does not 
    seem to work well, send me a *.wav file and your wsjtx.ini file as an 
    example. Ideally your example *.wav file should have only a few (or no) 
    signals present.

    -- 73, Joe, K1JT

    4. Set AGC-T to 45-50 and use SLOW.  You can adjust the level if you need to.  I suspect you'll have plenty of excess gain to play with.

    5. Use the DAX Control panel RX slider and the WSJT-X slider to set the RX level in WSJT-X to about -30dB with NO SIGNALS present.  The best thing to do is try to catch the quiet period at the end of each minute.  Joe's manual suggests that you try to keep his slider as close to center as possible.  I bumped it down some so I could keep the DAX slider sort of in the middle as well.

    6. For JT9 transmit, you'll need to set the TX BANDWIDTH "HIGH CUT" to 4.5kHz or so.  It's a very sharp cutoff above that.

    Once we got everything set well, we've had excellent results pulling signals out of the deep noise.   Please try some/all/none of the above and give feedback on what works and doesn't.  

    73, Greg - K5GJ

  • Bernie
    Bernie Member
    edited May 2018
    What version of WSJT-X are you using?

  • Ed_NZ1Q
    Ed_NZ1Q Member ✭✭
    edited November 2016

    Hi Greg,

    I've been experimenting with settings as well. I've found that my settings are essentially the same as yours other than the bandwidth I set the receive slice to. I use just a bit less - 4500 Hz.  I'll open up my receive a bit more and see how it works.

    Looks like you are honing in on how to get the best JT-9 decode when both modes are being used.


    Ed  NZ1Q

  • Ed, K0KC
    Ed, K0KC Member ✭✭
    edited December 2014

    In your testing with WSJT-X did you observe the "sidebands" in the Wide Graph that seem to be occurring randomly (although most evident on strong signals) as the result of a DAX issue, which first showed-up in version 1.3.8? The temporary fix is to stop and restart the DAX channel, but this a pain in certain parts of the human anatomy.

    If not, perhaps you were testing with version 1.4 and hopefully the problem has been fixed.

    Ed, K0KC
  • Greg - K5GJ
    Greg - K5GJ Member ✭✭
    edited May 2015
    Ed.... Good point!  I'm not back in the office til 1/5 so I'll see if I can get someone to wander into the shack and see what version of SmartSDR and WSJT-X we were running. 

    Regarding the sidebands, I actually haven't seen them but know what you are talking about.  Just make sure you have everything in DAX set to 48000.  You can go to your soundcard settings in Windows and just look to make sure.  That will stop any resampling that might be going on.  

  • Ed, K0KC
    Ed, K0KC Member ✭✭
    edited December 2014

    I will check the sampling rates, but I am pretty sure everything is 48K. I do not think that the sideband issue is related to mismatched sampling rates as you can make them go away by simply shutting off the DAX channel that you are using for a second or so and then turning it back on. Also, the sidebands seem to come back up on a random basis after making them disappear after the shut-off.

    Thanks for having someone take a look at this and enjoy your time off.

    I would say "Hook 'em Horns", but it seems like the Horns got hooked themselves...maybe next year will be better.

    Ed, K0KC
  • DrTeeth
    DrTeeth Member ✭✭
    edited December 2018
    FWIW, I also found the JT9+JT65 mode much better than the JT65-only mode for decoding JT65 signals.
  • DrTeeth
    DrTeeth Member ✭✭
    edited August 2016
    Thanks Tim, will check and try that later.

    HNY es mni 73 de Guy
  • Ed, K0KC
    Ed, K0KC Member ✭✭
    edited December 2014

    According to the WSJT-X manual, the only waterfall control that affects decoding is the "spinner" control that sets the position of the blue line that separates JT65 decoding from JT9 decoding. Assuming that the manual is correct, all of this discussion about "flatten" affects only the waterfall display and cannot be responsible for decoding difficulties with JT9.

    Although it is not relevant to the current discussion thread, the manual is not quite correct...JT65 signals can be decoded above the blue line.

    Ed, K0KC
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    Ed - we have conclusive decode data that shows the flatten control is a factor.
  • Ed, K0KC
    Ed, K0KC Member ✭✭
    edited December 2014
    Hmmm...perhaps the manual has not been updated to reflect the most current state of the software.

    Ed, K0KC
  • Tim - W4TME
    Tim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    Wow!  That really happens? :-P
  • George KF2T
    George KF2T Member ✭✭✭
    edited December 2016
    Thanks, Greg & FRS Lab!

    Tried out the settings and concur they work very well. Practically eliminates AGC capture by strong stations, and seems to create a clearer waterfall (on WSJT-X). Not sure the reception is better (haven't gone deep into the numbers), but it seems that it should be. Very surprising - in a good way. Looking forward to the write-up.

    I had been using fast AGC with the slider down in the 30's, and a 4 kHz filter. All JT profiles are hereby updated.

    Happy New Year & may 2015 be a prosperous and bug-limited year for us all...


  • DrTeeth
    DrTeeth Member ✭✭
    edited August 2016
    Further to the "flatten" comment by one of the main devs, "Note that the flatten algorithm has no bearing on decoding and only impacts the waterfall display and signal
    spectrum power display."

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.