Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please refer to the product documentation or check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Flex 6300 and WSPR Audio Problem Solved

Jeff Member ✭✭
edited June 2019 in New Ideas
If you saw my previous post, I will detail how I solved the problem. 

First, thanks for the replies!

1.  I watched the You tube video showing the rig control should use the Kenwood TS 2000 setting and a port speed of 4800.

2.  If you check the SmartSDR Cat program, main page you will find the com port assigned to Cat commands.  In my case it was Com Port 4.

3.  In the SmartSDR Cat program, click on the serial port tab and then click on add a port.  Make the port a PTT port.  I used DTR as the setting for my PTT port. 

3.  When you download the WSPR program at http://physics.princeton.edu/pulsar/K1JT/wspr.html , make sure you use Version 2.12, not version 2.0. (that was my mistake)

4.  In WSPR, from the top menu, select Setup, then select Station Parameters, enter your call sign, grid locator, power level, and select your audio inputs and outputs...which should be DAX RX 1 and DAX TX 1.  For PTT, select DTR and the COM port you added in SmartSDR.

5.  Select CAT Control checkbox and select the Kenwood TS-2000 from the list of radios.  Com port speed should be 4800.  Select your COM port rig control which should be the same as shown on the main screen in SmartSDR.  Close the WSPR configuration window and check for rig control by trying to change bands in WSPR.  If it doesn't change bands you probably have a COM port  number or COM port speed issue.  Retry until band changes work.

6.  Once band changes work and you have CAT control via WSPR, bring up the DAX Control Panel by selecting it from your Windows task bar, right hand corner.  Left click on DAX program and view the DAX control panel. 

7.  Set your receive audio levels in WSPR using the DAX Audio Stream RX Gain control.  I set mine between 0 and 3 dbm. Remember the mode is USB.  Make sure your computer clock is up to date with NIST.  Make sure you have enabled DAX RX audio in your slice receiver.  I selected DAX and in the drop down channel box use Channel 1.

8.  For WSPR transmit, I set the RF Power slider, in the transmit window to 5 watts.  Also select DAX button as the transmit audio source.  I then used the DAX TX gain button in the DAX control panel window to set the audio gain so my transmitted signal was adequate but not distorted by compression.

I probably forgot something but if you follow the above procedure, you should be close to using your Flex 6300 on WSPR and not have to experience too much frustration.  WSPR is a lot of fun.




  • Ned K1NJ
    Ned K1NJ Member ✭✭
    edited February 2017
      Thanks for passing along that information.  Often problems become resolved without folks
    passing along details about the solution.  Going that extra step is in the spirit of the hobby.

    All the Best,

    Ned, K1NJ
  • Robert Allbright
    Robert Allbright Member ✭✭
    edited September 2014
    Jeff Many thanks for a very comprehensive answer and useful info. Much better using CAT control rather than VOX as I have been doing!
  • Robert Allbright
    Robert Allbright Member ✭✭
    edited April 2018
    Hi Jeff
    just followed your instructions and wspr is running like a dream on 20m, everything working fb.
    just can't beat this 6300!
    I'm presently working on a whole bunch of guys over here to go 6000 series
    thanks again
    Robert G3RCE
  • Jeff
    Jeff Member ✭✭
    edited September 2014
    Hi Robert, Glad it is working for you. I have been running my 6300 on 20 meter WSPR for the past 2 days and no problems so far. 73 Jeff KD6RC
  • Robert Allbright
    Robert Allbright Member ✭✭
    edited May 2019
    Hi Jeff
    well, I've been running wspr this pm on 20m and 17m and in both cases if I switch to dummy load and set the noise level to 0 and then switch in my ZS6BKW doublet, the level still remains at zero.
    But I'm receiving stations no problem at all. Just curious, I've never seen low noise levels like this before with other radios running wspr!
    I shall shortly switch over to my Yaesu FTDX1200 to do a comparison.
    The Preamp is not on 17m.
    10m was dead.
    All very interesting
    73 and have fun
    de Robert G3RCE
    6300 rules ok!
  • Jeff
    Jeff Member ✭✭
    edited September 2014
    HI Robert

    Interesting.  My noise level is low too but I haven't set WSPR by using a dummy load before.  Let me know how it compares.

  • Dolan Morrison
    edited December 2018
    Flex 6300.Problem i have is WSPR will change bands and i can see and hear audio in DAX but will not transmit.Any ideas.Thanks
  • DrTeeth
    DrTeeth Member ✭✭
    edited August 2016
    I have found it useful to always set up a new and dedicated CAT port for each app. Cat4 is not a universal port in spite of what SmartCAT infers. Nearly every program 'protests' when I try to use it as per SmartCAT 'connect 3rd party program to port:'.
  • Jay Nation
    Jay Nation Member ✭✭
    edited August 2016
    Just Ignore my from Memory rambling/recollections about adjusting WSPR Audio I'll edit together a proper explanations soon.

    --Begin Ignore--
    Switch to dummy load, then set the audio to 0dBm in WSPR, then switch back to an antenna signals should remain below 30dBm. Over driving the decoders with strong signals affects the decodability of the weak signals, from that "0" level raise the WSPR audio levels 1 dBM at a time, "which is hard to do with that slider" if you suspect your missing weak signals below the noise level. I also adjust the WSPR waterfall to show the band noise "0" level as solid black, or a deep solid color dpending on the pallate I'm using.  Then I raise the WSPR audio 1 dBm at a time,until I just start to see spots of noise appear in the waterfall and then lower the audio until I dont see them anymore. You can also raise and lower the audio level with the DAX RX slider, and the AGC-T slider. The goal is to optimize out the noise floor going to WSPR. the DAX slider determines the total signal level going to WSPR. the SmartSDR Preamp settings and AGC-T slider will change the percentage of noise in that total going to WSPR. For practice at setting the level correctly I run WSPR on 20m and above late at night, where the panadapter only seems to have the noise floor visible. Remember It's not late at night everywhere and greyline effects and propagation are factors that constantly change. Just because a band looks dead locally doesn't mean it's not crammed full of loud signals somewhere else. they might just "pop" right out of a noise floor. Sometimes I see a slight bump in the flat waterfall noise floor just before I see signals pop out. first one or two pop out then more and more then the band opens up. the cumulative effect of strong signals buried in the noise is that it raises the noise floor a dBm or two. Comparing a dead band to your dummy load will show the difference. Never any good DX on my dummy load, only locals. Dummy Loads are perhaps the worst DX antennas you can buy. Sometimes having the worst is better.

    Everyone knows all the above, They just don't know exactly what everyone else knows, unless everyone keeps explaining it to them, something always gets left out, or lost in translation. But that's the true answer, to the questions of, "Now why can't I do that? It's what we did before we had Video's with Musical Soundtracks.

    We posted long boring posts filled with common knowledge
    -- End Ignore --

    Rewrite to be generated due to differences with how I setup the latest Alpha versions of WSJT and WSPR. Something different going on.

    Mo' Better to follow soon!

    Jay - NO5J

  • AA1UI
    AA1UI Member ✭✭
    edited June 2019
    I just can't get my 6300 to change bands on WSPR no matter what I try.  I have CAT working ok with DM780 on com port 5.  WSPR doesn't want to know.  I have WSPR working otherwise with DAX and a dedicated PTT port, just no band changes.. tried everything that's been said in the original post above.  I wonder if minideluxe can be hanging it up?

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.