Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Remote IPad Operation of 6000 series using Parallel Access App --- Update. June 17, 2014

KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
edited June 23 in New Ideas
On June 17, 2014 Parallels released an update to their "ACCESS" iPad Remote Access App which finally fixed the issue with using the iPad microphone remotely It looks to be a major fix What thus means is that I will no longer need to run Skype for Audio at the same time as. I run Access to control the radio. As I have stated previously. I prefer Access over Teamviewer because Access seems to give SSDR a Native iPad Look and feel. I am still in Paris and then Freidrichshafen until the end of the month so all my set ups of my 6700 in San Diego are being done remotely via Access. Initial SSB QSO audio reports using my $24 Logitech Bluetooth Headset over the iPad over a 4G phone connection and also over WIFI to the 6700 have been positive. However since I am remote from my base station I can't provide a full,comparative analysis nor can I easily provide photos of the full setup until I return to the USA. All in all it seems to be a major improvement and is one step closer to achieving the dream of a true Native iPad SSDR app. BTW. Been running JT65 iPad remote QSO via Access while waiting for the XYL shopping. What a great fun way to **** boring shopping time.
«1

Comments

  • kr4kkr4k Member
    edited September 2017
    Do you have two way audio from the iPad into SmartSDR using Access?
    How are the latency and drops?
  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited February 2018
    Yes as I said. the new release v2.0 of Access fixed the mike issue so there is now two way audio without Skype.

    Latency is really an issue of your internet connection.

    Using 4G phone connection via a MIFI box walking around in Paris I am seeing 21Mb/s download and 5Mb/s upload speeds while back in our apartment I am seeing 1.5Mb/s download and 1Mb/s upload speeds on Wifi. Needless to say no audible latency on 4G and minimal but acceptable on the wifi.

    But that was also true using Skype.

    I would prefer to use 4G here over WIFI but the 4G is not free.

    I have a 50Mb/s download by 5M b/s upload connection back in San Diego so symmetrically I have 5Mb/s by 5Mb/s I suspect that if I had lower speed connections at both ends then latency and drops would be an issue On The Other Hand. I have run remotes at 3G speeds (like from a taxi in Bali) with more than acceptable results The real issue of remoting is that the ergonomics of SSDR are not ideal for a small touch screen. So I have to be very careful when pulsing buttons.
  • George Molnar, KF2TGeorge Molnar, KF2T Member ✭✭✭
    edited February 2019
    Thanks for the news! Can't wait to try it out on ssb. JT modes are great while waiting in line , etc! A natural for remote.
  • Bill N3HQBBill N3HQB Member ✭✭
    edited February 2017
    Thanks for the head's up on the Parallels Access update.  I have it running on my MacBook Air and iPhone 5.  How are you connecting the iPhone audio in/out to the Flex?  Are you using DAX?  Can you walk me through the audio set up?  
  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited January 2017
    First. Thanks for the heads up on Access now working on the iPhone. I installed it this AM on my iPhone and already made my FIRST IPHONE /FLEX 6700 REMOTE contact while the XYL was buying purses in Paris this afternoon. Second. Yes u use DAX FOR THE AUDIO When I get back to the apartment this evening, I will try to post screen shots of the simplest setups albeit I use several different setups ( we really need full DAX persistence or better yet Profiles) depending on the mode. Digital modes such as JT 65, RTTY and PSK are very easy to set up as you just substitute DAX channels for your sound cards as you would do if you were working directly. SSB can be tricky. Especially since I am 6000 miles from my base now and working remotely on the new set ups for V2 of Access. So have had to guess at levels and hope on air reports are truthful.
  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited January 2017
    I really needed working profiles last Nite as I tried to document the setup. It seems that there is something different about VOX over DAX via Access which causes the audio drive to work ok but no power output from the transmitter. It took me several frustrating hours to find this issue and fix it by turning off VOX. I might note that VOX works via Skype and DAX so I need to research this issue more The good news is that I got things working OK Since we don't have working profiles I set up Digital on Slice A using DAX1 and SSB on Slice B using DAX4 Here is my headset image Here is the SSB setup On the transmit side I renamed the Parallels Mike so it would be easy to recognize. image I set DAX 4 transmit to LISTEN to the Parallels Mike image On the receive side I renamed the Parallels Speaker so it would be easy to recognize. And made it the default speaker image I set the playback to LISTEN to DAX4 RX image Here are the slices image Of course you need to turn on audio image Finally there is random persistence of the parallels speaker and mike so sometime you may need to reconnect them
  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited January 2017
    Just worked NR5T remote from a bar in Paris. He gave me a "superb audio" report so I guess I must have got my settings right. The only issue seems to be that I have to use MOX as VOX does not seem to activate in this configuration like it does using Skype and DAX.
  • Norbert MeyerNorbert Meyer Member
    edited June 2014
    Howard, I'm using also my IPad to run remotely my Flex 6700, as you'd described earlier, thanks for these and also for the new screenshots, just last Night I tried the same with the new App of Parallels Access. Would be great to meet you on the HAM Radio this week. Please send me your mobil number to [email protected] to arrange a personal meeting. Vy 73 Norbert dj7jc
  • W1IMDW1IMD Member
    edited September 2018
    If I might be allowed your permission to hijack the thread for a moment, I wanted to mention that I had a difficult time getting the audio set up as Howard described above. I couldn't get any audio out of my Flex computer.

     When looking at the audio sources in my Win 7 32 bit computer for the 6700 both the Parallels speaker and mic were listed as being "unplugged" and unavailable to set up.

    Today while trying to troubleshoot this problem I connected my iPad Mini to the Win 7 box via Parallels Access and all of a sudden the audio channels were "plugged in" and available and I was able to set them up per the instructions above. I now have 2 way audio from my iOs devices to my 6700.

    Thank you Howard for leading the charge!
  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited January 2017
    Your welcome You ran into the issue that the Parallels Sound Devices only show up as active when an iOS device is actually connected to the Flex Computer
  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited January 2017
    Worked W1AW/3 SSB SPLIT today from Zurich. Set slice B DAX 4 to Receive. On 14224. slice C. DAX 6 to transmit on 14229 Slice A continued to work JT65 on 14076 Still have not got the VOX settings right. Using MOX until I get home so I can try it locally
  • DK1EYDK1EY Member
    edited December 2015
    Howard! 

    Great How-To, many thanks for that.

    I also use a streamed SSDR that way (mostly to listen to CW remote).

    Did you manage to setup the VOX right now?
    How big is your latency from hitting teh MOX button to transmission and after the transmission the "closing" of the MOX?

    73
    Tom
    DK1EY
  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited June 23
    Have not solved the VOX issue yet. VOX works with Skype audio but not others? Still not sure why I have been using my iPad to control my Flex 6700 for many months both on LAN (NO LATENCY) WAN - WIFI (No Appreciable latency issues). and over the AIr - 3G and 4G... I have operated it from 17 different countries. (#18 Mallorca in Sept 2014) 4G - No appreciable latency issues... 3G - some minor latency to terrible latency depending on the quality/Speed of the connection. 2G. Unacceptable latency On 4G, WIFI WAN and LAN ... the screen updates like it was directly connected with MOX switching instantaneous On good 3G. It works acceptably On bad 3G it does not. Ultimately everything depends in quality of connection.
  • Ken - NM9PKen - NM9P Member ✭✭
    edited December 2016
    Howard,
    Has the new v.1.3 enabling VOX on DAX solved this problem?  Just curious.
    Also... What model is you bluetooth headphone, and where can I get one.  I am always looking for another good headset....

    Ken - NM9P

  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited December 2017
    Yes DAX and VOX work great in 1.3


    Just confirmed a QSO from country #18. Mallorca with john NA6L a couple of minutes ago via iPad remote.

    (Used up a few XYL frequent flyer miles with XYL so I could make the QSO before dinner)


    He reported my audio was FM Broadcast quality. ... So much for needing expensive mikes.


    I am using a Logitech Bluetooth headset


    http://smile.amazon.com/gp/product/B0....


    Note they raised the price from $24.50 to $37.48

    Country #19 will be Ireland at the end of October. I think there needs to be a DXCC Remoting Award
  • I0JBL - LucI0JBL - Luc Member ✭✭
    edited December 2016
    Howard thanks you for all the tips that I have followed step by step.
    Unfortunately in my IPAD2 waterfall works fine but the panadapter no (it also happens to others? Bandwith matter?) 
    Under Android (Samsung Note 3) system works fine with the advantage to associate ham radio activity with stamp collector hobby :-)
    73, Luciano, I0JBL

  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited December 2014
    Definitely a bandwidth issue. Should work ok if effective bandwidth exceeds a minimum of 2 Mb/s I find that issue with slow 3G. But OK with fast 3G, 4G and good wifi.
  • Joe - KC2TNJoe - KC2TN Member ✭✭
    edited March 2017

    Back on the ipad remote again!

    I had to completely remove 1.3 and DAX plus drivers and reinstall.

    Now that it's working again, I'm trying to get my headset to transmit. It receives ok but I have no transmit audio.

    iPad transmits ok without headset by hitting MOX but as soon as I connect the headset via Bluetoth, the transmit and receive goes away. If I turn off the Mic under Parallels the receive returns but no transmit.

    Do I need a different setup to use with the headset? 

    It's the same one you're using Howard.

  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited January 2017
    I don't believe so. I was on it from Mallorca last week ok In Paris at the apartment now. I am rebooting both remote computer and the radio as I write this I will report back with the results.
  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited January 2017
    I had just updated the iPad to iOS 8 This was the first test of iOS 8 I am definitely transmitting OK HOWEVER MY headset seems to be backwards With Parallels Mike off. I hear sound via the headset With Parallels Mike On I hear sound through the iPad speakers Transmitting is only through the iPad mike NOT the Bluetooth headset Which makes VOX impossible to use but MOX worked. Best guess there is a bug in Parallels with headser under iOS 8 I will report bug so Parallels will fix it ASAP.
  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited January 2017
    Just confirmed to myself that it is an iOS 8 Parallels issue with Bluetooth headset on iPad I just did a connect via headphones via Skype. Worked OK Gotta LOVE Profiles. Jus one click to switch from parallels to Skype audio I reported it to Parallels Hopefully they will issue a iOS 8 bug fix update ASAP
  • Joe - KC2TNJoe - KC2TN Member ✭✭
    edited March 2017
    So, did your headset work OK for transmit under IOS 7.x? Or did it never work under Parallels? Mine is also backwards, same as yours!
  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited January 2017
    Greetings from Paris

    Parallels worked 100% correctly under iOS 7

    But clearly is backwards under iOS 8

    I also have parallels on my iPhone 4S under iOS 7. (iPhone 6+ will be waiting for me when I get back to USA)

    I definitely can connect and operate from my iPhone.

    But the Logitech headset does not show up in it so I cant test to see if Bluetooth is still coreect

    I still believe it's a parallels iOS 8 issue as Skype works 100%
  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited January 2017
    Joe I tested the headset on another computer where I had parallels running Headset seemed unaffected by Parallels red mike setting and seemed to work normally That machine does not have mike enabled So perhaps it's somethin in our DAX settings that causes it to run backwards
  • W5UN_DaveW5UN_Dave Member ✭✭
    edited February 2019
    Howard, how are you handling the 2K-FA with Parallels Access? I see that only the top portion of the remote control program shows for the 2K. The gray bottom half that allows power control does not show in the Parallel's iPad screen.

    BTW, the sound setup works great. Thank you for sharing (and congrats on the 6300).
  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited February 2019
    @Dave I sometimes run into that issue. The work around is to login via team viewer. Start the 2K-FA app. ClickView-->. Home Display and Keyboard Logout of teamviewer. Logon via Parallels. That always. Fixes it. BTW. I need to update the remote process. With V1.4+ it's actually much easier to use the Remote feature to feed Audio rather than DAX as I show above
  • George Molnar, KF2TGeorge Molnar, KF2T Member ✭✭✭
    edited December 2016
    MUCH easier. 
  • KY6LA_HowardKY6LA_Howard La Jolla, CA. Paris and Sablet FranceMember ✭✭✭
    edited April 2015
    if I have time this week I will write up the Remote Solution for the IPad
  • W5UN_DaveW5UN_Dave Member ✭✭
    edited November 2016
    Howard, last night the iPad worked great on remote. Today, no power out when I speak, even though the spectrum signal shows my speech, and receive is just fine.. Not sure what is going on, but I look forward to your instructions on loading a better way to do audio.
  • Jim GilliamJim Gilliam Member
    edited May 2015

    I have been having problems with Parallels Access but it was all my fault. It is very important that you select Desktop mode while running the app. If one doesn't the whole screen if filled with the app you are running and the bottom icons will not be visible. That prevented me from remotely setting the correct audio.


    Jim, K6QE

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.