Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

Who is using the 6.5k, with DAX and JT9? I need some clues

I need a step by step to link the 6.5K, and wsjt-x in either JT9 or JT65.
I have rig control working via DDuT.
But I need DAX setup instructions.
Can I pick any pair of DAX?
What I did in the jt program is...
Audio in, DAX RESERVED AUDIO TX 1 (DAX TX
Audio out, DAX RESERVED AUDIO RX 2 (DAX RX

Where I'm confused is how to connect to the radio?
I'm missing the obvious. Where do I tell the 6K which DAX to listen to and which to talk on.

pse and tu.....I'm old and getting dumb....and I was never too bright to begin with.
My 5K is fully automated for all modes. Just can't figure out how to tell the software

Completed · Last Updated

Answers

  • Ken - NM9PKen - NM9P Member ✭✭
    edited June 23
    Do NOT use the RESERVED audio lines in your software.  Those lines are the Radio End of the virtual "Cable."  Use DAX AUDIO RX 1 (or 2 or whatever you choose)  for the Audio IN, and use DAX AUDIO TX 1 (etc.) for the Audio OUT.

    Then be sure to select the proper Dedicated PTT port number pair, either using direct connection or via DDUtil.  

    I have been using WSJT-X for WSJT and JT9 and don't mess with DDUtil.  I have reserved a sufficient number of com ports that I am able to get by without it.  But I don't have computerized rotators and amplifiers to contend with yet.

    Also be sure to turn the proper channel ON in the DAX control panel, and select the proper DAX channel o the Slice Flag AND turn ON the DAX button on the TX panel.  (I have made these mistakes several times and wasted a lot of time tracing "configuration errors."
    Hope this helps.  If you need more help, let me know and I will look up my exact configuration when I get back to the shack.

    Good luck,
    Ken - NM9P
  • WQ5CWQ5C Member ✭✭
    edited June 16
    One hiccup that I've noticed is that Windows occasionally renumbers the audio devices.  When that happens, everything looks OK, but you don't get any audio to WSJT. 

    The fix is to go back and compare the values in the WSJT DOS box and Options box & make sure everything still matches.
  • Ed, K0KCEd, K0KC Member
    edited September 2017
    Bill,

    I use WSJT-X to work the JT65 and JT9 modes almost everyday with my 6700. In addition to the information that Ken shared with you above, I have found that WSJT-X is more stable if I ignore its CAT capability with split operation.

    If you set your 6500 transmit bandwidth to something like 4200 Hz and the receive bandwidth to a similar number, you will be able to work JT65 and JT9 with a single slice.

    The alternative is to use two slices (where slice B is considered VFO B) and use split operation; I have experienced periodic problems with this setup, but I understand that these CAT problems have been fixed in the current beta version which is not yet available to the general public.

    Let me know if you have any questions.

    Ed, K0KC
  • Ed, K0KCEd, K0KC Member
    edited May 2014
    By the way, each time that you restart your 6500, you will have to activate DAX in your Transmit Control Panel as well as select transmit for the DAX Audio TX 1 (or whatever channel that you use). It would be nice to have persistence here.

    Ed, K0KC
  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited December 2016
    DAX Control Panel persistence was fixed in SmartSDR v1.2
  • Bill-W9OLBill-W9OL Member
    edited February 2019
    I guess I didn't explain myself correctly
    I KNOW I must use DAX
    I KNOW I must use one Dax channel for sending the transmit audio from the  JT program to the Radio.
    I KNOW I must use a different DAX Channel to get the receive audio from the radio to the program

    What I DON' KNOW is where in SmartSDR is the options to select the DAX channel for receive and where I select the other DAX channel for transmission.
    This should be obvious to me, but I'm missing.
    I must be doing this wrong
    On the left side of the screen  I see.
    <-
    +RX
    Band
    Ant
    Display
    DAX which is where I selected Channel 1

    In the window describing the slice is another button named DAX
    I'm assuming this is the receive setting side and I selected Channel 2

    In the JT program I just reversed the numbers: Channel 2 to the transmit side
    and Channel 1 goes to the JT receive side.

    but it don't work, so I must be doing something wrong.

    pse and thankyou
  • WQ5CWQ5C Member ✭✭
    edited March 2019
    WSJT uses the enumerated Audio Device number.  Take a look at the DOS box that is the 1st WSJT dialog.  It has a list of all the audio devices.  It's the number on the left that you use to configure the WSJT Options.  Let me see if I can post a screen capture...
  • WQ5CWQ5C Member ✭✭
    edited March 2019

  • Bob G   W1GLVBob G W1GLV Member ✭✭
    edited December 2016
    Does not happen in Win 8.1
  • WQ5CWQ5C Member ✭✭
    edited April 2014
    Good to know.  I'm on Windows 7.
  • Steve-N5ACSteve-N5AC Community Manager admin
    edited February 2017
    I recommend using WSJT-X as the interface is a lot easier to setup.
  • George Molnar, KF2TGeorge Molnar, KF2T Member ✭✭✭
    edited December 2016
    You should select DAX from the slice you're using (yes, that's the receive path), and then also activate the transmit side from the right hand TX window. You don't select another DAX channel. In WSJT-x, use DAX RX # to match what you've selected earlier! and TX with the same number. NEVER use the "Reserved" selection. In the DAX Control Panel (you will find it by right-clicking on the DAX system traya icon) ensure that both RX and TX are selected for the DAX channel you desire. The bar graph meter for RX Should deflect close to full scale, and the TX meter likewise when you transmit (use the TUNE button in WSJT-X). You can adjust the slider there for optimal modulation. The DAX function is active even after you "X" out of the control panel. Do not relaunch DAX, as this can lead to instability. Use the right click on the icon to see the panel again. You can leave it up all the time with no ill effects. If I recall, the DAX Selection on the left menu is for the IQ function, which is not supported in WSJT-X or JT65hf. Good luck!
  • Jerry GardnerJerry Gardner Member
    edited April 2014
    One area I would like to see changed is how the various DAX "pieces" are arranged in the UI, At this point, it requires going to several places (DAX control panel, TX panel, slice flag) to get everything setup.

    I've missed lots of juicy DX on JT65 because I go to call someone, WSJT-X starts transmitting, and I get no transmitter output. It's usually because I don't have the DAX button enabled in the TX panel or I don't have TX enabled on the slice receiver feeding WSJT-X. By the time I figure out what's wrong, I've missed the transmit window and my chance to bag the DX.
  • Bill-W9OLBill-W9OL Member
    edited October 2016
    I do use it Steve, in fact, I'm quite adept at it, but using the Flex5K.
    The 6K...is a different cat and I'm normally too dumb to be so totally confused.
    I'm thinking 5K & VAC, can't get over the ****...
  • Steve-N5ACSteve-N5AC Community Manager admin
    edited June 23
    OK Bill I hadn't read the whole thread here, but I saw some folks suggesting WSJT and I wanted to throw in that I I thought WSJT-X works better with the 6000.  At any rate, let me give you a brief how-to and see if it helps.

    Think of the DAX Control Panel as a middle man that connects your radio to your digital mode software (WSJT-X in this case).  First, we'll get the receive audio path running.  In the radio, you need to send the audio to DAX.  To do this, pick the slice you want to run digital modes with and select the first DAX channel.  You do this in the DAX drop-down on the slice flag.  Just pick "1":



    Now you should look at the DAX Control Panel and be sure it is receiving the signal from the radio.  Ensure that DAX has channel 1 turned on (the 1 button is blue -- if not press it so that it is blue).  You should see the audio meter in the DAX control panel light up (red line showing a signal).  If you do not see this, you do not have receive audio from the radio to the computer.  Nothing will work until you have this part working, so it must be right.  If it is not, you can try turning the channel off/on to ensure it is connected to the radio and verify that you have the right channel selected in the SmartSDR GUI as shown above.  Once you get the signal in the DAX Control Panel as shown below, you are 25% there!



    Next, you should go into WSJT-X and ensure that it is setup correctly.  Go to the Setup Configuration page in WSJT-X.  Here's how mine is setup:



    Once you have this done, you should say OK and then go look at the waterfall in WSJT-X.  You should see that you have audio from the radio and WSJT-X should start decoding.  Note how the waterfall in WJT-X reflects your receive filter in SmartSDR:



    Here's decoding happening now:



    Again, if you do not see this -- it must be fixed before you go any further.  Now much of the JT-9 activity happens above the typical filter bandwidth of 2900/3100Hz or whatever.  I recommend grabbing the right edge of the filter in SmartSDR and raising it to 5kHz or so -- this way you will get everything over in WSJT-X, even the guys that are camped up at 3500-4000Hz away from the calling frequency.  Here's my filter after the change (I'm running Alpha code so I have the waterfall going -- you'll have this shortly too):



    and WSJT-X after the change:



    You are half way there!  OK now if you also setup the transmit side in WSJT-X when we had the control panel open earlier, WSJT-X should send signals to the DAX Control Panel and you should be able to see that.  To check this, be sure you have a dummy load or your power turned all the way down in SmartSDR and click the TUNE button in WSJT-X.  I've shown it here next to the DAX Control Panel:



    WSJT-X will go into tune and the DAX Control Panel will show audio in the control panel for channel #1.  Turn down the DAX TX Gain slider until the audio level is just below the 0 indication as I have done here.  If you do not see the red signal line in the DAX control panel, you have to fix this before going on!  Next click the TX button if it is not red in the DAX control panel.

    If you have CAT working correctly, the TUNE in WSJT-X also keyed your radio.  If it did not, you need to fix CAT before going on!  If it doesn't work, verify the settings in both CAT (right click the CAT icon in the Windows System Tray and say "Show" and then check the settings).  If this is all working, you are 75% done!

    Now go into SmartSDR and ensure you have DAX checked as the audio source as shown here:



    Your panel will look different from mine, but the important thing is that you have DAX checked (blue). Now try the TUNE from WJT-X again with your power turned down in SmartSDR.  You want to be sure you have signal making it to SmartSDR and you will see this with the level indicator (one more time, yours will look different, but similar).  You want to ensure that the signal is just below the 0dB point in the meter -- you make the adjustment with the TX Gain slider in the DAX Control Panel.  Your 0dB point will be in a different place than mine, here, so look carefully.



    You are now 100% complete.  The audio goes from the radio to the digital program and all the way back to the radio and we're keying the radio with CAT.  You are now ready to make a contact on the air!

    I hope this helps -- if I've missed something or you're still having an issue, let me know.
  • Steve-N5ACSteve-N5AC Community Manager admin
    edited December 2016
    Jerry -- we talked about putting the DAX Control Panel functionality inside SmartSDR. We all thought this would be less confusing.  Be we also talked about the "what if someone wants to set up several computers and use each to decode different or the same things".  We hated to have a requirement that you have to run SmartSDR GUI on each of the other computers.  So we came up with the DAX CP.  You can run just that on several remote computers, all connecting to the same radio.  For example, you could have FLdigi and MixW each running on a separate computer both connected to the same radio through their own DAX CP decoding the same data and you could compare how they do with the exact same data at the same time.  We imagined many scenarios like this and wanted to be sure you could do all these things.  

    You could argue that we made it more difficult for the 95% case because we wanted to enable the 5% case.  I'd probably be fair criticism, but we wanted to be sure you could do "anything you wanted."
  • Ken - NM9PKen - NM9P Member ✭✭
    edited December 2016
    Nicely done, Steve.  I hadn't had time to prepare an answer yet, but you did it better than I would have done!  Sticky this somewhere, it will be helpful.  You guys should prep a special section of this community website for tutorials like this.
  • K1UO - LarryK1UO - Larry Member ✭✭
    edited December 2016

    Hi Bill,  What it seems to me, from your above description of selecting the DAX channels in Smart SDR,is that you are not finding/selecting the channel results in the DAX program itself.  This is a stand alone view (Not shown in Smart SDR  itself) that should reside in your computers Icon Tray (bottom right side of your computer screen)  The Icon looks like the CAT Icon only it is labeled DAX.  When you click on this it will open and shows the 8 DAX channels for both RX and TX as Steve described in his tutorial above.  It sounds like this is what you are not seeing/adjusting.  My perception but just thought I would throw this idea in here if it may help.  Its possible you are missing the DAX Icon in the Icon Tray?

  • Ernest - W4EGErnest - W4EG Member ✭✭
    edited January 2015

    Steve,

    I could not say it any better!

    Very well documented and illustrated. I am very happy to see it on the forum.  From now on I will refer all request for JT65/9 for my Flex radio setup to this page;  along with your call.

    Thank you

  • Bill-W9OLBill-W9OL Member
    edited October 2016
    K1UO Larry, you hit the nail.....I was trying to do it from SmartSDr
    I knew I was doing it wrong, just didn't know what I was doing wrong. LOl
    Now to figure out why ptt isn't working....one baby step at a time.
  • Ed, K0KCEd, K0KC Member
    edited May 2014
    Bill,

    I have set up PTT by creating a PTT port with SmartSDR CAT (icon on the lower right of your screen...right-click and select "Show"). I used the pair 5-15 with the 5 end going to WSJT-X. Be sure to set it up as a PTT port and check the RTS box or the CTS box or both.

    In WSJT-X, under Setup/Configuration, under PTT method select either RTS or CTS depending upon how you set up SmartSDR CAT. Also select COM5 or whatever port you used in SmartSDR CAT.

    There is a button in WSJT-X to test PTT for your system.

    I hope that this helps!

    Ed, K0KC
  • Bill-W9OLBill-W9OL Member
    edited October 2016
    That's the tutorial I was hoping for. Thank you Steve, I owe you a ****, or two, you Texans do drink **** don't you?
    I totally missed the DAX Control Panel part.
     I'll give it a try later.

    I'm pretty sure that I can't use my VSPM ports for ptt between my DXLab automated computer system or can I?
    Basically I click one button and it changes band, mode, changes amp if needed, turns antenna to proper direction, etc. etc.
    All my 5K rig programs use com 8 as the ptt port.
    Not sure how to route that to the 6K? I'm thinking the 5K must be powered down when I switch to the 6K and vice versa.

    I'm presently not using  SmartCat as the most Contest and most logging software will not accept a port higher than 8.
    I and ran out of port numbers years ago. LOL

    Thanks again Steve...
  • W5XZ - danW5XZ - dan Member ✭✭
    edited December 2016
    great job, steve...THAT's the kind of stuff we need!!

    (shoot, i may try digital modes someday...)

    73, w5xz

  • Bob N7ZOBob N7ZO Member ✭✭
    edited December 2016
    Steve,

    Good tutorial.  I did not have any problem getting WSJT-X running.  Now I'm playing with multiple instances.  Thanks.

    But, why is this:  "Your 0dB point will be in a different place than mine"?


  • Jerry GardnerJerry Gardner Member
    edited April 2014
    I think it's because he's using SmartSDR v1.2, which isn't generally available yet.
  • Ken - NM9PKen - NM9P Member ✭✭
    edited December 2016
    Yes,
    If you compare his meter to yours you will notice that the mike level has been changed to make it more readable.  They have taken the scale from -40 dB to just barely over 0 dB  in stead of going all the way to +20 dB.  No one ever needs to go over 0 dB because SDR audio can start to get nasty really fast when overdriven.  The FLEX is designed around an industry standard of 0 dB or "unity gain" on all of it's audio circuits.  So your 0 dB point is on a different location on the meter.

    They also seem to have changed the simple compressor to a much more gutsy processor.... "Normal...DX.. .DX+"  That is exciting, too.  I believe that Steve said it is based upon broadcast industry "hard limiting" algorithms.   I can't wait to try it.
  • Steve-N5ACSteve-N5AC Community Manager admin
    edited December 2016
    The compression algorithm was developed by David Hershberger, W9GR. He approached us at Dayton a year ago with the algorithm and we coded and tested it in SmartSDR. It worked so well we integrated it into SmartSDR as the primary algorithm. We did on-air testing of this with our alpha team and it was really amazing how much audio popped out of the noise floor with it on. David has an article about the algorithm that will be published in QEX later this year.

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.