Welcome to the new FlexRadio Community! Please review the new Community Rules and other important new Community information on the Message Board.
If you are having a problem, please check the Help Center for known solutions.
Need technical support from FlexRadio? It's as simple as Creating a HelpDesk ticket.

MacBookPro15

Tim BoldmanTim Boldman Member
edited January 5 in SmartSDR for Windows
The only computer I have that has the processing, RAM, and 194 khz sound sample rate is a MacBookPro15. I have Parallels Desktop which runs Windows 7, or 8 environments. Has anyone had success running FlexRadio SDR on a Mac using this configuration? Right now, I use this computer to record, and mix music mostly using LogicPro9, and synching with video using Soundtrack Pro. This machine runs 64bit applications flawlessly (so far).

Completed · Last Updated

Answers

  • Tim - W4TMETim - W4TME Administrator, FlexRadio Employee admin
    edited March 2017
    Tim, Before I get into the issue of Parallels or other VM environments, not since the SDR-1000 has a sound card been needed for the operation of our SDRs. A sound card is now used in conjunction with the FLEX-6000 only for operating sound card based digital modes and this situation is only temporary until we have the ability to stream audio from the radio over the network (IP). SmartSDR for Windows is a 32 and 64-bit application and will operate under Parallels as long as the VM has sufficient CPU (cores) and RAM allocated to it. Some of our developers use OS X to develop the radio code and when they test it, they do so running SmartSDR for Windows on Parallels.
  • VA7LWEVA7LWE Member
    edited August 2013
    Glad to hear there are some devs using OS X and doing incidental testing in Parallels. That's exactly how I'll be running the client when my 6700 arrives (this week I hope). Of course it would be *awesome* to eventually get a native OS X client, which is hopefully a lot more of a possibility with the 6x00 line, given that it's a thin client. However, I imagine there are a few other priorities to come first!
  • mikes3mikes3 Member
    edited August 2013
    I'm running SmartSDR .12.17 just FINE with VMWare Fusion version 4.1.4. (VERY happy to use this fine radio in the Mac environment, even if it is a virtual.) 73; -Mike- K0JTA
  • Jeff HerholdJeff Herhold Member
    edited August 2013
    Ditto here, using VMWare Fusion 4.1.3, in a VM with 2 allocated I7 cores and 8GB memory. Jeff WI7D
  • DonSDonS Member ✭✭
    edited January 5
    I am running Parallels which should not be too much different from VMWare. I am having an issue with sound into the Navigator (an interface for the digital modes). I am wondering if I have to do something for the USB and sound to get the audio. I have cat control control working. Don
  • W4EYW4EY Member
    edited January 5
    Don: I am having the same problem with my Navigator. If I look at the Device Manager in my Win 7 Pro Desk top, I see a lot of COM ports assigned to SmartSDR CAT and Navigator interface. However, still cannot see the Navigator in my Sound card settings. Also using DM-780, I cannot get the Navigator to be recognized in the soundcard settings. I ordered a Navigator Interface cable from Navigator folks to see if this may be my problem. My HRD will control the FLEX and the FLEX follows it when changing Frequencies and modes. Issue is the DM-780 and Navigator settings. May be a conflict with the COM ports and Virtual lines in my Desktop. Still working on the issue. Will let you know if it is resolved. Bill W4EY
  • DonSDonS Member ✭✭
    edited August 2013
    Bill I went into the control panel then sound section. I disabled all the audio devices in Speaker except USB Audio Codec and under Microphone I did the same thing. I rebooted the Win 7 Pro and everything worked after that. If you do not see the the USB Sound Codec then follow the instructions to uninstall the Navigator software - if you need the instructions I can supply it, reboot the pc, then go through the install again. Hope this helps. Don
  • Sergey R5AUSergey R5AU Sergey Member ✭✭
    edited April 2017
    Hi Tim, i am running on the iMAC 27, 2.94gHz CPU with 16 GB RAM, with VMware (for VM ware i have split 4core and 6Gb RAM) and WIN7 64 bit and FlexControl - no specific issue with performance or any other troubles found, i have noted only case with white slice on screen in unity mode of the VMware - rest is vince, CAT working fine. On the screen shot you can see single window mode of the VMware with started DDUtil V3 and HRD as a logbook
  • Paul RN3APaul RN3A Member
    edited August 2013
    I have tried to run SSDR under both Parallels and VMWare Fusion on my iMac. All worked just fine, but only if SSDR, SCAT and logging software were all running within one VM. However, I've attempted to run MacLogger DX and tried to connect it to VM Serial port created by SCAT in VM, and it didn't work. This is probably a bit outside of purely SSDR subject, but did anybody try to interface Mac software like MacLoggerDX with Serial ports inside VM? Is it possible doing at all?

Leave a Comment

Rich Text Editor. To edit a paragraph's style, hit tab to get to the paragraph menu. From there you will be able to pick one style. Nothing defaults to paragraph. An inline formatting menu will show up when you select text. Hit tab to get into that menu. Some elements, such as rich link embeds, images, loading indicators, and error messages may get inserted into the editor. You may navigate to these using the arrow keys inside of the editor and delete them with the delete or backspace key.