Upgrading form Win 8.0 to 8.1 problems..

  • 1
  • Problem
  • Updated 5 years ago
  • Solved
This may be more of a report than a problem, because I think I solved it, but others may benefit from my experience.

I just did the update to Win 8.1 and my SmartCAT stopped working beyond letting me have access to the 6500 and FlexControl Knob.

I deleted all my serial ports, rebooted, set them up again, several times, and still nothing....The Control Panel showed the ports, but with the yellow warning triangles on them. ( I have 4 dedicated ports, one PTT port, and 4 shared ports set up.)

The solution was to use SmartCAT to remove all virtual serial ports, uninstall SmartCAT, reinstall SmartSDR, reboot, reinstall SmartCAT, reboot, and set up my ports again.

It didn't take very long, but was frustrating to figure it out.

If you are having trouble getting SmartCAT to work... Follow this procedure and it should begin working again.

Apparently the upgrade to Win 8.1 messed up some of the configuration files in the registry.

Good luck.
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 3971 Posts
  • 1226 Reply Likes

Posted 5 years ago

  • 1
Photo of Neal - K3NC

Neal - K3NC, Elmer

  • 438 Posts
  • 130 Reply Likes
Sadly, the 8->8.1 migration is as random as the 7->8 and others before it.

It obviously plays with the system registry so programs with registration keys held in the registry will appear to be incorrectly installed, etc. I have also found some things programmatically that used to work on 8 and blows in 8.1 (things like calling the file browsing control logic.

So, when things don't appear to be working after you install 8.1, I would suggest you uninstall (if you can) and then reinstall.

73
Photo of Greg

Greg

  • 656 Posts
  • 63 Reply Likes
The only problem I have heard of so far with 8.1 is that the update process reassigns COM ports. I think if you remove your virtual ports and reset them you will be OK.

73
Greg
Photo of Marten - VE2WU

Marten - VE2WU

  • 4 Posts
  • 1 Reply Like
If this still doesn't work for you, try uninstalling both the Smart SDR and SmartSDR CAT programs, reboot and reinstall SmartSDR and setup SmartSDR CAT.
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 3971 Posts
  • 1226 Reply Likes
I may not have been clear. I got it working, it just took a while and uninstalling/reinstalling of software to do it. Everything is OK now, except I needed to shrink my default font/display size to make it fit. Win 8.1 makes changes to display settings.

This conversation is no longer open for comments or replies.