Unhandled error (Non-UI) - seems Flexcontrol related

  • 1
  • Problem
  • Updated 4 years ago
  • Acknowledged
  • (Edited)
I have a new Flex-6300 that works extremely well, and today I encountered my first glitch. I'm running SmartSDR 1.3.8 under Windows 7 Ultimate on an Intel quad core with 8GB RAM. While operating on 10m SSB this evening I got the Unhandled Error exception shown below. It seems related to the FlexControl which I have had for quite some time - I used it on my old Flex-1500 and more recently with DDUtil on my ANAN-10. It seems to work fine on the 6300. It's on COM2, and I have real hardware COM ports on 3 and 4. (My computer does not have COM ports on COM1 or COM2, so assigning COM2 to the Flexcontrol has never been an issue before.) The rest of my COM ports are Flex Virtual Ports starting at COM13. After I clicked OK to clear the exception SmartSDR stopped. Restarting SmartSDR restored normal operation, and I have not been able to make it fail again in limited testing. Has anyone seen this same error?
73,
Doug K4DSP

Photo of Doug Hall

Doug Hall

  • 187 Posts
  • 54 Reply Likes

Posted 4 years ago

  • 1
Photo of Jay / NO5J

Jay / NO5J

  • 1514 Posts
  • 222 Reply Likes
I used to see that once in a while. I think it might have been DDUtil and SmartSDR fighting over the FlexControl, But I also moved the Flexcontrol's Port to port 99. Windows sometimes renumbers/rearranges the assignments of the ports. explained a bit at ...
 https://helpdesk.flexradio.com/hc/en-us/articles/202479329-How-to-Change-the-Com-Port-Assignment-for-a-FlexControl 
hasn't done it for a while so I can't be certain if that fixed it or If it was something else going on. The PC has front panel USB connections that get things plugged and replugged into them but the FlexControl has it's own jack on the backside and never gets unplugged.

And restarting SmartSDR usually is all that needs to be done. that or rebooting the PC too. Nice of Microsoft explaining it all in precise terms isn't it. I wonder if Microsoft speaks Klingon too?

73, Jay - NO5J
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9148 Posts
  • 3466 Reply Likes
Doug - the error is FlexControl related.  It received bad data when it queried the firmware loading on the FlexControl.  Since you have not seen it again, I suspect it was a glitch receiving data over the USB emulated com port interface.  If it starts happening with any regularity, open up a HelpDesk ticket and we'll see what is going on.