system boot - "Select a Version"

  • 2
  • Question
  • Updated 2 months ago
  • Answered
  • (Edited)
When booting up the 6400M, the user eventually arrives at a screen that displays three soft buttons: Info/Connect/SmartLink Setup.  After selecting "Connect", I am asked to select from either of two pieces of firmware, v2.1.32, or v.2.1.30.

Is there a way to configure the radio to make the latest downloaded firmware several as the default so that when I press "connect" the radio will automatically load latest available firmware rather than having to manually select from multiple versions of firmware?
Photo of W8QB

W8QB

  • 75 Posts
  • 12 Reply Likes

Posted 2 months ago

  • 2
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 8698 Posts
  • 3268 Reply Likes
Official Response
There is logic in the software to auto start the software that runs on the M models (as well as on the Maestros) if certain conditions are met, like not connecting to the radio with a different client, a new version of software is not available, connecting to the same radio (which is always met with an M model), and a few other operational "state" conditions.

If the M model is the only radio on your network and you are not using a different GUI client (Maestro, SSDR Win, SSDR iOs, dogparkSDR) to connect to it and you constantly have to select the latest version of the software (v2.1.32 as of this writing), then there may be something amiss in the logic that is supposed to perform this function.