SmartSDR.xml now Slice A/B specific?

  • 1
  • Question
  • Updated 3 years ago
I have FLDIGI working with my Flex 6300 with the help of this forum .  From what I can find, the rig control xml files are now specific for Slice A and Slice B.  The general SmartSDR.xml file apparently no longer exists.  With the slice specific files found at http://www.w1hkj.com/xmlarchives.html  I cannot figure out how to make FLDIGI TX on a TX Slice other than A or B, but not both.

In my setup, I have "SmartSDR-SliceA.xml" loaded in RigCat.  If I have Slice B designated as TX for instance for split operations, when FLDIGI transmits, it reverts back to Slice A.

I'm either missing something obvious, or I need a copy of SmartSDR.xml without a slice specified to make FLDIGI transmit on the slice I choose.

Help?
Photo of Mike Sonn

Mike Sonn

  • 46 Posts
  • 5 Reply Likes

Posted 3 years ago

  • 1
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4074 Posts
  • 1267 Reply Likes
Check your CAT com channel properties. You may have the designator set to automatically switch to VFO 'A'. Turn off the auto-switch button in SDR CAT for that COM port.
Photo of Mike Sonn

Mike Sonn

  • 46 Posts
  • 5 Reply Likes
Thanks Ken, I did change the COM ports in CAT to not "auto-switch", but its still doing it. I'm going to shut down and reboot o see if that helps anything.

I was pretty comfortable around PowerSDR, but SSDR has many settings in completely different locations.

For future info, in what case would I want that CAT COM port to auto-switch TX? Any ideas?
(Edited)
Photo of Ken - NM9P

Ken - NM9P, Elmer

  • 4074 Posts
  • 1267 Reply Likes
If you have multiple slices open on multiple frequencies, perhaps even with different digital programs running at the same time, you can monitor different channels simultaneously and when you respond to one, it will automatically switch to the correct slice depending upon which program you are using.  It will also change antennas, tune the antenna from ATU memory, as it moves to the correct frequency.  I haven't done this much, it is pretty mind-boggling.  But I have used it when running A/B split on RTTY contacts in order to force the rig always to transmit RTTY on the slice B, avoiding accidentally transmitting on the DX's frequency on slice A.  It was a nice way to "idiot proof" or "lid-proof" my DX hunting operation.

Ken - NM9P
Photo of Mike Sonn

Mike Sonn

  • 46 Posts
  • 5 Reply Likes
This seems so simple, but in practice, I'm banging my head against the wall.  According to Smart AT User Guide:  "When ENABLED, Auto Switch TX Slice will automatically switch the Transmit Slice to the VFO A Slice selected above (shows picture of Edit CAT Port details) when a CAT TX command is sent to the COM port.....If this option is not enabled, the operator will have to manually select the Transmit Slice".

I've gone through and Disabled and then Enabled the  "Auto Switch TX Slice"  on everything created in SmartSDR.  Auto-Switch TX slice doesn't seem to do anything...

Here's what I have as indicated in SmartCAT for COM Ports -
CAT - Slice A; 10 & 12
CAT - Slice B; 9 & 11
PTT Ports - 7 & 8

When FLDIGI RigCAT is set to COM 10 or 12 - Slice A is ALWAYS the TX slice.
If set to COM 9 or 11, Slice B is ALWAYS the TX slice.  As soon as I initialize the port in FLDIGI, the TX changes to the selected SmartCAT port"s "Slice" designation.  If I only have Slice A open in SSDR, and a Slice B Port is selected as my COM port in FLDIGI, there is no TX.

My PTT is port 7 on FLDIGI.

The frequency readout in FLDIGI follows the CAT Port's indicated Slice the TX slice, regardless of the slice selected for TX in SmartSDR.  As soon as I transmit in FLDIGI, TX switches to whatever Slice the selected COM port indicates it serves.

So, for simplex communications, all is well and FLDIGI works as it should.

When operating split right now, I have to manually go into FLDIGI's Rig Control setup and choose the appropriate COM port for my 'Slice B" frequency, which, as noted above, also changes FLDIGI's frequency readout, to the B Slice frequency.

Does that help?

Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9153 Posts
  • 3497 Reply Likes
Mike - I suspect you are using old RigCAT files.  When CAT changed for release 1.6, we provided new RigCAT file for each slice.  The old slice B RigCAT file will not work properly because Fldigi does not have a "split" mode that tells the radio how to use the file.

Download the new RigCAT files.