SmartLink Relocation

  • 1
  • Question
  • Updated 2 years ago
  • Answered

If one is moving one's FlexRadio, that is already registered (at home), to a different location (club), and presuming the clubs router responds to UPnP, do you just move it and turn it on.

Or, must you access it locally at the new location, de-register the radio and then re-register the radio, so the cloud servers know it's new location (IP address)?

Photo of Brent Parker

Brent Parker

  • 93 Posts
  • 12 Reply Likes

Posted 2 years ago

  • 1
Photo of NX6D Dave

NX6D Dave

  • 314 Posts
  • 96 Reply Likes
It needs to be unregistered and then registered at the new location.  When you move the radio, it is going to be seen as running under a different IP address and possibly port number.  That information has to be refreshed, if you are going to use SmartLink.

At the new location you may not have UPnP available, so you may have to set up port forwarding manually.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9198 Posts
  • 3558 Reply Likes
I am afraid this comment is incorrect.  See below for details.
Photo of NX6D Dave

NX6D Dave

  • 314 Posts
  • 96 Reply Likes
S'ok, I don't bat 1000 either.
Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9198 Posts
  • 3558 Reply Likes
:-)
Photo of Brent Parker

Brent Parker

  • 93 Posts
  • 12 Reply Likes

Thanks Dave,

I suspected as much. Just didn't know if it was dynamic, like some ddns services, of if it was a one time "set it". As you have to click the mic, for security, I suspected it was de-register and re-register process.

Yea, I've done the manual router thing, as I have two radios and a commercial type router that does not do the UpnP service.

Thanks Again,

Photo of Mike va3mw

Mike va3mw

  • 824 Posts
  • 199 Reply Likes
I 'think' you just need to power cycle the radio.  There is no need to re-register the radio as long as you log in on the same SL account.  I'll leave some room for Tim to correct me if I am wrong.

The reason I say this is that over the weekend, I had a total and 100% firewall meltdown requiring it to be rebuilt from scratch.  During that period, my WAN IP address changed.

Essentially SL came back online the next time I powercycled the radio.

If you un-register, then you will need to PTT register again.

Mike va3mw
Photo of NX6D Dave

NX6D Dave

  • 314 Posts
  • 96 Reply Likes
That could be.  It may be that the radio checks in with the server at startup, and if the IP address is different, it is simply updated in the server.  However, if the external port numbers were changed and UPnP were not being used, the radio probably wouldn't know about that, so it would probably be necessary to update the port numbers on the config screen and "save" them again.  Very little has been said about the details of this algorithm, so we're discovering them one at a time.
Photo of Brent Parker

Brent Parker

  • 93 Posts
  • 12 Reply Likes

Interesting Mike.

I'm going to take the radio over to a club on Friday. I'll fire it up there and see if it works first, before I de-register and post it back here.

73  Brent W8XG

Photo of Tim - W4TME

Tim - W4TME, Customer Experience Manager

  • 9198 Posts
  • 3558 Reply Likes
Official Response
Brent - a radio is registered with a SmartLink account and that is independent of where it is located geographically.  However, there is a radio network configuration concern that has to be taken into account.

When the radio is moved to a different location and powered up, the radio, assuming that the router configuration is the same (UPnP or static port forwarding), the radio will contact the SmartLink server and inform it of its new public IP address, port information and you are good to go.

Now if the router's network configuration at the new location is different from that of the original location, then once you log in to your SmartLink account using a client on the local LAN, you will need to change the network configuration on the radio to match the new router's configuration.

So in your example you proposed, you would not have to re-register the radio or change the network configuration because the original and new router are both UPnP configured.

I'd bring a lap top with SmartSDR loaded on it to the club just in case you need to change the radio's network configuration.
(Edited)
Photo of Rick - W5FCX

Rick - W5FCX

  • 287 Posts
  • 77 Reply Likes
I'm running into a similar issue.  I decided to swap the locations of my 6300 and 6700.  SmartLink client's are showing one set of UDP/TCP ports for connecting (to correct IP), yet the UPnP ports being defined for NAT rules in the firewall don't match.  This appears to be preventing traffic from passing. 

What iOS SmartLink clients show on both iPhone and iPad:

UDP:  21993   TCP:  21994

What is shown in modem NAT as a result of 6700 registration via uPnP:




I suppose I could manually remap the ports to what SmartLink says they should be externally, but based on this post that shouldn't be required at all.  What's wrong?

Rick
(Edited)
Photo of Rick - W5FCX

Rick - W5FCX

  • 287 Posts
  • 77 Reply Likes
I added the manual remappings and now it works.  Something is amiss in SmartLink not recognizing that the radio ports changed or not correctly following the UPnP settings created in the router/firewall by the 6700.

Here's the new mappings (i added the ones marked "custom").


Don't know why the router re-ranged the target ports (another bug probably because that's not what I entered, but it's working)

Looks like a bug in 2.0.19 (didn't see this issue before upgrading from 2.0.17 to .19)
Rick, W5FCX
(Edited)
Photo of Rick - W5FCX

Rick - W5FCX

  • 287 Posts
  • 77 Reply Likes
Alright.  This was my fault and not a bug...  At some point I had changed the settings on SmartLink Setup (in Windows) from Auto mode to Manual mode, which is why the automatically chosen settings did not work.  That's now fixed.

This conversation is no longer open for comments or replies.