SmartCAT Unhandled Critical Error

  • 1
  • Problem
  • Updated 3 years ago
I'm running the most recent version of SmartSDR/CAT and DAX on WIn 7 computer. I began to experience problems with CAT ports for other devices and software. I spent an entire day on it and finally, after attempting to do a repair on SmartCAT following Tim's suggested procedure I got the long "Unhandled Critical Error" message. I also removed ghost ports but that didn't seem to help. I've tired to narrow it down by first turning on peripherals before booting Win 7 and visa versa but it seems difficult to predict and it's gotten worse. I did take a screen shot of the critical error message which is foreign tongue to me and no way to attach the file here. Has anyone experienced this problem and is there any resolution short of deleting SmartSDR and all related files and reinstalling everything? This started when I wanted to establish CAT connection for another radio by a different manufacturer. 
Photo of Rick

Rick

  • 160 Posts
  • 21 Reply Likes
  • A bit frustrated as this problem has gone on for a while unresolved

Posted 3 years ago

  • 1
Photo of Mark - WS7M

Mark - WS7M

  • 1294 Posts
  • 491 Reply Likes
Hi Rick,

I don't run Win7 much anymore.  Generally, if an error suddenly begins to appear I suspect something recent changed such as a recent install of some software or perhaps (unlikely with Win7) an update?

I don't have the best suggestions but sometimes a fresh install is the best.  I also would not rule out a hardware issue.  While rare and unlikely bad RAM can cause erratic behavior.

Mark - WS7M
Photo of Rick

Rick

  • 160 Posts
  • 21 Reply Likes
Thanks Mark. I fear that once again I'll have to strip off all smartsdr software and do a clean install. Unfortunately I've had to do this at least once before over the years.
Photo of Andrew O'Brien

Andrew O'Brien

  • 384 Posts
  • 44 Reply Likes
The only thing I can say about this is that before I owned a Flex I used a Kenwood and a Microkeyer with their device router.  Then I added a Flex 3000 and installed VSPM.  The virtual ports created by VSPM did not like the presence of the virtual ports Microkeyer created and caused various issues.  I had to dump one of them. I suspect you are running in to the same type of conflicts between your other devices and SmartCAT ports. 
Andy K3UK
Photo of Rick

Rick

  • 160 Posts
  • 21 Reply Likes
Yup....and I use Virtual Serial Port Emulator. I've disabled it while trying to trouble shoot the problem but haven't gotten to the bottom of it yet. Probably need to do an uninstall and reinstall. I'm getting tired of doing that periodically. TNX 73
Photo of Andrew O'Brien

Andrew O'Brien

  • 384 Posts
  • 44 Reply Likes
In fact, it may have been VSPE that I had issues with, not VSPM.